Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network problem - can't join homegroup

28 Jul 2015   #1

Windows 7 Professional 64bit
Network problem - can't join homegroup

Hi guys. Since I reinstalled my Windows I can't join the homegroup and have problem accessing another pc in the network. Before the reinstall everything worked great.

More detailed:
1. When I try joining the homegroup, I get the error message: "Windows can’t join homegroup on this computer."

2. And when I try to access one PC (lets call it otherPC) via the windows explorer (also Windows 7, but Home Premium) I get following error message: "\\otherPC is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Logon failure: the user has not been granted the requested logon type at this computer."

3. Another computer (windows 10 Insider Preview) just asks for logon data when I try to access it via windows explorer. I guess this is the normal case.

4.The Windows 10 computer was able to join the homegroup and can access the otherPC, and when trying to access my PC it gets the popup for logon information just like in 3.

5. When I try to access my PC from the otherPC via the windows explorer, that it takes a moment and then also pop up the logon window.

I have been at it for hours and don't know what to do about.

Things I tried:
- restarting internet box, all computers are connected over it
- making sure TCPIP6 is activated (DisabledComponents = 0 in registry)
- disabling Kaspersky Internet Security on both PCs (although Windows 10 computer had no problem with it)
- checked following services if they are started:
DNS Client
Function Discovery Provider Host
Function Discovery Resource Publication
HomeGroup Listener
HomeGroup Provider
Network List Service
Peer Networking Grouping
SSDP Discovery
UPnP Device Host
- renaming idstore.sst to idstore.old.sst so i gets created new again (althoug I left file be)
- MicrosoftFixit.HomeGroup.Run.exe doesn't work anymore
- both computers in same workgroup
- homenetwork chosen for active network

It's possible I left something out, but I read and tried so much I lost count.

Hope you can help me out and many thanks in advance.

My System SpecsSystem Spec
28 Jul 2015   #2

Windows 7 Ultimate x64 SP1

See Homegroup - Add Computer or Join to make sure all is good.

Also Logon failure: the user has not been granted the requested logon - Microsoft Community

Do you have Guest enabled? Password protected sharing?
My System SpecsSystem Spec
29 Jul 2015   #3

Windows 7 Professional 64bit

OK, I did check everything again according to the first link. Everything is fine.

Regarding second link: tried the mentioned settings on my pc and simultaniously on the windows 10 PC and was able to get access without name and password, but that didn't help with the homegroup and is a security risk. Since everybody can get access. But will try with the otherPC later on. Can't access it right now.

With Guest enabled, do mean the windows user account? If yes, then no it's disabled.

Had password protected sharing disabled for the second link, but it's enabled again, because of the risk.
My System SpecsSystem Spec

29 Jul 2015   #4

Windows 7 Ultimate x64 SP1

Yes, turning it off is not ideal. Did you check Group Policy setting described in the answer on the PC you are trying to access? Gpedit is available on pro and above.
My System SpecsSystem Spec
29 Jul 2015   #5

Windows 7 Professional 64bit

I'm the only one with a pro edition, but I managed to fix it. I left the group with all the PCs and then created a new one on my PC. Everyone could join the new group so all is good again :)
I can also access the PCs via the network tab in windows explorer. So problems fixed. :)

Thanks again.
My System SpecsSystem Spec

 Network problem - can't join homegroup

Thread Tools

Similar help and support threads
Thread Forum
Unable to join homegroup, homegroup creating computer is no more
The computer that originally created the homegroup on my network is no more. It seems that because of this that my new computer is unavailable to join the homegroup that already exists. Other computers that were part of the homegroup before the "host" computer died are still part of the homegroup...
Network & Sharing
Can't join homegroup - problem and solution
I was unable to join a Homegroup on my netbook, and found no help anywhere, but stumbled on a solution on my own. Here is what fixed my homegroup problem. Go to Control Panel and click on Adminstrative Tools Scroll down and click on Services Scroll down and right click on Homegroup...
Network & Sharing
Home network set but Win 7 says can't join homegroup, no home network
Situation- 5 month old Dell XPS 8500 Win 7 64 bit Pro as main computer connected by Wired Adapter, Upgraded Gateway 5632E also running Win 7 64 bit pro as second connected by Wireless. Both running Kapersky successfully. no network problems for 5 mo. Both were successfully linked using...
Network & Sharing
Homegroup problems - Homegroup detected, can't join. @wit's end
I have a desktop that is connected to my Belkin router via wire. I have 3 laptops that are all connected to the router wirelessly. All computers have Windows 7 64bit and synched clocks. All are connected to a Home network. All 3 laptops detect that a Homegroup has been created on the wired...
Network & Sharing
Homegroup encountered an error / This computer cannot join a homegroup
I get a "Homegroup encountered an error" message when I try to join my laptop and desktop to a homegroup. It does not matter which one sets it up and which one tries to join. It errors in either direction. I have tried leaving and creating, no use. The desktop is wired to a Belkin 300N router and...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:49.
Twitter Facebook Google+