Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Strange WiFi Network/Printer Problem

30 Aug 2015   #1

Windows 7 Home Premium SP1 64-bit
Strange WiFi Network/Printer Problem

Dear All,

First post here and in need of some help. Following problem has been driving me crazy for the past 2 days and I'm no closer to an understanding/resolution.

The following is quite an exhaustive and (I hope) logical description of the problem....

I have 4 WiFi computers and 3 WiFi printers - 1 Samsung M2070W Laser printer and 2 Canon Pixma MG5250 inkjet printers.

2 computers on my WiFi network print fine to all three printers.

2 other computers (one a desktop and one a laptop) which are both running Windows 7 Home Premium SP1, 64-bit, cannot print to the Samsung or either of the Canon printers.

All computers could print to all printers last week before I replaced my wireless router (I had a Netgear DGN2200 and have replaced it with an ASUS DSL-AC68U). Now, after this upgrade 2 PCs can still print to all printers and 2 cannot.

I have checked that all of the computers are on the same WiFi network and all have the same encryption key (using WPA2-PSK encryption).

The network configuration page from the MG5250 says that Bonjour is enabled but the Bonjour LPR Service is disabled. Is this important? it seems not as 2 of my computers can print OK.

I can successfully ping all of the printers from both PCs that cannot print to a printer - the printer IPs are, and My router's IP is and subnet mask - so that seems to be OK.

I have reinstalled the printer driver for both Canon printers using the latest drivers on the Canon website (Version 1.05, released 22 July 2015) on both problem machines and I still can't print to any Canon printer over WiFi. I have also re-installed (though what a pain that was) the printer driver for the Samsung Laser printer.

Also, once a document has been sent to a printer and stalls, opening an elevated command prompt and stopping and restarting the print spooler service ('net stop spooler' / 'net start spooler') also has NO effect and the document still won't print. However, on one of the two non-printing PCs, starting and stopping the print spooler service will allow the Samsung Laser printer to print the document - but I have to do this for each document I send.

Just to confuse matters even further - I tried scanning a document from both Canon Printers to all 4 WiFi computers - to see if data could be sent from the printers to the computers, and both documents were received by all 4 WiFi computers.

This surely points to the fact that the Canon printers are correctly connected to the WiFi network correctly and that the problem lies within both of the PCs that cannot print.

The Samsung printer will send a scan to the two PCs that can print to it, it (apparently) sends a scan to a third (but there is no error but I can't find the scanned document anywhere) and the fourth PC it apparently can't see!

I am currently checking which services are running on all 4 PCs in an attempt to see if the problem is in a service or services that is/are disabled or stopped.

Any help or advice would be greatly appreciated.

Thanks for reading the above and sorry for the short novel!

Thanks in aticipation,


My System SpecsSystem Spec
30 Aug 2015   #2

Windows 7 Ultimate x64 SP1

Is this a HomeGroup or Workgroup network? Did you check Network Location? Network Location - Set as Home, Work, or Public Network

Did the network ID change while changing routers? Was it with the previous router too?

These are some of the networking services that are required, the last few ones are for HomeGroup:
- Computer Browser
- DHCP Client
- DNS Client
- Network Connections
- Network Location Awareness
- Remote Procedure Call (RPC)
- Server
- TCP/IP Netbios helper
- Workstation
- IPSec
-- Start one by one if above doesn't help
- Homegroup Listener
- Homegroup Provider
- SSDP Discovery
- UPnP Device Host
My System SpecsSystem Spec
30 Aug 2015   #3

Windows 7 Home Premium SP1 64-bit

Hi GokAy

Thanks for the swift reply.

I suspect it may be a Homegroup problelem. One of the machines (Win 7 HP SP1 64-bit) that can print to all printers belongs to a homegroup and I have the password/key from that machine.

The other machine that can print to all printers is a Windows 10 Home 64-bit machine but I don't know if it is in a homegroup or not.

On one of the machines that can't print (a desktop running Win 7 HP SP1 64-bit), says that it belongs to a homegroup - but the password/key is different from my other machine.

If I click on Control Panel > Homegroup I have various options - such as view or print the homegroup password/change password/leave the homegroup/change advanced sharing settings/start the troubleshooter - but I don't get an option to join a specific homegroup.

In truth, Homegroups seem to be a bit of a mystery - which is why I suspect this is where the trouble might lie. What puzzles me is that everything was fine until I swapped the router over. Incidentally, the Netgear router's default gateway was and the new Asus router's is I have entered the new SSID and WPA2 keys into all 3 printers - which is why 2 of the 4 compuers can print and scan over the WiFi network.

I am currently systematically writing down (it is taking a while) all of the Serices on each of the 4 machines in order to compare the differences in the services which are running on the machines which can print and on those that can't.

It is 23:50 here in the UK at the moment and I won't be able to reply for the next 18 hours at least as I am away from home for most of tomorrow.

Once again, many thanks for the time you have already spent on my problem and your help so far.

My System SpecsSystem Spec

30 Aug 2015   #4

Windows 7 Ultimate x64 SP1

Well, ok :) I had a similar issue in my friend's shop and fixed it by:
- leaving HomeGroup on both machines (Win7 and Win8.1) - Homegroup - Leave
- created a new HomeGroup on one machine - Homegroup - Create
- join the new HomeGroup with the other PC - Homegroup - Add Computer or Join
- share the printer with the HomeGroup - Homegroup - Change File and Folder Sharing Settings
My System SpecsSystem Spec
31 Aug 2015   #5

Windows 7 Home Premium SP1 64-bit

Hello again!

Just a quick reply before I set out.

What puzzles me is that everything was fine until I swapped the router over last week.

Also, are you aware of any issues/conflict with Bitdefender Internet Security 2015 and Homegroups in Win 7? I ask because I suddenly realised that both machines that can't print have Bitdefender installed whilst the other two machines (which can print) have Avast Free on them.

Could a change of router suddenly cause a homegroup/antivirus issue??

My System SpecsSystem Spec
31 Aug 2015   #6

Windows 7 Home Premium SP1 64-bit

Hi Gokay

Here are the preliminary results for three of the 4 WiFi computers...

Services for all 4 WiFi machines.

Those marked (*) can't connect to the printers

In order: Toshiba / DELL / VAIO* / Zoostorm*

Computer Browser N/A Dell M(s) M(s)
DHCP Client A(s) Dell A(s) A(s)
DNS Client A(s) Dell A(s) A(s)
Network Connections M(s) Dell M(s) M(s)
Network Location Awareness A(s) Dell A(s) A(s)
Remote Procedure Call (RPC) A(s) Dell A(s) A(s)
Server A(s) Dell A(s) A(s)
TCP/IP Netbios helper A(s) Dell A(s) A(s)
Workstation A(s) Dell A(s) A(s)
IPSec M Dell M(s) M(s)

- Start one by one if above doesn't help

Homegroup Listener M(s) Dell M M(s)
Homegroup Provider M(s) Dell M M(s)
SSDP Discovery M(s) Dell M(s) M(s)
UPnP Device Host M(s) Dell M(s) M(s)

I hope the above helps. M = Manual, A = Automatic, (s) = Started, N/A = Not Available (not there). Dell indicates the Win 10 machine I haven't looked at yet.

The only machine that I haven't checked the services on yet is the DELL - which is running Windows 10 Home 64-bit - all other machines are rinning Windows 7 SP1 Home Premium 64-bit.

Looks like the Zoostorm (which has the same configuration as the Toshiba) should be able to print based on the services running - but it can't.

Incidentally, going back to the Homegroup issue for a sec, how can I see what homegroup a PC is in (I'm guessing here that Homegroup is like Workgroup as in you can have different groups just like you can have different networks?)


My System SpecsSystem Spec
31 Aug 2015   #7

Windows 7 Ultimate x64 SP1

Answering HomeGroups; it is my understanding that once a HomeGroup is detected you can't create another one. You either join it or have to turn off the other PCs with HomeGroups.

The IPs for printers are scattered, are those static IPs? How about the PCs?
My System SpecsSystem Spec
01 Sep 2015   #8

Windows 7 Home Premium SP1 64-bit

Hi GokAy

All devices are assigned IPs from the router via DHCP. Whilst I know that that isn't the best for network devices (like printers), it hasn't been a problem up to now (my old Netgear Router used to assign IPs like rather than the Asus Router which is setting IPs like and!)

Below is a result of the investigation into the services running on all 4 WiFi computers (if I can post a picture that is):

All necessary services seem to be running on the compters that can't print over the WiFi network.

Any further help much appreciated.

Zaph : )
My System SpecsSystem Spec
01 Sep 2015   #9

Windows 7 Home Premium SP1 64-bit

Hi GokAy

I've finally managed to sort the problem out - and it was nothing to do with Homegroups, Workgroups or Services.

Searching on the internet for keywords 'Bitdefender' and 'Homegroup' I came across several posts where folks have reported issues with the Bitdefender IS 2015 Firewall.

After a few tests, I nailed the problem by setting the Bitdefender Firewall to 'OFF' and Windows Firewall to 'ON'. All four WiFi computers can print to all 3 WiFi printers - and receive scans from them.

I must admit that the fact that the two computers that COULD print had a different anti-virus from the ones that COULDN'T (see post #5) first occurred to me several days ago, but because the problem arose so soon after swapping my router over, I thought that that was where the problem lay. I now suspect that an update to Bitdefender (which I do almost every day for AV signatures) may have been the issue.

I've been tearing my hair out for 2 1/2 days only to find that something I though of on Day 1 was the cause - I just headed off on a different track to start with.

Many thanks for taking your time to try to solve my problem and for your advice. It is very much appreciated.

Kind regards

My System SpecsSystem Spec
01 Sep 2015   #10

Windows 7 Ultimate x64 SP1

Ah hehe, I guess it was Bitdefender Firewall not trusting the new network. Good to hear it is sorted, well done :)
My System SpecsSystem Spec

 Strange WiFi Network/Printer Problem

Thread Tools

Similar help and support threads
Thread Forum
HomeGroup and wifi Home Network printer incompatability?
Hi all, New to Win 7 and have for the past couple of days been searching all over the WWW for answers and solutions to the following. I have been on countless discussion boards and tried everything that has been suggested, but I am no closer to finding solutions. 1) I am the only person in my...
Network & Sharing
Very strange problem connecting to network drives / network.
So im at a complete loss here.... I have a windows 7 pro x86 computer that out of the blue stopped connecting to its network drives. I tried a few things like flushing the dns, re-registering, new IP finally I decided to rejoin it to the domain, big mistake. The computer couldn't contact the...
Network & Sharing
Strange network problem
Hi, This is about a friend's computer and a strange networking problem. It's running Windows 7 Starter x86. He told me that whenever he connected his PC to the home network through a network cable it would hang up. That's all I knew. I took it home and connected it to my network...
Network & Sharing
Wireless not working after trying to add HP Printer to wifi network
So I have wireless internet in my house through an xfinity cable/internet modem. While I was trying to set up my new printer on the wireless network, my wireless stopped working. My computer is showing it has a full signal from my wireless network, however it unable to connect. Also, if I connect...
Network & Sharing
Problem with mapping network location - network printer
Hello! I added a printer to my network (hp c5180) via ethernet cable. But problem accords when I try to map a network location (card reader 5in1 or sth like that, is used to read SD, xD, ms cards used in cameras) from which I d like to copy images, files in explorer without extra software from...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:48.
Twitter Facebook Google+