Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Homegroup

12 Nov 2009   #1


I have just upgraded a second machine to win7 on my little home network.
It immediately offered me the chance to start a homegroup. So I did.
But the machine I upgraded first can't join it. It says I have to install IPv6 first.
But IPv6 is running.
I can see shared files and folders across the network.

My System SpecsSystem Spec
12 Nov 2009   #2

7600.20510 x86

Go to Network and Sharing Center. Click on local area connection, then click properties. Is there a check next to Internet Protocol Version 6 (TCP/IPv6)?

If not, put one there and click ok.
My System SpecsSystem Spec
12 Nov 2009   #3

Yes maybe

The IPv6 is ticked. But I notice that in the "general" tab it says "no network connection" for IPv6.
And on the "advanced" section it has only IPv4 references.

Attached Images
My System SpecsSystem Spec

12 Nov 2009   #4

Win 7 x 64

i have the same problem with my win7x64. and also my network wont show under "My computer" - "network".
My System SpecsSystem Spec
12 Nov 2009   #5

Windows 7 Pro X64

Turn off any antivirus software you have running before you try again, most AV programs have not been updated to allow for MS,s new network connection methods.
You may find that when you turn your AV back on you'll loose conectivity again.
My System SpecsSystem Spec
13 Nov 2009   #6


It detected the other computer on the Homegroup. But still insists that IPv6 isn't enabled soit can't connect.
It also thinks that I have Comodo firewall running, which I don't! It's not even on my machine. I use Windows firewall!
My System SpecsSystem Spec
13 Nov 2009   #7

Windows 7 Ultimate x64 SP1

Did you do an in-place upgrade, or did you do a clean install of 7? If you did an in-place upgrade, did you happen to have Comodo installed (or any other third party security suite)?
My System SpecsSystem Spec
13 Nov 2009   #8


It was in-place upgrade - but Comodo wasn't on the system pior.It still isn't on the system.
I did have it,once. A while ago.
But not now.

I've searched the registry and can fnd no trace.
I've been through the computer, by searching and manually. There is no trace.
I use ccleaner and Glary Utilities.
It doesn't appear as a service.
It doesn't appear in any startup location.
I assume there's a binary that references it in some magical way.
And that still doesn't mean that that is what's casuing this problem.
i.e. that IPv6 is running and Windows doesn't believe that it is.

I have ad-aware and Avast installed. I treid disabling Avast, as noted already.
I'll try turning off Windows firewall, but I dont expect that to make any difference.

I'm so mystified.
My System SpecsSystem Spec
13 Nov 2009   #9

7600.20510 x86

Quote   Quote: Originally Posted by tbernstein View Post
It was in-place upgrade - but Comodo wasn't on the system pior.It still isn't on the system.
I did have it,once. A while ago.
But not now.
I am a huge fan of upgrades but a system has to be in mint condition to begin with for it to be successful.

Best thing here in this case is a clean install right on top of where Windows is now. The installer will place everything currently there into a Windows.old folder at root, so you will not lose a single file.

Just do not format anything and you'll be fine.
My System SpecsSystem Spec
13 Nov 2009   #10


Yes, I did think of that.
It's a cost benefit analysis.
I may be able to get the homegroup working, which won't give me a lot more than I already have through conventional networking. It'd be nice though.
1.) I'd have to reinstall all the software, including MS Money, which would need a download of an essential patch, which I can't get cos MS don't support it anymore.
2.) My wife would kill me
3.) It still might not work
4.) It's much more satisfying to find a solution.
My System SpecsSystem Spec


Thread Tools

Similar help and support threads
Thread Forum
Unable to join homegroup, homegroup creating computer is no more
The computer that originally created the homegroup on my network is no more. It seems that because of this that my new computer is unavailable to join the homegroup that already exists. Other computers that were part of the homegroup before the "host" computer died are still part of the homegroup...
Network & Sharing
Windows 7 Control Panel Homegroup not revealing Homegroup Password
I installed Windows 7 on my laptop, and I also have a desktop running Windows 7. I am trying to connect my laptop to my homegroup with the password for my homegroup, but my desktop will not reveal it. Is there any other place that I can find it? Thanks in advance for your help. theAdmiral
Network & Sharing
Help with HomeGroup Issues, cannot detect other computers on homegroup
Hi ppl, My home network has 4 computers(including mine) running windows 7, and all of them are connected to the same router/access point for internet connection. When I created a homegroup, and went to add the other computers, they created another homegroup and the other 3 computers are now in...
Network & Sharing
Homegroup encountered an error / This computer cannot join a homegroup
I get a "Homegroup encountered an error" message when I try to join my laptop and desktop to a homegroup. It does not matter which one sets it up and which one tries to join. It errors in either direction. I have tried leaving and creating, no use. The desktop is wired to a Belkin 300N router and...
Network & Sharing
Con't get my wirelss Laptop homegroup to find my pc ethernet homegroup
Hello all, I have connected my pc to the Linksys Wireless-G 2.4GHz directly with an Ethernet cable and created a homegroup. I then connected my laptop to the linksys with a wireless connection which has a WPA Personal security key. I tried to connect the laptop to the homegroup but instead of...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App