Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wifi Connectivity Issue - IPV4 & IPV6 Not Connected

28 Dec 2015   #1

Windows Vista Business 32-BIT
Wifi Connectivity Issue - IPV4 & IPV6 Not Connected

Hello all! I hope I'm not breaking any rules by doing this, but I had an issue over the weekend where my PC wouldn't connect to the internet, and it took me hours to fix! I wanted to post what I did here in this forum since this popped up in the Google search most often so others can find it. Also I can't figure out how to put the SOLVED icon in the title, can an admin help? Thanks.

Some brief background; I'm running an old HP Compaq 6730s with Windows Vista Business 32-BIT that still runs pretty well. I decided to clean it up a bit and went and deleted a bunch of programs including Comodo Firewall, I'm inclined to believe my issue was caused by the sudden deletion of this program (maybe old setting still in effect causing a conflict, etc) but I'm not certain. After restarting my computer I could see networks in my area but could not fully connect to them. The windows diagnostic tool said it was either a hardware issue with my Intel Wifilink 5100 AGN or the IPV4 and IPV6 needed to be switch on. Which they already were.

The most prevalent things that I did that seemed to fix the issue in no particular order

1. Run scf/scannow through the Command Prompt window as an administrator.
2. Run a chain in Command Prompt 'netsh int ip reset' as a administrator.
2. Went to the Network & Sharing Center, Manage Connections and right-click on the primary wireless connection and go to properties.

Here I made sure both the IPv4 and IPv6 boxes were checked. I also went to the properties of each and made sure the options were set to auto-retrieve for the IP and DNS.

In the same properties dialog I noticed that there was a Comodo Firewall component of some sort which was checked. I unchecked and deleted that box! I attribute this as a primary offender of my issue since the program was deleted and therefore there should have been no component left in effect.

I also clicked on the install option and installed the only one that was offered there.

3. I downloaded the updates for my Intel Wifilink 5100 AGN from the HP website NOT the Intel website. The program that you download has a page of instructions with it but I basically downloaded, installed and ran the .exe to reinstall the drivers which updated my Wifilink driver from 13.5 to 14.0.

During this process if you have an Intel driver (or other driver manufacturer program) I would go to your Start Menu and search 'Intel Proset/Wireless Tool' and use the diagnostic feature. This will scan your Intel network related content and find conflictions which you can use for additional troubleshooting. Updating my drivers alone did not help, but it did resolve one issue the Intel Proset found as far as the version of driver I was using.

4. Lastly, and this was what FINALLY did it for me, I went to my Device Manager and right-clicked, properties of my primary wireless adapter Intel Wifilink 5100 AGN (the updated version 14.0), went to Driver Details and changed one of the options with a 2-digit input to 1 (mine of set to 11 and sorry I can't recall the name of the option but it's the only one with the option of entering 2-digits) and two other options in the list to '5.(highest) (there are only two components with this choice and I changed both to it).

I hope this helps save someone the process of buying a new wifi adapter or doing a clean install. Also I hope if this thread breaks any rules an admin will help me correct it, archive it or at least copy and paste some of these items that weren't suggested on this site (some were, some I can across on my own) in a stickied post. Cheers!

My System SpecsSystem Spec
28 Dec 2015   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Although you went to all that effort,
that explanation only relates to HP.
by the way that drivers out of date USE it on this lappy (Acer).
and i do not use the proset tool


Attached Thumbnails
Wifi Connectivity Issue - IPV4 & IPV6 Not Connected-wifi5100.png  
My System SpecsSystem Spec
28 Dec 2015   #3

Windows Vista Business 32-BIT

During my research to fix the issue I believe I saw many threads with others who weren't just using an HP, but in any event if it helps someone I'm satisfied.

Also now that I've got it working again I won't bother with installing any further drivers. But I do wonder why that 3rd party website has a driver version that HP and Intel does not?
My System SpecsSystem Spec


 Wifi Connectivity Issue - IPV4 & IPV6 Not Connected

Thread Tools

Similar help and support threads
Thread Forum
No network acesss, ipv4 and ipv6 not connected
Yesterday, my ethernet cable got pulled out of my laptop and I couldn't connect to the internet anymore. But on my desktop, it works perfectly fine. (I don't use wifi, if that information is also needed) I've researched several threads with similar situations, and I've tried different methods to...
Network & Sharing
Cable connected to modem, ipv6 no internet access ipv4 no network
Hello Guys, I've been searching for the past 2 days a solution, but nothing came up to work. Tried different things, nothing good yet. So I'm directly connected to a modem, cable, and well, my computer takes time to identify and then identifies it first a a public network (i was able to...
Network & Sharing
No Internet Connectivity (ipv4/ipv6)
Hello, My wifi was working fine a few days ago but i think the windows update has messed up my wifi adapter or connection. I did do a system restore when this happened a few days ago but since the restore is more then 1month old it is no more. Please can some1 fix it for me or guide me. So far...
Network & Sharing
Ipv4 and Ipv6 not connected no more internet access!!
Hello everyone. I recently had a sound problem on the internet in google chrome ( no sound at all although the system sound worked fine) I contacted tech guru to solve that problem. The guy installed shockewave and reinstall chrome on my pc and reboot my pc all remotly. At this stage my problem...
Network & Sharing
Windows 7 - No network acesss, ipv4 and ipv6 not connected
Hi, I am on an aspire one netbook and can no longer connect to the internet via wireless or a wired connection. I typed ipconfig/all in command prompt and all i got was..: Host name . . . . . . . .. . . . .: Primary Dns Suffix . . . . . . . : Node Type. . . . . . . . . . . . .: Broadcast IP...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:11.
Twitter Facebook Google+