Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network connection stuck at 100Mbps (Gigabit card installed)...

11 Jan 2016   #1

Windows 7 64Bit Pro
Network connection stuck at 100Mbps (Gigabit card installed)...

Hi all,

I cannot work out what could be causing a network card to only connect at 100mbps (full duplex).

The setup of the office is as follows:
WAN -> Router = 100Mbps Fibre
Router -> Switch = 1000Mbps port
Switch -> Patch Panel = Cat5e Cable (Switch port configured to Auto)
Patch Panel -> Floor Port = Cat5e Cable
Floor Port -> PC = Cat5e Cable but PC will only register 100Mbps

I have tried to set the PC to 1000Mbps Full Duplex through the NIC Properties page.
I have tried forcing the Switch to broadcast at 1000Mbps on the relevant port.
Either of the above just show no network connection when set to 1000Mbps.

I have tried changing the network cables.

I have disabled and re-enabled the NIC from the BIOS.

I have uninstalled the NIC driver from windows (inc. deleting the files) and then allowing windows to install the driver fresh, followed by a windows update for a newer driver version.

Despite all the above, the PC will not connect at 1000Mbps.

The PC is a Lenovo M90z, Win 7 Pro x64, 4GB RAM.
NIC Card: Intel 82578DM Gigabit Network Connection.

Any ideas on what to do?

My System SpecsSystem Spec
12 Jan 2016   #2

Ultimate x64

I see this all the time. Sorry to say but without replacing the switch its unlikely you will ever be able to solve it (and yes it is likely some device son that same switch will work at gig and others wont). Problem with the switches is some of them don't seem to broadcast their capabilities in the correct fashion, so although it may be able to do 1000FD the PC does not recognise this as a valid mode and will fall to the next fastest option.

what you can try, is disable auto negotiation on both the NIC and the switch and select 1000FD mode. If the link wont come up in this mode you have hit the end of the road.
My System SpecsSystem Spec

 Network connection stuck at 100Mbps (Gigabit card installed)...

Thread Tools

Similar help and support threads
Thread Forum
Intel 825879LM Gigabit Network Card - Cannot start (Code 10)
Hello, I have recently purchased a new system, and since the first time I booted it up the on board gigabit network card is unable to start. I get the following error when in device manager: Device cannot start (code 10) In order for the device to work, whilst in device manager, I must...
Hardware & Devices
Gigabit NIC operating at 100Mbps
I have a Abit AX78 w/ integrated Marvell gigabit NIC. I downloaded and installed the lasted Win7 drivers directly from Marvell, but NIC is operating at 100Mbps. Other Win7 machine are working fine at gigabit speeds. Is there any configuration settings that would affect the nic speed.
Network & Sharing
Dynex Gigabit PCI Card- connection drops. Help?
Hi all, Like many of you, I am having networking issues with Windows 7 Pro. I did a clean install on Saturday from Windows XP and started having issues staying/getting connected to the internet with my motherboard's (ASUS A8NVM-CSM) on board Nvidia nForce networking controller. After seeing...
Network & Sharing
Gigabit nic stuck at 100mbps in Gigabit network.
Cannot get gigabit performance out of Nics in Win 7.. Locked 100 mbps. My motherboard is an Evga 590 Sli Am2 motherboard, with dual gigabit nics. Having established that there is really no benefit to using both nics at the same time in another post, I am now posting because it seems I am only...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:36.
Twitter Facebook Google+