Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WiFi won't work after disk transplant to identical machine

04 Mar 2016   #11

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Interesting, I used your link in post #2 to find the ones I posted.
Hum thanks Derek I just ended up at what looked like dead end to me but anyway they were found that is all that matters eh?

Must be getting a bit rusty I reckon been a lot going on just lately.

My System SpecsSystem Spec
04 Mar 2016   #12

Microsoft Community Contributor Award Recipient

Win 10 Pro x64

Quote   Quote: Originally Posted by ICIT2LOL View Post
Interesting, I used your link in post #2 to find the ones I posted.
Hum thanks Derek I just ended up at what looked like dead end to me but anyway they were found that is all that matters eh?

Must be getting a bit rusty I reckon been a lot going on just lately.
I had to click on the show more at the bottom of the initial list displayed to see them all,

WiFi won't work after disk transplant to identical machine-2016-03-03_21h21_53.png

My System SpecsSystem Spec
15 Mar 2016   #13

win 7 pro x64

Update. No joy so far.

I tried uninstalling the "devices" in Device Manager that I was complaining about, then rebooting. It just tries to install the same things and ends up in the identical state.

I used NirSoft's regscanner to find registry references to the wifi card. There were several, including the wifi card from the dead machine.

I tried installing the wifi drivers and software that derekimo suggested from Intel Wireless LAN (bg, abg, abgn) for Windows 7 (32-bit, 64-bit), Vista (32-bit, 64-bit), XP - ThinkPad - Lenovo Support (US) . This did install the Intel software. Not clear if it actually installed any drivers, but the Intel software complains that there is no wifi to configure, and the Device Manager reported driver for the wifi device is still the same microsoft one from 2009 (the download was from 2012, iirc). Still reported the wifi device as "#2."

I did discover a way to fix the "#2" problem, thanks to this web page: Remove Old Drivers After Upgrading to New Hardware which tells me to set an env variable before running device manager, namely,

Then, device manager shows devices that are not currently present. The previous wifi card was in this list, so I uninstalled it. After that, no more "#2."

However, that did not fix the problem. The Intel wifi software did now at least allow me to "troubleshoot" the connection, but when it tried, it said there is no wifi.

I have not yet installed the chipset drivers.

In general, I am not that keen about downloading random drivers, because there can be dependencies that I'm not aware of, and an outfit like Lenovo is not going to be careful enough about preventing me from shooting myself in the foot. Lenovo does have a "system update" feature, mimicking windows update, that is probably a better way to do it -- let it analyze my system first. I don't like that Lenovo system because it is clunky and keeps installing call-home features and scheduled nonsense, but I may yet go that route.

So, here are things that I will try next:

1. Do a fresh install of win 7 on another identical machine. (I currently have 3 of these.) That will at least prove that win 7 can work the wifi on these machines. It certainly worked on the old machine, but who knows. Slightly different hardware, maybe different BIOS, maybe older rev of the wifi card...

2. Try the chipset drivers.

3. Try the Lenovo system update feature.

4. Reinstall win 7 and start from scratch. I hate this option because the amount of reinstallation of software is enormous, taking about a week to complete. This is why I am trying to now only install "portable" software, avoiding the rat's nest of the windows registry.

5. Transplant the old wifi card into the new machine. (This will, however, at best fix only one machine of the 3, unless I want to stay with win xp forever.)

Any further suggestions would be welcome.

My System SpecsSystem Spec

15 Mar 2016   #14

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

You MUST install the chipset driver before the wifi.
And the driver is on your comp, just looked it up on mine


Attached Images
WiFi won't work after disk transplant to identical machine-4965agn.png 
My System SpecsSystem Spec
15 Mar 2016   #15

win 7 pro x64

@torchwood: Ok, thanks. I'll do that. I already know "the" driver is on my computer. The problem is not that I don't have the driver, the problem is not that the driver is not associated with the wifi device. The problem is that nothing believes that the wifi device does anything. So, I am not sanguine that installing the chipset driver will do anything different, I'll still try it.

I think the most likely explanation of my problem is that due to a few hardware differences: no wwan, yes fingerprint reader, when I transplanted the disk, the boot process was confused in analyzing the hardware. Now, it's possible that I'm missing drivers for something, so I'll try.
My System SpecsSystem Spec
16 Mar 2016   #16

win 7 pro x64

Ok, I uninstalled the broken devices, and the losing wifi device, in device manager.

I downloaded and ran the chipset driver installation. I rebooted.

No joy.

In fact, it took about 5 minutes of the wifi card not even being considered a network controller before it finally decided it was willing to load the same old driver, resulting in the same identical state as before, which is to say 3 "other" devices with no driver, the wifi card with the MS driver from 2009, and no operability.

My System SpecsSystem Spec
16 Mar 2016   #17

win 7 pro x64

Another update:

I transplanted my disk from the dead machine into another of the identical machines (actually a clone of that disk). Exact same losing behavior.

So, I unpacked a new HD, and I did a fresh install of Win 7 in the other identical machine. Wifi works great!!!

I installed win 7 from an enterprise full version standalone dvd, no service pack, no Lenovo nonsense, no hidden system partitions to find Lenovo drivers, etc. -- it was a brand new disk.

So, this proves that it is not a hardware problem, and it is not a problem of needing to update drivers, or missing drivers. It's some kind of misconfiguration problem.

Next, the question is whether anyone can help me figure out what the difference is between the losing installation and the good one. Of course the losing installation has tons of other software installed that I do not want to have to reinstall. On the other hand, that will make doing a diff of registries difficult. In addition, there is always the chance that some brain-damaged Lenovo or MS software decided to hardwire in the MAC address of the wifi card. MS does a lot of weird stuff with their DB system that caused me endless woe due to the DB depending on HD sector size, so going to a new 4k sector disk broke everything using the DB, such as windows update. (I mention that only as an example of extremely stupid MS design.)

Any further suggestions?


My System SpecsSystem Spec
16 Mar 2016   #18

win 7 pro x64

Maybe I should mention one other wrinkle. Of the 3 live machines I am working with, I don't think they all have the same rev of the BIOS. I doubt it, but maybe it's related to that. (Note that wifi always worked with win xp, though, on all 3 machines.)
My System SpecsSystem Spec
17 Mar 2016   #19

win 7 pro x64

BTW, on the machine with the fresh install of Win 7, where the wifi works just fine, Device Manager also reports the same devices as "other" with no drivers. So, I doubt those are the problem on the machine with the transplanted disk, unless some win 7 update that has not been done to the fresh install would break wifi.
My System SpecsSystem Spec
18 Mar 2016   #20

win 7 pro x64

I haven't solved my problem yet, but for anyone who might be interested, the unknown "PCI Memory Controller" turns out to have hardware ID PCI\VEN_8086&DEV_444E&SUBSYS_444E8086&REV_01, which is Intel "Turbo Memory," described here:
It is a 1GB on-motherboard flash, like SSD, but obviously only 1 GB.
My System SpecsSystem Spec

 WiFi won't work after disk transplant to identical machine

Thread Tools

Similar help and support threads
Thread Forum
acer aspire 4738' s bluetooth doesn't work but wifi work?
Acer aspire's Bluetooth doesn't work since I bought it I've installed drivers too but it doesn't work what should I do. In its specs it has Bluetooth . But there is no Bluetooth device found in device manager how to repair this. Please HELP!!
Hardware & Devices
Opera embraces WebKit in browser brain transplant
Read more at source: Opera embraces WebKit in browser brain transplant | Internet & Media - CNET News
2 sets of identical RAM seem to not work together?
So I've had 8GB (2x 4GB) of G.Skill Ripjaws RAM in my system for about a year now and I got another 8GB of the exact same RAM in December and ever since then I've been getting BSOD's every couple of hours with all 4 DIMMs installed - However if I use just use either the 2 old sticks or the 2 new...
Hardware & Devices
Identical Monitors, not identical colors
I received my 2 Samsung BX2431 LED monitors today, hooked them up, installed drivers. And now after wasting an hour on finding out that I had to do scaling on my card in the AMD Vision control center to get rid of the black bands, I still am left with the problem that one monitor is whiter than...
Graphic Cards
transplant dell into antec
ok, so I've got a dell vostro sitting in the other room, core 2 duo 6550 (I think), cheap vid card, blah blah blah.... and I've got a pretty nice antec case in the basement with a P4-2.8 that I no longer use. built it a while back... I'd like to swap the dell guts into the antec case, the...
PC Custom Builds and Overclocking
Suddenly cannot connect to an XP machine (others work)
I have a small home network setup with a handful of Windows XP machines. I recently upgraded one machine to Windows 7 and everything was configured and working. This morning the Windows 7 machine will not connect to one of the XP machines. I set up the Windows 7 machine with two logins (my wife...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App