Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7: "No Internet Connection" with Wireless

17 Nov 2009   #1
ThisIsDJT

Windows 7 Professional 64-Bit
 
 
Win7: "No Internet Connection" with Wireless

Hey Everyone,

I'm a newb to the forums and this is officially my first post. I just installed Windows 7 64-bit last night and everything went smoothly...except my wireless is acting pretty funky. It seems like it connects to my router just fine (it's a linksys rangbebooster-b,g), but the internet connection itself keeps turning on and off. When the wireless is working, which is rare, it runs at dial-up speeds for about 30 seconds, then stops working again .

I had Vista before this install, and my wireless card was working just fine. It's a D-Link N card, I don't remember the specifics because I'm at work right now. The troubleshoots in Windows aren't offering any help at all. On another note, I have other devices in the house (laptop running XP, Playstation 3, Nintendo Wii, Acer Netbook) that have no trouble accessing the router and the internet, so I'm figuring it can't really be the router can it? I understand that multiple devices using the same router at the same time can cause "slower" speeds, but these devices were not on when I was working with the computer.

Any help with this situation would be greatly appreciated!


My System SpecsSystem Spec
.
17 Nov 2009   #2
Tews

64-bit Windows 8.1 Pro
 
 

Make sure that you have the latest drivers from D-link installed..
My System SpecsSystem Spec
17 Nov 2009   #3
ThisIsDJT

Windows 7 Professional 64-Bit
 
 

Okay, I'm such a bonehead, I can't believe I forgot to do that last night. I was just stressed that the seemingly flawless installation had such a major setback. I will try to go through with it tonight when I get home and I'll let you know, thanks for reminding me!
My System SpecsSystem Spec
.

17 Nov 2009   #4
Tews

64-bit Windows 8.1 Pro
 
 

You're welcome!
My System SpecsSystem Spec
17 Nov 2009   #5
myzr7

Windows 7 Ulti. x64
 
 

Quote   Quote: Originally Posted by ThisIsDJT View Post
Okay, I'm such a bonehead, I can't believe I forgot to do that last night. I was just stressed that the seemingly flawless installation had such a major setback. I will try to go through with it tonight when I get home and I'll let you know, thanks for reminding me!
If by chance you are connected to your router by hardwire then you might look in windows update for the driver dl. I looked at my update this morning and found a dl for my yukon marvel adapter. look for your optional updates. start/all programs/windows update. Good luck to you with this problem and welcome to SevenForums!
My System SpecsSystem Spec
17 Nov 2009   #6
ThisIsDJT

Windows 7 Professional 64-Bit
 
 

Ok, I'll try that as well when I get home. This whole work thing is a drag, thanks for the help!
My System SpecsSystem Spec
Reply

 Win7: "No Internet Connection" with Wireless




Thread Tools




Similar help and support threads
Thread Forum
Wired LAN Connection: "Unidentified network" No Internet Connection
Hi, I'm having a little bit of trouble connecting my computer to a wired internet connection. My wireless works, but some of the programs I am running require wired connections. My Physical connections are pretty weird, so I think I'll get that out of the way first. I have an AT&T wireless modem....
Network & Sharing
Wired LAN Connection: "Unidentified network", No Internet Connection
Microsoft Windows Copyright (c) 2009 Microsoft Corporation. All rights reserved. C:\Users\Jesse>ipconfig /all Windows IP Configuration Host Name . . . . . . . . . . . . : JPC Primary Dns Suffix . . . . . . . : Node Type . . . . . . . . . . . . : Hybrid
Network & Sharing
Help! Internet wireless connection "connects" but no internet access
Hi all! I was installing a software on my other laptop (it had SQL software with it) and I ran into some trouble as I got error problems that the installation of the software had failed and now whatever I do, I can't access the web! Sure enough, my wireless connection connects successfully and it...
Network & Sharing
Internet wireless connection: "Limited Connectivity" in one machine!
Hi! I've been checkin some info in other places but the problem appears to be resistant to solutions :sarc: After scanning and removing some viruses, I found myself without wireless internet connection. I suppose some configuration was changed by the virus but I can't find out what it was to...
Network & Sharing
I have "DHCP" how can I use "Static" IP on a wireless connection?
I don't know if this is the right place, but I seriously need some help. I've got an IP that changes every time my "gateway" (router) is reset. First of all, I'm using windows 7 ultimate 32 bit. AND IIS. (Internet information services) or something like that.. It's really annoying, because...
Network & Sharing
Windows 7 Ultimate 64 bit "limited access" Wireless Network Connection
I just did a clean install on my windows 7 ultimate 32 bit computer to 64 bit. At first, my wireless internet was working fine, but it suddenly dropped to "limited access". I'm using a Linksys WUSB100 ver. 2 wireless network USB adapter. I've already tried downloading the latest driver for windows...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App