Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: After deleting VSO by RevoUninstaller Network adapter stops working

24 May 2016   #1

Win 7ult 32
After deleting VSO by RevoUninstaller Network adapter stops working

Hello everyone,

I have two identical machines HP dc7100 CMT desktop at home, with Windows 7 ult 32bit. There is a particular software installed in it, VSO downloader, and this particular software doesn't show up among the list in the Uninstall a program in the Control Panel- which is dubious to me. So, I tried to uninstall it with RevoUninstaller - which it did perfectly well. But, after restarting the machine, I found out the internet connection was down. I tried the Troubleshooting, which says "Problems found: The Broadcom NetXtreme Gigabit Ethernet adapter is experiencing driver- or hardware-related problems - detected (with an exclamation mark in yellow triangle").

I tried to re-install the driver by all means, from Device Manager, but it didn't work. Under the list in the Device manager, Network adapters, the "BroadcomNetXtreme Gigabit Ethernet" is flagged with the yellow exclamation mark.

I updated the driver by locating the device manufacturer manually but it says, "Windows encountered a problem installing the driver software for your device" "This device is not working properly because Windows cannot load the drivers required for this device. (code 31)".

Next, I pointed it to Windows\System32\Drivers\b57nd60x.sys, but to no avail since it's not .inf file.

Yet, when I look at the back of the machine at the interface port where the LAN cable is connected, the lamp is well lit. That means, the NIC is working, but somewhat the internet connection is cut off.

Next, I used an SD-card reader to get the driver from the working machine, and from this link

DriverMax - Network Adapters - Broadcom - Download Broadcom NetXtreme 57xx Gigabit Controller Computer Driver Update 420373

I downloaded the driver "NET-Broadcom-Broadcom-NetXtreme-57xx-Gigabit-Controller 2,979KB (version date: 4-26-2009)", but when I ran this on the broken machine by pressing the Next button, it hangs on there waiting saying, "Downloading and installing..." and never moved. Of course how would it move without internet connection to do the downloading (!?) So, I stopped that one. It didn't work.

The final option I did was to copy the b57nd60x.sys from the working machine and replaced it, but didn't do the job, either.

I tried to restore the system to earlier point from System protection, but to my surprise, the Local Disk C: was OFF, altered. Therefore it couldn't proceed further.

Perhaps, that's as far as I could do, and I very much appreciate for any help, please. Thank you in advance.

My System SpecsSystem Spec
24 May 2016   #2

Win 7ult 32

Just to update on this problem, I am glad to tell everyone that the problem is solved. For future reference for others with the same trouble, this is how I did it. I went to the Computer icon's Properties/ Device Manager/ and (right-click) uninstalled the device with the yellow tag, "Broadcom NetXtreme Gigabit Ethernet." Without rebooting, I right-click a device in the list, in this case "Mice and other pointing devices", and clicked on "Scan for hardware changes" selection, and there it did the job. All is well now.

Otherwise, see the #4 on this link:

My Network adapter cannot be found?

Thank you again for all sympathizers.
My System SpecsSystem Spec

 After deleting VSO by RevoUninstaller Network adapter stops working

Thread Tools

Similar help and support threads
Thread Forum
Help! Network Adapter not working on my laptop!
I have a Sony Sve15113enw laptop. Everything was working fine. Then last week i lost connection to the router and for whatever reason, i can't connect again anymore. shows limited access. Task manager show no wireless internet connection. Microsoft teredo tunnelling adapter...
Network & Sharing
wired network adapter not working
Hi, I've been having problems with my wired network adapter. It no longer seems to be operating but my wireless connection still works fine. I plug in the ethernet cable to my laptop and there are no LEDs lit up on either end of the CAT 5 cable receiving plugs. Normally these light up when the...
Network & Sharing
Wireless network adapter not working
I've followed some on the steps provided on here, but I still can not connect to the internet via wireless option error message appears as "there might be a problem with the driver for the wireless network connection adapter" I've downloaded the latest version from the Dell support site and it...
Network & Sharing
Network connection adapter not working
Hello! My laptop cannot currently connect properly to the internet. After trouble shooting, the diagnosis is that "There might be a problem with the driver for the Wireless Network Connection adapter". My laptop also wouldn't connect to the internet via cable. I'm not sure what the problem is as my...
Network & Sharing
Wireless adapter stops working after 15 minutes.
Hi all, I have a problem and can't seem to find anything similar online after over an hour of searching. My connection works perfectly for 15ish minutes, then I get disconnected. The wireless icon at the bottom left has a red x and says that there are no connections available. In the network...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:08.
Twitter Facebook Google+