Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network map shows switch that does not exist

24 Jul 2016   #1

Windows 7 Ultimate x64
Network map shows switch that does not exist

Hi guys. I am usually pretty good with these things as I have been networking for years and I am currently studying a Bachelor of Information Technology, but this one has be baffled.

As you can see in the image below, the network map shows my PC---Switch---Router/modem---Internet. The problem is that the switch has only appeared recently and I have not installed any switches, nor do I have a need for one as my PC is the only device wired to the router, all others are WiFi. I have looked everywhere for a solution to this both on my computer and on the internet and have come up blank

The other problem is that I had my 2 PCs (Main in office and one connected to TV in lounge room) and laptop all set up so they could each access the other device's shared file through the Home Group, however now I can not see or access the other 2 from my main PC, but I can see and access the Main PC from the other 2 (TV system and laptop). While all this is happening, if you look at the bottom of the image, you will see that the TV system is in the 'The following discovered devices cannot be placed in the map' section...... This has me totally confuzzled

Any help here is appreciated guys, thanks !!

My System SpecsSystem Spec
25 Jul 2016   #2

Windows 7 Ultimate x64

UPDATE: After having the main PC off for a while and turning it back on tonight, it seems the other computers are now visible in the network section of the side panel (see first pic below). The other systems in the side panel didn't disappear until the last few days and the system has been turned off and on many times lately with no change.....until today. DAMMIT CIA....STOP MESSING WITH MY STUFF !!!

Also there are now more devices in the 'The following discovered devices cannot be placed in the map' section. The non-existent 'Switch' is also still there . I may try changing the network cable between the router and the PC and see if that gets rid of it, but I have my doubts. The second pic shows all the other devices now in the 'The following discovered devices cannot be placed in the map' section.

But somehow they are all showing up under 'Computers' under the 'Network' section of the control panel. I'm lost lol.

My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
windows explorer shows folders/files that do not exist
Windows explorer shows folders/files (example: C:\Windows.old) that I wish to delete.When I try to delete them, I get message: "Could not find this item. This is no longer located in C:\. Verify item's location and try again. How do I get rid of them?:(
General Discussion
How to switch from WLAN to LAN adapter? (if both exist)
Asume I run a notebook which is currently successfully connected to a WLAN. Fine. Now I plugin a cable to another (!) physical Router into the LAN slot of the notebook. In order to configure this (second) router I have to type into the browser the localhost addres But this way...
Network & Sharing
Full Network Map shows a "switch"? I did not add intentionally
In my task bar over the internet icon there is a red X. Typically this means I do not have internet. However, I know I have internet because I am leaving this post. When I look at my internet map there is also an "X" in the path to the internet (The globe/planet). When I look at my full...
Network & Sharing
File explorer shows a virtual cdrom which does't exist
Hi All, Couple weeks ago, I tried a virtual cdrom software (sorry, I forget its name). That software was crashed after created the driver E. Since then I tried a lot of ways to remove this ghost virtual driver which I searched from the google, unfortunately, all failed. Do you guys know how to...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:04.
Twitter Facebook