Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to Make Connection To Internet

21 Oct 2016   #1

Windows 7 64bit
Unable to Make Connection To Internet

Last evening after starting up my computer, I was unable to connect to the internet. After several reboots of the computer and modem, there was still no resolution. All the other network connected devices were able to maintain an internet connection through both wired and wireless connections, so it wasn't an ISP outage and the router appears to be working as normal. There had been no tinkering of the router at any time.

My computer was telling me it was unable to find a network connection and that I should ensure a network cable was plugged in or to ensure it wasn't damaged. Neither the router's port or computer's adapter LEDs were illuminated to indicate a connection. I exchanged my ethernet cable between the wall jack and my computer which made no difference. I disconnected the cable from my computer and reconnected it to my laptop. I was able to make a connection. I concluded the issue was with my computer. Fearing that the onboard LAN adapter had failed, I went out and purchased a PCIe LAN adapter (TP-Link TG-3468 Network adapter) and installed it. The computer found it and installed drivers. Still, the problem persisted, Unable to find any connection.

A reboot of the modem and computer made no difference.

I disabled the onboard NIC through BIOS, uninstalled all instances of any network interfaces, and installed the drivers from the CD provided with the card. From there, a driver update attempt indicated the drivers were up to date. Still, unable to make a connection in either safe mode (with networking) or regular Windows 7 initialization. (Using Windows 7 64 bit OS)

A reboot of the modem and computer made no difference.

Tried: (as per

netsh winsock reset and the result was "The following command was not found: winsock refresh.

ipconfig /release and the result was "An error occurred while releasing interface Local Area Connection : An address has not yet been associated with the network endpoint."

Then, ipconfig /renew which resulted in "No operation can be performed on Local Area Network while it has its media disconnected. An error occurred while releasing interface Loopback Pseudo-Interface 1 : The system cannot find the file specified."

Followed finally with ipconfig /flushdns which indicated "Successfully flushed the DNS resolver cache."

I tried a Windows repair, and that to had no positive results after rebooting. A virus check indicated no infection or concerns. Unfortunately, for whatever reason, automatic restore had been disabled, so I don't have a restore point to fall back on.

I hope someone is able to help find a solution. I thank all those who have taken this post into consideration. This has been crossposted here, and I'm looking to a group of other knowledgeable individuals to offer their suggestions.

My System SpecsSystem Spec
21 Oct 2016   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Jenn,
have a look at this MS thread

My System SpecsSystem Spec
23 Oct 2016   #3

Windows 7 64bit

Thank you Roy for your help. I appreciate it.

Unfortunately, it wasn't the solution needed. I still have the problem.

Last night, while trying to identify the cause, I stumbled on the likely culprit. Windows is reporting that I need to plug in a network cable. The network cable is clicked securely in place.

I had received this same error with both network cards, the online one and the one I purchased to replace it, the PCIe card. I have tried three different cables, from 3 different ports on my router with no resolution. I have no problem connecting with those same cables from any port on my router, to my laptop.

I've attempted a common online fix that was successful for many ... a simple solution involving unplugging the power and ethernet cables for 30+ minutes, followed by reconnection and rebooting. This made no difference regrettably.
My System SpecsSystem Spec


 Unable to Make Connection To Internet

Thread Tools

Similar help and support threads
Thread Forum
Can't make than 1 connection when internet-connected on windows
Hello, I've been encoutering this strange problem for weeks now, and it happens only on 1 of my computers: When I'm for example downloading a game on steam, I cannot access internet on my browser or on any other program! Also, when a program is updating, other programs cannot access internet; it...
Network & Sharing
Unable to make a TCP connection to the server
Hello, I originally posted this information in the Hardware section, then thought about it and it should be here... Good morning, I have a user that is unable to use the networked Lexmark X646E to scan documents. She is able to successfully fill out the Scan profile and send the job to the MFP,...
Network & Sharing
Unable to make a TCP connection to the server
Good morning, I have a user that is unable to use the networked Lexmark X646E to scan documents. She is able to successfully fill out the Scan profile and send the job to the MFP, but when you go to the printer to scan the document it will scan and attempt to send the doc back to the users...
Hardware & Devices
How to make program use a specific internet connection?
say i got 2 NIC, 2 internet connection, how can i bind my program (torrent/IDM) to use the specific internet line?
Network & Sharing
Unable to make internet connection
A friend's asked me to take a look at her laptop ... when I wire it into a router, there's no internet connection. Tried different ethernet cable, different router port. Still same. Fails when I ping the router (192.168.x.x), but can ping local loop ( Windows shows the ethernet card as...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:26.
Twitter Facebook Google+