Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't access wireless adapter (shows disabled) but can access internet

30 Dec 2016   #1

Windows 7 Home Premium x64 SP1
Can't access wireless adapter (shows disabled) but can access internet

This just started this morning. My wireless icon keeps having the loading circle, which changes to an x when I click it. I am unable to load my network options, also. But internet connects fine and I am able to surf (and come here, begging for help). Also, other devices like my tablet and phone can connect no problem. What could be the issue?

On a possibly related note, my Kaspersky Internet Security is stuck on loading. This edition has Kaspersky Secure Connection. Do you think the fact that it's not loading could be a cause?

Also, I am NOT very smart when it comes to computer things.

My System SpecsSystem Spec
30 Dec 2016   #2

Windows 7 x64


Go to --> Control Panel\Network and Internet\Network and Sharing Center

On the top panel, you will see Your Computer -------X -----> Router/Modem ----------Internet

As you mentioned, from the Router/modem ------------- Internet is fine, no yellow exclamation ! or no red X

Next, on the left panel, select "Change adapter settings"

If your are using Wireless, then click on the "Wireless Network Connection" and will be highlighted.

Right click on the highlighted "Wireless Network Connection" and select "Enable".

If when right click on the highlighted "Wireless Network Connection" is Disable, then click to show Enable, and then click to show Disable. This is to force the computer to refresh and connect.

If it do not work, you need to switch off the router/modem and then switch on.

It is to refresh the connection.

My System SpecsSystem Spec
31 Dec 2016   #3

Windows 7 Home Premium x64 SP1

Well, as it turns out, it was my anti-virus that was the cause. I forced an update for it and now it seems to work fine.
My System SpecsSystem Spec


 Can't access wireless adapter (shows disabled) but can access internet

Thread Tools

Similar help and support threads
Thread Forum
Multiple internet connections with no access (wireless adapter)
Here's what happened: I wanted to set the computer to a static IP of I tried this by going into Network and Sharing Center, clicking Change Adapter Settings, right clicking Wireless Network Connection and selecting Properties, selecting Internet Protocol Version 4 (TCP/IPv4) and...
Network & Sharing
Internet loses connectivity, problem access point/ wireless adapter
So my computer has been having problems lately. I know it's only related to my computer, because my phone and my PS3 (which I added to the network AFTER the issues started) both have no issues running the internet. However, on my laptop, an Asus G73JH with a Qualcomm Atheros AR9285 Wireless...
Network & Sharing
No access to Internet - Limited access for both wired and wireless
Hi i am new here My Original post is here - No access to Internet - Limited access for both wired and wireless - Microsoft Answers I have seen most of the threads going un-answered so i feel that i can get help from here! I just accessed wireless internet on another laptop! So i am sure we...
Network & Sharing
unable to access radio shows on the Internet
OS Windows 7, anti-virus is Avast, Broadband for Internet. Windows 7 updates are current. I used to listen to two radio shows via their programs website. All of a sudden I can't connect to the audio. I can connect with a radio station to listen to the programs, but since I subscribe to the...
Browsers & Mail
Internet shows connected but unable to access Internet
A warning in advance: this is going to be a fairly long post. I don't know a ton about troubleshooting but I'm not computer illiterate and I've tried quite an array of tests while trying to fix things on my own. First of all my laptop is an: HP Presario V6000(GB115AV) I'm running windows 7, I...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:10.
Twitter Facebook