Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wi-Fi doesn't have a valid IP configuration

19 Jan 2017   #1
monopod

Windows 7 Professional 64-bit
 
 
Wi-Fi doesn't have a valid IP configuration

(I attach an ipconfig/all output text file and a Xirrus screenshot.)

My Windows 7 Lenovo M30 laptop has suddenly stopped connecting to my router. Other Windows 7 devices connect just fine. The problem suddenly arose for no apparent reason. (The device worked fine until yesterday.) I've read widely in forums and tried lots of things without success (below).

Troubleshooting reports these 2 errors:
1) "Wi-Fi doesn't have a valid IP configuration"
2) “Problem with the Wireless Adapter or Access point”

I’ve tried the following so far.
1) Factory reset router (BTHub6)
2) Rebooted PC
3) Disabled Microsoft Virtual WiFi Miniports
4) Disabled Bluetooth
5) Disabled then re-Enabled the (Qualcomm Atheros AR956x) Wireless Network Adapter
6) Updated the driver for the Wireless Network Adapter
7) Checked that “Obtain an IP address automatically” is checked in IPv4 and IPv6
8) Checked that “Obtain the DNS Server address automatically” is checked in IPv4 and IPv6
9) Checked that there was no McAfee Bonjour Service installed.
10) Rebooted again….

Can anyone help?

Many thanks in advance for any ideas!




Attached Thumbnails
Wi-Fi doesn't have a valid IP configuration-xirrusscreenshot.gif  
Attached Files
File Type: txt ipconfig.txt (4.6 KB, 4 views)
My System SpecsSystem Spec
.
19 Jan 2017   #2
samuria

win 8 32 bit
 
 

Welcome to the forum. You get a IP in the range 169 which means Windows can't get an IP from DHCP server. You could set a fixed IP it's either you not entering correct password the router is out of range another router is close killing connection. Disable ipv6 it's not used there 3 routers on channel 6 that can kill it
My System SpecsSystem Spec
21 Jan 2017   #3
monopod

Windows 7 Professional 64-bit
 
 

Many thanks for your reply samuria - I learnt some useful basics here.
When I understood that in order to set a static IP address I would have to do that for all devices on the network, I took the chicken's way out and rebooted the router (yet again) - this time the device connected.
If the problem persists though, I'll grit my teeth and set static IPs for all devices!
Thanks again.
My System SpecsSystem Spec
.

21 Jan 2017   #4
samuria

win 8 32 bit
 
 

You can set any one pc to static you dont have to do them all
My System SpecsSystem Spec
22 Jan 2017   #5
monopod

Windows 7 Professional 64-bit
 
 

Ah - OK. The reason I assumed that is because the instructions I found for setting static IP said not to forget to switch off the dynamic IP service in the hub (so I assumed the hub would be unable to do dynamic for the other connected devvces) . Do I not need to switch off the dynamic capability of the hub? Does the hub recognise whether it is being asked for static or dynamic IP address?
Many thanks for your help !
My System SpecsSystem Spec
22 Jan 2017   #6
samuria

win 8 32 bit
 
 

It stays the same giving out IP the one you set static doesn't ask as it has an IP nothing needs to be done on the router you set it on the PC you may have read how to set it on the router which isn't the same thing
My System SpecsSystem Spec
Reply

 Wi-Fi doesn't have a valid IP configuration




Thread Tools




Similar help and support threads
Thread Forum
Connection doesn't have a valid IP configuration-error
Hi. I made a change to my network today and I'm having an issue with my desktop. I converted to a modem/router combo from TWC because of issues I have been having with my own router. All tablets and phones in the household are connected to the new wifi setup with no issues. My desktop however...
Network & Sharing
LAN doesn't have a valid IP configuration! (ICS prob.)
I have instaled Windows 7 Ultimate 32bit on my new computer. (Dual boot with XP). On my old computer there was installed XP... so the problem is: When i tryed to share Internet connection Windows 7 gave me an error: "Local Area Connection" doesn't have a valid IP configuration but files were...
Network & Sharing
Wireless doesn't have a valid IP configuration
I have been having this problem intermittently for some time. I can be connected at home to my wireless network fine and then something happens and i get 'wireless doesn't have a valid IP configuration'. Sometimes if i plug into the network (wired) the wireless will be fine again and sometimes...
Network & Sharing
Wireless doesn't have valid ip configuration
I have a Dell Intel Pentium Desktop and a Toshiba laptop running Windows 7; the router is a Netgear RangeMax Wireless-N 150. Until 8/17/11 I was able to make wireless/wired connection with my laptop, I can make connection with desktop with no problem. When I run troubleshooter I'm informed that...
Network & Sharing
Connection doesn't have a valid IP configuration.
Hey guys, little problem here. I just bought my wife a new laptop with Windows 7 on it. When I first got a hold of it, I proceeded to remove all the HP bloatware that was installed. I went to Add/Remove programs and uninstalled everything that had HP beside it. Next, I tried to have the...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App