Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No network adapter driver found, connections are available?

12 Mar 2017   #1
jfarinto

Windows 7 Home Premium 64bit
 
 
No network adapter driver found, connections are available?

Hey all!
I'm unable to connect to the Internet after a system restore (malware).
If I mouse over I get "Not connected - Connections are available", but there aren't any connections.
In device manager I don't have any network adapters other than a Bluetooth device. I've downloaded drivers from another computer but they can't find the network card.
Originally my USB ports weren't working either, I uninstalled the driver for them and reinstalled it with success. I tried the same with the network adapters but no luck.
I've tried all the solutions on similar to no avail.
Am I missing something simple?
Any help is greatly appreciated, many thanks in advance!


My System SpecsSystem Spec
.
12 Mar 2017   #2
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi JF,
Malware does tend to muck things up, It may even still be present by the sounds of it!
System Restore DOES NOT clear malware
Run your AV and Malwarebytes free
Strangely enough depending on what the malware was, it could be a bonus your NOT on-line
(on-line banking etc)


Go to the homepage for your model, input the service id, drop the Ethernet/wireless drivers to a usb.
Now on the problem laptop,
download the drivers to your desktop
go Device Manager >> problem devices(this is where i think they BOTH are)
select update driver and point it to drivers on desktop.

note if you LEFT click on your wireless signal stength icon and you can see your network ID, connect to it, possibly just your password is missing should be on the router.


Roy
My System SpecsSystem Spec
12 Mar 2017   #3
jfarinto

Windows 7 Home Premium 64bit
 
 

Hi Ray,
Thanks for the fast response! I transferred over malwarebytes and some other programs to clean it up on a USB along with some new drivers.
I've installed a few drivers but still nothing other than the bluetooth device under Network Adapters within device manager. (I assume problem devices isn't actually header?)
I tried going to action > add legacy hardware and bringing them in. I can get them to show up but not run. I also checked in hidden but didn't find any of use.

I can't left click as there is no signal strength, just the 5 grey bars with the yellow star* "connections are available", but there is no wifi.

Thanks again for the response, I'll keep fiddling around with it!
My System SpecsSystem Spec
.

13 Mar 2017   #4
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi JF
problem devices is NOT just a header.

Thats where it puts equipement that it cant allocate drivers to
expand it hopefully you should see them
click properties >> details >> then use the little down arrow goto HardwareID
it will show PCI VEN those are the details you need
post them

note
i suspect that your malware clean up tools removed them, compromised??, the logs might list them as well.

Roy
My System SpecsSystem Spec
13 Mar 2017   #5
jfarinto

Windows 7 Home Premium 64bit
 
 

Hi Ray,

I didn't have any headers named problem devices, although after tethering to my phone and attempting to install drivers I now have the category "Other devices" and "PCI Device" within it.
I followed the path and got this:
PCI\VEN_10EC&DEV_5209&SUBSYS_C0D0144D&REV_01
PCI\VEN_10EC&DEV_5209&SUBSYS_C0D0144D
PCI\VEN_10EC&DEV_5209&CC_FF0000
PCI\VEN_10EC&DEV_5209&CC_FF00

Hopefully this helps,
Thanks again!
My System SpecsSystem Spec
13 Mar 2017   #6
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi JF,
No there fine,

DID you go to the samsung model hompepage for the drivers??

Roy
My System SpecsSystem Spec
13 Mar 2017   #7
jfarinto

Windows 7 Home Premium 64bit
 
 

Hi Roy**,
I did get the drivers from the samsung page, although I'm having trouble installing them.
For the realtek ethernet control driver I'm getting "The Realtek Network Controller was not found. If deep sleep mode is enabled Please plug the Cable".
For some of the intel wireless drivers I'm getting a newer driver is already installed although it isn't showing in device manager.

I'm trying to find a driver for the PCI Device in "Other devices" as it isn't working atm, although it is the only one that even shows up in device manager.
Thanks again
My System SpecsSystem Spec
Reply

 No network adapter driver found, connections are available?




Thread Tools




Similar help and support threads
Thread Forum
Network Adapter Driver not found after Clean Install of Windows 7
Hello, After spending my entire friday trying to fix my mom's pc, I'm stumped... She recently purchased a new 2T HDD, 8 more GB of 1333 DDR3 Ram (12 GB total), and Windows 7 Home Premium x64. Everything was installed smoothly and works with the exception of the network adapter. I've installed the...
Network & Sharing
My Network adapter cannot be found?
Hi Everyone I am having problems with my Dell XPS 8300 desktop computer, which runs on Windows 7 and has a 64bit operating system. The problem might have something to do with the network adapter as when I turn on the computer the network icon in the bottom right corner of the screen is...
Network & Sharing
Network Adapter Not Found
This is with a wired ethernet connection. Verizon FiOS internet. The router is working and other devices on the network connect to internet just fine. It's a Biostar TZ77B motherboard. There were some issues with Windows Startup. I did a repair using the disk, also reset CMOS. Booting fine...
Network & Sharing
Network adapter not found on laptop?
Hello, I came across this forum while searching for answers on google, by alas I wasn't able to find and clear answer, so I feel as if you folk over here may be able to help me. First off, back in December I brought an ASUS G74SX-BBK9 and it was running perfectly until about two weeks ago. Two...
Network & Sharing
No network adapter Found
I'm running windows 7 bit32 with VM ware on my macbook pro. Not sure what happened. but all of a sudden I can't connect to the internet on the windows side. The error I get is that there is "no network adapter found. In device manager there is no wireless adapter in the list. In addition when...
Virtualization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App