Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Strange web problem after switching to xfinity

18 Mar 2017   #1
eegad

home premium 64bit
 
 
Strange web problem after switching to xfinity

For the past several years I have had Verizon DSL in my home. Devices in use on network are Win7 Pro desktop, older Mac laptop with OSX 10.6.8, an ipad, an apple tv, occasionally an iphone. All devices worked just fine. Apple devices connect via WiFi of course; the desktop was hardwired via ethernet. I got Comcast/Xfinity "performance" internet this past week (rated 25Mbps) with an Arris TG1682G modem/wireless gateway and am having a strange problem. No problems with any of the Apple devices. On the macbook, firefox 48 (the highest available for 10.6.8) works perfectly. On the Win7 desktop, the current version of Firefox that was installed had issues….some webpages load fine, others are scrambled. Sometimes they show up as garbled text/html. Sometimes they show, but the photos are missing or scrambled (look like corrupted jpg's). Sometimes top part of page looks fine, but as you scroll down, the lower portions turn into scrambled text/html code. Sometimes they don't display at all, but show a message about either an encoding error, or an SSL error. The desktop was connected via ethernet cable. I tried disconnecting it and instead connecting via WiFI. It made no difference. I tried uninstalling firefox completely (deleting caches, profiles, etc) and reinstalling. Same problems occur. I tried downloading an older version of Firefox (32). Same problems. I tried downloading the current version of Chrome. Chrome didn't work either….some pages fine, others scrambled, same as Firefox. Then I launched IE (which I typically never use)….whichever old version that came installed originally with Win7 Pro a few years ago when I bought the machine….and guess what? All webpages display just fine through IE. And so I am truly puzzled. Can anyone think of any setting, or any reason WHY this might be happening? If IE can display sites fine, then why can't Firefox/Chrome? What setting could possibly be different between IE and other browsers? And because IE works, it can't be a network setting in windows, or some setting in the modem/gateway, right?? One more interesting point. Speedtest.net runs just fine through Firefox on the Macbook. On the PC, in ANY browser, it completes the download test and then just craps out…it never gets to the upload test. BUT…if I disconnect from the comcast/xfinity service, and connect to the old verizon DSL (I didn't cancel it yet), then speedtest.net works just fine on the Win7 desktop in all browsers (and all webpages load fine also, just like they always did, just very slowly). WTF??? Any help much appreciated.


My System SpecsSystem Spec
.
20 Mar 2017   #2
eegad

home premium 64bit
 
 

After spending all day playing around with things, I found the solution. There is apparently some sort of conflict with Microsoft Security Essentials and some browsers. With MSE active, all browsers work fine with a very slow (~5 mbps DSL connection). On a faster (~30 mbps) connection, Firefox and Chrome both have issues displaying pages - roughly 1/4 of all webpages show up corrupted. Oddly enough, Microsoft's own Internet Explorer does not have any issues with MSE active. Deactivating MSE causes Firefox and Chrome to work without any problems.

Also of note....an older desktop that I rarely use anymore has Win7 Home and an older version of MSE on it (2013 vs 2015 copyright on the newer machine). That machine has NO problems with Firefox or Chrome while MSE is active.
My System SpecsSystem Spec
Reply

 Strange web problem after switching to xfinity




Thread Tools




Similar help and support threads
Thread Forum
Anybody else on here with XFINITY from Comcast?
So I am posting this thread out of curiosity to see who else is with XFINITY through Comcast and has also been having issues getting websites to load for the past 3 nights because of there routers that are junk
Network & Sharing
Problem with switching ISP.
I am moving house and my ISP (Virgin) will not transfer their service to my new area because Virgin now only supports fibre optic connections. I have agreed a new ISP contract and email address and I have emailed everyone in my address book to advise them of my new email from the end of the month....
Browsers & Mail
[PLEASE HELP] Serious problem when switching Graphics Card...
Hello! I have a big issue and Im in need of your expert help. I have a gtx 260 graphics card and I just bought my little brother a computer that has a Radeon 5770. Since Im in much need for the HDMI and some other reasons and he's not, I switched our graphics cards. Everything seemed...
Graphic Cards
Comcast xfinity
So with Comcast switching to only digital does that mean any 3rd party tuners are worthless. My dad is complaining now he can't record his tv shows. Short of renting the overpriced dvr what else can he do?
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App