Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Recently installed Win 7 and can't connect to the internet

05 Apr 2017   #1
William N

Windows 7 Home Premium 64 bit
 
 
Recently installed Win 7 and can't connect to the internet

Hello, yesterday i reinstalled to Windows 7 Home Premium no my PC and now i can't connect to the internet. I installed the LAN driver for my lan card, Realtek PCIe GBE Family Controller (hope its the right name) and the chipset driver. Those are the only drivers i have installed at the moment. Now in the Device Manager, under "Device Manager" the "Ethernet Controller" has a yellow exclamation point that says: "The drivers for this device are not installed (Code 28)" . I'm not sure but i think that might be the problem ? I've checked the cables and the router , and connected directly to the ethernet cable just in case the router is ****ed or something. Still doesnt work. I dont know if i've missed something or what... Would be really happy if someone could help me with this. Thanks in advance.


My System SpecsSystem Spec
.
05 Apr 2017   #2
oscer1

win 7 64 bit
 
 

hi

is this the driver you installed for Ethernet? http://www.gigabyte.com/Motherboard/...-10#support-dl

if so uninstall it and try it again
My System SpecsSystem Spec
06 Apr 2017   #3
William N

Windows 7 Home Premium 64 bit
 
 

Hey, thanks for the reply nad yes that is the driver i downloaded the win 7 64 bit version, I reinstalled it and still have the same problem.
My System SpecsSystem Spec
.

06 Apr 2017   #4
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi William,
looking at the homepage for your MB,
theres a Bios update, F8, for Lan are you using it ?
if not
suspect you will have to update that and the internet might click straight in then retry the driver

Roy
My System SpecsSystem Spec
06 Apr 2017   #5
William N

Windows 7 Home Premium 64 bit
 
 

Hi Roy, i tried installing it but i got an error stating that the F8 does not support the win 7 64bit version.
My System SpecsSystem Spec
Reply

 Recently installed Win 7 and can't connect to the internet




Thread Tools




Similar help and support threads
Thread Forum
network controller driver not installed. unable to connect to internet
I just came home from overseas to discover my wife tried to modify our custom built computer. I am not sure of the specs off the top of my head. I wiped it out and re-installed windows 7. Now, I get a no driver for the network controller and other device yellow triangle. I have an ASUS mobo and...
Network & Sharing
Re installed Windows 7 and can't connect to internet
I had to re install windows 7 , when i try to connect to the internet it says I am missing drivers, when I click download drivers it tells me it can't find any. Help? its not Wireless so i need drivers for LAN?? is that right............................... this is the pc i got IS... ...
General Discussion
Just installed windows 7, no modem drivers, cannot connect to internet
ok so i just got a new computer with 32 bit XP on it and upgraded it to win7 ultimate 64 bit, and i lost my modem drivers. the modem (thomson speedtouch 546(i)v6) didn't come with any CD, and i can't seem to find drivers for it online. any idea how i can fix this? (internet was working before...
Drivers
Re installed Windows 7 and can't connect to internet
I had to re install windows 7 and wipe my hard drive due to a BSOD, when i try to connect to the internet it says I am missing drivers, when I click download drivers it tells me it can't find any. Help?
Drivers
Autochk cannot run due to a recently installed program
Hi! Recently I have started up my pc and it says that it will check for errors (disk check) on my local "C:" disk. This is normal. But what is not normal is that it will say " cannot open volume for direct access" " this might be due to a recently installed program" I have Norton 360 Premier...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App