Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to connect to 127.0.0.1 on any port.

01 May 2017   #1
BTGbullseye

Windows 7 Ultimate x64
 
 
Unable to connect to 127.0.0.1 on any port.

Ok, so I've been having this issue for some time now, and it primarily happens with games. (but it also interferes with O&O Defrag, since it uses localhost connections to control its services) They try to connect to a localhost server using 127.0.0.1:XXXXX and are never able to. Nobody has been able to figure out what's causing it, or how to fix it.

Windows 7 Ultimate x64, all IIS services installed.

Already tried DNS flushing, removal and disabling of all firewalls/antiviruses, reinstalling everything related to the networking system of Windows, services enabling/disabling, and full settings resets for everything related to the networking system.


My System SpecsSystem Spec
.
01 May 2017   #2
samuria

win 8 32 bit
 
 

Welcome to the forum. What is running on the port and what error do you get what port is it running on can it work via local network?
My System SpecsSystem Spec
01 May 2017   #3
BTGbullseye

Windows 7 Ultimate x64
 
 

It's a large variety of different ports, and many different services. Singleplayer games, (like OpenRA for its singleplayer) O&O Defrag, etc.

No errors arise, it just sits there never connecting. (and considering how many different programs from different developers, I doubt it's an issue with their software)
My System SpecsSystem Spec
.

01 May 2017   #4
samuria

win 8 32 bit
 
 

What firewall are you using some still block thing even when disabled as they run as a service if you try local host is it the same?
My System SpecsSystem Spec
03 May 2017   #5
BTGbullseye

Windows 7 Ultimate x64
 
 

Only have the default Windows 7 firewall, no others have been installed since I last wiped the system and started with a fresh install... I have tried it both enabled and disabled, with and without exceptions.
My System SpecsSystem Spec
03 May 2017   #6
samuria

win 8 32 bit
 
 

My System SpecsSystem Spec
04 May 2017   #7
BTGbullseye

Windows 7 Ultimate x64
 
 

As I already said, (just not in a very clear way) been there, done that. No change whatsoever. I've done literally everything it is possible to do with the Windows firewall, with no change in the issue.
My System SpecsSystem Spec
24 May 2017   #8
BTGbullseye

Windows 7 Ultimate x64
 
 

2 weeks, and still nobody has any idea what's going on?
My System SpecsSystem Spec
Reply

 Unable to connect to 127.0.0.1 on any port.




Thread Tools




Similar help and support threads
Thread Forum
Can I connect an SSD 120Gb OS to a USB port?
Can I take my SSD 120Gb OS with me & plug into another PC via a USB cable & port same as one would use a flash drive?
Hardware & Devices
Can't connect to internet "Windows was unable to connect to this netwo
Hello guys, I have just finished my very first computer build and am rather happy with most things. Unfortunately I am having problems connecting to the internet. I have a temporary dongle in place and because it's my only option for about a month I kinda need it to work. When I first...
Network & Sharing
How to connect additional DVI monitor to HDMI port
Hi I have an i5-based DG67BL intel motherboard computer that has a DVI and HDMI ports with one DVI monitor connected to the DVI port. I added an GeFORCE 210 graphics card to it that has a VGA and a DVI ports and connected additional two monitors to it. So far computer is working fine with...
Graphic Cards
Cannot connect to any open port
I have a desktop computer that I haven't started for around half a year. Last week, when I started it, it made a lot of updates and later when I wanted to connect my laptop to it, it didn't work. This used to work in the past, so I started to debug the issue. I have Avast antivirus and the Windows...
Network & Sharing
cmd could not connect to the host on port 23
Microsoft Telnet> o < to > towel.blinkinlights.nl...could not open connection to the host, on port 23: connect failed :( this has also not worked when i have tried to connect to a IP address and i would be happy if any one could help thanks, Dan:)
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App