Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: LAN connection (driver) lost

16 May 2017   #1
white wolverine

Windows 7 Professional x86
 
 
LAN connection (driver) lost

Yeah so today suddenly out of the blue I lost my LAN connection (network and sharing center says no connections are available). I am saying out of the blue not as a novice (which i probably am) but because it was actually OUT OF THE BLUE. AFAIK, I have not done any suspicious downloads at all and no other such risky activity. And the worst thing is I can't fix it. OK as far as the problem goes, normal troubleshooting says that either my lan chord is broken or the network driver is faulty. I had the drivers in my disks and I tried installing it, in vain. The exact error it gave was something like "No ethernet cable found, if you have put your pc in deep sleep mode then remove it". I tried restoring my pc but the only available restore points were today itself, and one of them was 10 minutes ago (suspicious) I still tried to restore it but to no avail. I went into the device manager and surprisingly the ethernet driver was missing. So now I am clueless as to what to do. Please help.


My System SpecsSystem Spec
.
16 May 2017   #2
MeOnMine

Windows 7 Ultimate x64 SP1 OEM
 
 

Hi and welcome to Seven Forums.
It sounds more like Virus to me, sorry to say.
First try to replace your LAN cable as yours maybe faulty.
Go to Asus and download your M/B updated driver if one is available.
If it will not install then you will need to download on another PC Malwarebytes.
Install and remember to un-tick Trial version.
You will not be able to update it with no internet so run it as is.(re-boot first)
I am not sure on your choice of Virus scanner but run that also.
If none of this is doable then remove the drive and scan it on another PC.
Virus and Malware can disengage your LAN driver and stop you from correcting it.
My System SpecsSystem Spec
16 May 2017   #3
white wolverine

Windows 7 Professional x86
 
 

Hi
Thanks.
I had been suspecting virus but needed a little proof to ascertain it.
I have been using Malwarebytes on my laptop but since this is my parents desktop they decided to get some antivirus on it.
Scanned using Malwarebytes.
Was virus after all.
Thanks.
My System SpecsSystem Spec
.

Reply

 LAN connection (driver) lost




Thread Tools




Similar help and support threads
Thread Forum
Lost wireless connection
I have a HP Pavilion dv8 using Windows 7 Premium Home 64-bit. I also use Norton 360 Antivirus. A couple of days ago my wireless connection started going in and out. Then, it just quit working. I thought it was the modem at first, but another computer and a Kindle still connect fine. I...
Network & Sharing
Unexpectedly Lost Connection
Virtually every time I open Windows Live Mail I get an error message saying that the connection to the server has unexpectedly been lost due to timeout, etc. I have an AOL mail address and have no problems with my Mac, or my iPhone, only Windows Live Mail. Any thoughts?
Browsers & Mail
Wireless network connection lost internet connection
Hi everyone, I work in an office where we have a main desktop computer which is connected to the internet via a Time Warner modem. The modem is connected by cable to a netgear wireless router, and up until today there have been no problems connecting to the internet from the laptops that use the...
Network & Sharing
Bluetooth connection lost
I have got this Bluettoth dongle which i've been using for 5 years on my old computer with windows xp and had no problems at all. So now on windows 7, i just plugged in the bluetooth dongle and it installed the drivers and it works the same way as on xp, but i cant transfers files, like long...
Hardware & Devices
Internet connection lost when using IE 8
For the past couple of weeks my internet connection has been failing 5 or 6 times a day. My ISP has been working to try to solve this problem but all their tweaking hasn't helped much. I have now noticed that the connection gets cut off when I click on a link to open a site in IE 8. I'm not that...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App