Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No internet despite excellent connection to router

22 Dec 2017   #1
bluehorse

64 bit windows 7 home premium
 
 
No internet despite excellent connection to router

I have limited computer knowqledge but manage to sort my computer problems by Googling. You learn a bit doing this and now I have become go to guy for my family's tech problems. I have been trying now for about 30+hours to solve my brother's problem. His laptop is an old sony vaio core 2 duo.

He basically has no internet despite having an excellent connection to his router. I have tried the following fixes and many others I now can't remember:
Rebooting router
Disabling firewall and antivirus
netsh winsock reset and int ip reset
checking ipv4 values in adaptor
deleting wireless adaptor and rebooting
updating wireless adaptor drivers
updating OS from Vista to Win 7 home premium as vista seemingly doesnt support wpa encryption

Here is his ipconfig all results


Windows IP Configuration

Host Name . . . . . . . . . . . . : tinternet
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : 00-21-4F-4D-82-FD
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Marvell Yukon 88E8055 PCI-E Gigabit Ethernet Controller
Physical Address. . . . . . . . . : 00-1D-BA-83-BD-07
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) WiFi Link 5100 AGN
Physical Address. . . . . . . . . : 00-21-5D-DD-B5-42
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IPv4 Address. . : 169.254.86.247(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{714C7CCE-8733-48B3-8F78-3E421EF5090E}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{90B9F76B-DCD6-4562-B255-78470354B63C}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


The 169.x.x.x shows that the laptop doesn't recognise the router or vice verca. The fact there is no default gateway is also odd. I have manually tried entering it in the ipv4 value under properties in the network adaptor but it always remains blank.

My connection, and my brothers(we live in different houses) are both BTHome hubs which are fibre cable, tho the last part is on old copper telephone wire from nearest box to our houses.

To compare ipcoinfigs, here is mine from a laptop in my home which can access the internet via the same router with no problems.

Windows IP Configuration

Host Name . . . . . . . . . . . . : User-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : home

Ethernet adapter Local Area Connection 3:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : TAP-Windows Adapter V9
Physical Address. . . . . . . . . : 00-FF-E2-AD-36-FF
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::f4fc:7d04:749e:b900%19(Preferred)
IPv4 Address. . . . . . . . . . . : 10.51.10.6(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.252
Lease Obtained. . . . . . . . . . : 22 December 2017 13:50:58
Lease Expires . . . . . . . . . . : 22 December 2018 13:50:58
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 10.51.10.5
DHCPv6 IAID . . . . . . . . . . . : 604045282
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-1C-EA-33-24-B6-FD-FC-2E-D3
DNS Servers . . . . . . . . . . . : 209.222.18.222
209.222.18.218
NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Wireless Network Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
Physical Address. . . . . . . . . : E0-06-E6-02-20-1C
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : C0-18-85-D6-F9-FD
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : mar.pri
Description . . . . . . . . . . . : Intel(R) 82579LM Gigabit Network Connection
Physical Address. . . . . . . . . : 24-B6-FD-FC-2E-D3
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : home
Description . . . . . . . . . . . : DW1530 Wireless-N WLAN Half-Mini Card
Physical Address. . . . . . . . . : E0-06-E6-02-20-1C
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2a00:23c4:f103:bc00:fd9e:b08c:e7ab:5041(Preferred)
IPv6 Address. . . . . . . . . . . : fdaa:bbcc:ddee:0:fd9e:b08c:e7ab:5041(Preferred)
Temporary IPv6 Address. . . . . . : 2a00:23c4:f103:bc00:9cce:6a72:56aa:af2b(Preferred)
Temporary IPv6 Address. . . . . . : fdaa:bbcc:ddee:0:9cce:6a72:56aa:af2b(Preferred)
Link-local IPv6 Address . . . . . : fe80::fd9e:b08c:e7ab:5041%11(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.66(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 20 December 2017 08:49:15
Lease Expires . . . . . . . . . . : 23 December 2017 13:52:37
Default Gateway . . . . . . . . . : fe80::2620:c7ff:fe7c:761%11
192.168.1.254
DHCP Server . . . . . . . . . . . : 192.168.1.254
DHCPv6 IAID . . . . . . . . . . . : 249562854
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-1C-EA-33-24-B6-FD-FC-2E-D3
DNS Servers . . . . . . . . . . . : 192.168.1.254
NetBIOS over Tcpip. . . . . . . . : Enabled
Connection-specific DNS Suffix Search List :
home

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.home:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{5088F9AE-833F-40EF-BD99-54DD316F31A3}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.mar.pri:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{E2AD36FF-BE90-4739-8A54-E8FCBB4EB19D}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #5
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{6AF62CE9-8D4F-47FF-8568-A1EB5AF2F596}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #6
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


Any help greatly appreciated. I have also downloaded and run the tool listed in the sticky incase you need data from it.


My System SpecsSystem Spec
.
22 Dec 2017   #2
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Bluehorse,

Plug in the ethernet cable, if it connects tells us somethings wrong with either the network settings or the card or driver.

That card should work fine, i should know thats what im connected with, using driver V14.3.2.1 (2012)
note this is a dual band card 2.4 or 5

Open device manager
Right click select properties

General - should tell you the device is working correctly
Advanced MY SETTINGS
Auto
Auto
Enabled
11
802.1 b/g
Dissabled
wmm dissabled
Enabled
CTS to self ENABLED
No pref
Highest
Enabled
Highest
No 6

Under Network & Sharing
Whats showing on identified networks
BT123456 >> WPA2 >> ANY >> Automatically connect..

If you click on the signal bars does it show your network.
Really silly time
is there an ON/OFF F key as well as a switch

Roy
My System SpecsSystem Spec
22 Dec 2017   #3
bluehorse

64 bit windows 7 home premium
 
 

Hi Roy

Thanks for replying.

I had tried connecting ethernet cable. It didn't work surprisingly as a lot of the similar problems I found Googling didn't have wirelesss but worked fine connected via ethernet.


My value start 802.11n channel width 2.4, 802.11n channel width 5, 802.11n mode, then 4 ad hoc choices. There is also something to the right that says value 20Mhz, I tried changing this to its only other option of Auto with no success.

My network just says unidentified. It also saysd public network. For some reason either I can't remember or it is not allowing me to set it up as a home network.

I'm not sure to be honest if any function key acts as a on/off wireless switch. Am Googling this model to find out.

Edit: Seems if a Vaio laptop has a physical wireless on/off switch as this one has it will not have a fn key also do this job.
My System SpecsSystem Spec
.

22 Dec 2017   #4
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi BlueHorse,

In the device manager tabs, i asked you to look at

General --- does it show this device is working correctly

Advanced

When you select an item in the left hand coloumn the right hand window value is what its currently set as.

Change the values to the same as mine,click down arrow for choices. >> they are in descending order <<


Where did you get the media to install W7, it might be corrupt
Does the comp work OK otherwise


Roy
My System SpecsSystem Spec
22 Dec 2017   #5
bluehorse

64 bit windows 7 home premium
 
 

Sorry, forgot to say it is working properly in general tab.

Didn't quite understand what you wanted before for these values, but think I do now, my values are:
20MHz
Auto
11
0. 802.11 b/g
disabled
wmm disabled
cts-to-self enabled
1. no preference
3. medium
disabled
5. highest
4. 802.11 b/g

Windows 7 bought activation key on ebay.

Sorry for slow reply, i type slow and going between 2 laptops is slowing me down.

Many thanks for your help.
My System SpecsSystem Spec
22 Dec 2017   #6
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Bluehorse,

Didnt mean the Key, the actual DVD that had W7 OS on it, when you installed it.

I've got more options listed than you, is the driver this, see screenshot.

Id be wary of that key from Ebay, i can check it for you if you like, no personal data in it
run this tool, copy/paste the output
http://go.microsoft.com/fwlink/?LinkID=52012

Roy


Attached Images
No internet despite excellent connection to router-wifi.png 
My System SpecsSystem Spec
22 Dec 2017   #7
bluehorse

64 bit windows 7 home premium
 
 

Yes, it's the exact same driver, Roy. I, too, thought the property options I had were a little strange when I compared them to my results for my own laptopt. But since they have different drivers I put the difference down to this.

The activation key came with instructions and an iso. TBH I suspected this was a bit dodgy but I did a small bit of research and they were citing a recent US court case as a reason for something or other and it was all well written their arguments so I just bought it.

The 30+hours I have spent trying to fix this have mostly been spent when the OS of the laptop was vista as it came with. I only changed it as my nth attempt at fixing it as I had come across quite a few mentions that Vista does not support wpa2 encrytpion so I thought at the tiome that the OIS might be the problem and updating to windows 7 would solve it. Not the case. I will be buying a proper copy or more likely reverting back to vista oncve this is sorted tho i doubt now it can be.

Thanks again Roy for your help.

Edit: I don't think I can check this copy as I am replying from my computer so clicking the link would examine the copy of my Windows 7 which I am certain is legit. My bro's laptop has no internet so I assume I could not chewck it with the link?
My System SpecsSystem Spec
22 Dec 2017   #8
samuria

win 8 32 bit
 
 

Can you try setting the router to open ie no password and see if it connects then it can be that it cant understand the encryption on the router
My System SpecsSystem Spec
22 Dec 2017   #9
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Bluehorse

go to Heidoc, you can get a genuine iso from there. DO a clean install
Burn it to a cd or drop it onto a USB, min4gb.

links

Windows ISO Downloader
Windows USB/DVD Download Tool - Microsoft Store

Roy
My System SpecsSystem Spec
22 Dec 2017   #10
bluehorse

64 bit windows 7 home premium
 
 

Tried it, no joy.

I am beginning to think a clean install is the only answer and no much hope at that.

I really think the problem is related to why the computer doesn't seem to recognise the default gateway given to it.

My bro's computer was chock full of bloatware and riddled with viruses so maybe some program is interfering. TYrouble is, the only portable app virus program I could get to work was Clamwin, and it was very poor. It took 6 hours to complete a scan and at the end of it just issued a report with no actionable steps able to be tasken by the program to quarantine or remove threats.

Thanks again for your suggestions.
My System SpecsSystem Spec
Reply

 No internet despite excellent connection to router




Thread Tools




Similar help and support threads
Thread Forum
what about getting my own internet connection router?
hello, by my math I have spent over $400 on modem rental with my internet, Oceanic Cable in Honolulu. I want to get my own modem. It seems easy enough to set it up according to directions at Oceanic site. Without the cost of the monthly rental I can upgrade speed by a factor of 4 for the same...
Hardware & Devices
Router keeps dropping internet connection
Good Day My router at work is working fine, at least for LANing...as for its connection to the internet, it keeps dropping the connection. The router will be connected to the internet for say an hour or 2, sometimes more, and then it drops the connection. Usually a router restart(either from...
Network & Sharing
excellent wireless connection, no internet access
Hello all, Long time lurker, first time poster here. I just installed 32-bit win7 ultimate on my laptop, and am (still) having a spot of bother getting my internets from a public router located near my girlfriend's place. My problem is the following: I connect to the router fine and the...
Network & Sharing
Slow internet - Excellent Connection
Hi, I've used my laptop absolutely fine for months on my wireless network, getting 2.3 meg a sec downloads on my 20meg connection, happy days! HOWEVER recently my laptop has decided that it doesn't want to cooperate now and after about 3 mins of booting up the connection goes from 2.3 straight...
Network & Sharing
How to share internet connection without a router
Hello I am currently in a student housing and have an internet connection through a lan cable that comes out of the wall, so i have no access to anything. I just bought a eeepc with windows 7 and have an older laptotp with also windows 7. My old laptop is connected to internet and i would like...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App