Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SMBv1, 2, 3 - how to tell if installed?

16 Apr 2018   #1
teckneeculler

Win7Ultimate
 
 
SMBv1, 2, 3 - how to tell if installed?

I'm having trouble getting an external device to see my W7 network.

Online info mentions a possible need for the SMB (Server Message Block) protocols.

I seem to recall there was some recent problem involving the WannaCry virus and SMB, and I'm wondering how to tell if it's still in my system.

A search of Windows Features didn't find any listings.

Any tips? Uh...please don't point me here: https://support.microsoft.com/en-gb/...ws-server-2012

I've looked at there and I'm afraid I'm no wiser. Is there a simple test that will reveal the SMB status in my W7 Ultimate 64bit system?

Thanks :-)


My System SpecsSystem Spec
.
16 Apr 2018   #2
Barman58

Windows 10 Pro x64 x3, Ubuntu
 
 

SMB1 has been depreciated by Microsoft due, as you say, to last year's WanaCry incidents

The problem is that SMB1 although outdated is still the default for many "Smart" Network devices, (a lot of Linux versions used in these systems still default to the unsecure SMB1), If you can change your devices to use SMB2 or SMB3 then this is the best way.

In the real world it's not likely to be possible to change the firmware of devices.

Make sure your system is as fully hardened against the vulnerabilities in SMB1 before doing anything (Antiransomeware from a 3rd party is possibly the best idea) check for emergency updates from MS that protect Windows 7 (Win8 & 10 are covered by design) Be careful as the first stage of microsoft's emergency response to Wanacry was to simply switch off SMB1

You need to get to the Add & Remove Windows Features in computer management?? ( not used Win 7 at this level for a while), to change the status of the SMB 1,2,& 3 - make sure they are all active and reboot - you should then find the externals will work, ( if they use the old Computer Browser System, which depends on SMB1 to work, then it could take a few hours to propagate across larger networks )
My System SpecsSystem Spec
16 Apr 2018   #3
Barman58

Windows 10 Pro x64 x3, Ubuntu
 
 

My System SpecsSystem Spec
.

4 Weeks Ago   #4
teckneeculler

Win7Ultimate
 
 

Thanks Barman58. Now that you mention those events, I remember doing something about the WannaCry thing, but not exactly what

However, I wasn't affected.

Re Windows, features, there's no mention of anything beginning with SMB. I opened up every option and couldn't find anything that looked like it. There are a lot of references in the Registry, however, but nothing in the Lanman\Parameters sections, where it's supposed to be.

Could it be that it has to be re-entered - a DWord value created?

Incidentally, the device I referred to is a Linux-based media player. It won't see past my modem, so perhaps it's looking for a SMB server that isn't enabled?
My System SpecsSystem Spec
4 Weeks Ago   #5
Barman58

Windows 10 Pro x64 x3, Ubuntu
 
 

Sorry My Bad

The option in Windows 7 can only be changed by using Powershell as described in the tutorial in my above post

Enable or Disable SMB1 File Sharing Protocol in Windows Windows 10 Tutorials

If the "Modem" is a Router/Modem and it handles network connections then it may have a option to be switched On/Off for the SMB protocols. Also if this is a device supplied by the ISP then they may have been "Helpful" and switched SMB1 off remotely
My System SpecsSystem Spec
4 Weeks Ago   #6
teckneeculler

Win7Ultimate
 
 

Thanks again, Nigel. You seem to have a handle on this fairly obscure topic, and you've already provided more info than I've been able to glean from other sources.

The modem is a Thompson TG582n, provided by NZ Telecom, or 'Spark' as they're now called. I don't know about their involvement with the SMB deployment but I'd guess against it. That modem was released some time before the WannaCry virus appeared.

Regarding the Linux 'reliance' on SMB, this brings up another of my issues: I have several Western Digital TV Live media players which have no trouble connecting to my network.

BTW, the network is hard wired: an RJ65 cable connects my network to the media player, and the player's connected by HDMI to the TV.

So, given that Western Digital media players run Linux-based software (AFAIK), I wonder why they easily see my PC file source, while the new box - a Vero 4K - does not.

Any thoughts on this?
My System SpecsSystem Spec
Reply

 SMBv1, 2, 3 - how to tell if installed?




Thread Tools




Similar help and support threads
Thread Forum
Windows10 Icon not visible - KB2952664 is installed but not installed?
Hello, I recently decided I would attempt to upgrade to Windows 10. However the icon was not visible. I thus googled the problem and found this site: Windows 10 Upgrade: How to Upgrade to Windows 10 ‚ Which states: "If you donít see it, visit our Q&A page for more info." directs you to:...
Windows Updates & Activation
Win 7 SP1 Installed, Previously Installed Updates Reappear
I recently installed Windows 7 Service Pack 1 for my Windows 7 Home Premium 32-bit edition. As the installation finished the computer restarted and I did not give it another thought. Later on I returned to the Windows Update screen to see if there were any recent updates available for my PC. To my...
Windows Updates & Activation
installed HD 2600 pro card, installed AMS driver, but no ccc software?
I was wondering if this would help? https://www.sevenforums.com/graphic-cards/195195-fix-catalyst-control-center-ccc-will-not-open-install.html I see no evidence that the AMD driver installed at all. Right click desktop does not show ccc, and ccc is not in the lower right panel. Windows...
Graphic Cards
neo basic 2165 - 4gb installed but only shows 3gb installed
hey guys got an issue her thats been like a stubbed toe - just cant let go of it - im using a dual core neo basic 2165 - i just recently upgraded my ram to 4gb 2x - 2gb -ddr2 800 but it just shows 2.75 usable - and only 3gb installed - ive tried every thing so far- still same result-...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App