Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ethernet adapter problem? Slow browsing and downloading/ buffering vid

08 Sep 2018   #11
supashaka

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by samuria View Post
It will remain with new router if the rest is set to dhcpit works best for all devices
So I haven't yet played around with changing DNS but I wanted to update you since you helped me. I bought a new network card which arrived the same day as the virgin media installation. On the new 100MBPs virgin media connection I got 110 MBPs and....all the problems were completely solved (with the original built in network card)!

When I changed back to the old origin broadband connection I disabled the normal network adapter in device manager and installed the new one, and that also solved all the problems. The speed is now constant and doesn't jump up and down, the buffering is (mostly) gone and downloads are back to normal (original) fast speeds. I think the fact that some buffering does still occur (3 times in 15 min on Iplayer) reflects the only thing which hasn't changed: the max speed is still coming up as 8.9 MBPs (but at least it's now consistent).

So the big question: what actually caused all this? With the original NIC when I plug in the virgin ethernet the problems are gone, so at 1st I thought the culprit must be the Openreach connection (probably within my premises). Then the new NIC solved the problem also so I'm back to thinking it could still be the old NIC which somehow developed a fault (taking into consideration the fact that all other devices were always working fine)?

Before we had the torrential down-pour of rain that day, we used to get around 12 MBPs and immediately after that day and all the problems it brought (re-read the OP) it was 9 MBPs max and completely unstable. Now it's still 9, but stable. The problem is when my current Virgin contract expires the price will go way up and I'll have to go back to an openreach connection, so I really do want to try to figure out the solution. But Origin broadband (and any other company I'm guessing) say if they send out an openreach engineer and their equipment shows my PC to be at fault then I'll be charged 175 or whatever it was!


My System SpecsSystem Spec
.
Reply

 Ethernet adapter problem? Slow browsing and downloading/ buffering vid




Thread Tools




Similar help and support threads
Thread Forum
ethernet adapter problem error 651
I have a desktop of dell with intel pentium. I just took a net connection for that but when i connect my modem it says ethernet cable not connected.when i checked the details on the ethernet adapter it says manufacturer unknown and device type other device.how can i solve this?
Network & Sharing
Slow Internet Browsing Problem
Hi, I installed Windows 7 couple weeks ago and found out that the Internet browsing is really really slow. I reinstalled it twice and the same thing is happening. My computer has 4GB of RAMS and on E8400 processor so I dont think it's my computer's problem. I have tried IE8, Firefox, Google...
Browsers & Mail
Extremely slow browsing and downloading when connected to public WiFis
Hi Recently I've been experiencing some painfully slow internet browsing and downloading speeds on my Sony Vaio VPCSE, it's basically not possible to use internet because of this. These problems first occurred about a week ago and came from nowhere. So far I've tried to connect to three...
Network & Sharing
Network adapter/wired ethernet problem
I have googled this problem for hours now with still no solution. gigabyte p67-ud4-b3 motherboard windows 7 home premium it was 100% working until something crashed my system and it wouldnt boot up again blablabla. so i reset comos and everything was fine/back to normal, except that my...
Hardware & Devices
Slow buffering on net viewing
Since I up graded to a new Compaq tower with win 7 pre installed I am experiencing very slow buffering of videos from the net. On my older tower with XP sp3 videos loaded rapidly. Are there others with the same issue? Possible settings to check? 3 GB+ memory lots of Virtual and the g force video...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:50.
Twitter Facebook Google+