Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network and Sharing Centre (NaSC) cannot see Wireless USB Adapter

2 Weeks Ago   #1

Windows 7 Home Premium SP1 64-bit
Network and Sharing Centre (NaSC) cannot see Wireless USB Adapter


Hope the good folks out there can solve this one ... driving me mad!

Desktop PC running Windows 7 Home Premium (latest patches applied).

I cannot see the wireless USB adapter in Network and Sharing Centre (NaSC) - it says 'No Connections are Available".

Have gone into Device Manager & checked on driver (says latest driver installed).

Have ripped device and driver out through Device Manager and restarted PC - still can't see the adapter in NaSC

Talked to Chat Agent at Belkin (adapter is Belkin Surf N150 Micro USB Adapter) and he suggested reinstallation of original software from the CD. This doesn't fix the issue.

He's now asked me to download some new firmware.

Will report back.

In the meantime, any suggestions?


EDIT: Needless to say, not fixed.

What I don't understand is that the adapter shows up in Device Manager and reports that driver is latest version, but Network and Sharing Centre can't see it. Unplugging and plugging the adapter back in gives the Windows sound of a USB device being unplugged and plugged back in and I've tried several different USB ports on my machine. All other USB devices (e.g printer & memory sticks) work fine in these USB sockets - so I figure the USB sockets are working fine.

Device Manager has no alerts for USB devices / Root Hubs or the Network Adapters

Thus far, I'm stumped.

What I DON'T get is that I WAS (sadly no longer) able to print to my two WiFi printers if the Cat 5 Ethernet cable was plugged into the router but not if I removed the Cat 5 cable. What is going on there?

My System SpecsSystem Spec
2 Weeks Ago   #2

win 8 32 bit

What does it use to connect. Wifi can use windows service or one from makers they cant both run at same time so if there is makers wireless service running windows can see it or start. Check if there is makers connect utility installed
My System SpecsSystem Spec

 Network and Sharing Centre (NaSC) cannot see Wireless USB Adapter

Thread Tools

Similar help and support threads
Thread Forum
Network and Sharing is using Wireless adapter instead of ethernet
I will try and make this a simple as possible. I have 2 laptops. The first is running Windows 7 ultimate and the other, Ubuntu 12.04. They are connected via Ethernet through a Linksys BEFSR81 router. Both computers have static Ethernet addresses. I have a wireless router and both computers use...
Network & Sharing
internet connection setup in Network and Sharing Centre corrupt!
hi all, I should state first of all i'm a newbie to computers so if you have any responses please write in layman terms. I connect to the web through a modem which is connected to a D-link router, this worked fine until about 2 weeks ago. I can connect to net but the set up in doing so has...
Network & Sharing
Net Adapter works but not visible in Network and Sharing centre W7
Hello W7 Forum'ers My Eth Network Adapter works fine and shows no errors and is visble in device manager running with the latest driver. However I cannot see the network adapter in the Network and Sharing centre. Normally I use wireless and that always works fine and i can see that in the...
Network & Sharing
Wireless adapter not visible in Network &Sharing center
Hi I have a Dell XPS 420 with a 64 bit windows 7 pro installed. My computer has a Broadcom 802.11g wireless adapter. I can see the adapter in network adapters (It has a red cross underneath it). But I dont see this adapter in the Network and Sharing center. Can someone help me with this problem....
Network & Sharing
Network Adapter Not Shown in Network and Sharing Center
I have windows 7 Ultimate installed (was originally installed as a clean install) and have ever since it was RTM. Everything has been running flawlessly and still is except for one thing. My network cards don't show up under Network and Sharing Center, but they do show normally under device...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:05.
Twitter Facebook Google+