Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WIN 7 NAS + XP-PC not showing

21 Nov 2018   #1

Win 7 Profeesional x64
WIN 7 NAS + XP-PC not showing

Hi there,

I am new to this Forum, but not new to computing (on it since the 8086 processor and before).
Recently I ran into a problem (after a move from Trend-Micro to Bitdefender) for which I can not find a solution or work-around, despite several hours of reading.

Maybe somebody knows the matter is addressed already and just points me to the right thread.

However, the issue is:
I am running a private home network (mostly LAN) behind my access point. There are 3x Win7, 1x XP, 1x Mac, 1x Linux + 2x NAS involved (apart from printers).

My current focus is on one Win7 PC which apparently lost it's ability to see the 2x NAS and XP components.

I have deleted and recreated the credentials and managed to map 2 driver letters to the 2x NAS.
These will also reconnect after reboot.

They are all member of the same work-group and SMB is active on the NAS. Everything runs on fix IPs.

Nevertheless they will not show in the IN-Explorer's Network section. Same goes for the XP.

If I enter their NW name in IN-Explorers address line manually ....
e.g.: \\LSD220-2TB\Share00

.... they will also show up in the IN-Explorer's Network section.

If I close the window and reopen it, it's gone again. Needless to say it does not survive a reboot.

Any hint or guidance welcome ....

best regards to all,

My System SpecsSystem Spec
21 Nov 2018   #2

win 8 32 bit

Welcome to the forum. Do you have NetBIOS running on all PC's it's that which lets you see all PC's via name. Windows doesn't look for PC's on the network it asks the master browser for a list. If you can connect via IP it's either NetBIOS or master browser problem it could be blocked by firewall or antivirus
My System SpecsSystem Spec
21 Nov 2018   #3

Win 7 Profeesional x64

Hi there and thanks 4 the reply,
checking NetBIOS I went through
>> Control Panel >> Network and Sharing Center
>> Local Area Connection <- Left Click
>> Properties
I select ...
>> Internet Protocol Version 4 (TCP/IPv4)

and there is no "advanced" button
there is only
"install" "uninstall" (grayedout) and "properties" active
My System SpecsSystem Spec

21 Nov 2018   #4

win 8 32 bit

If you open a CMD prompt type

Ipconfig /all

It should state at the bottom NetBIOS enabled
My System SpecsSystem Spec
22 Nov 2018   #5

Win 7 Profeesional x64

Hi Samuria,
did that and both entries:
NetBios over Tcpip (in Ethernet adapter Local Area Connection)
NetBios over Tcpip (in Ethernet adapter VirtualBox Host-Only Network)

both say: enabled

+ since i stumbled across the firewall issue before ....
I added exception rules in bitdefender to the related (fix) IP - addresses
(never had this issue with Trend Micro before...)

before posting 1st.

best regards,
My System SpecsSystem Spec
24 Nov 2018   #6

Win 7 Profeesional x64

Hi Samuria,

hence I concluded it should be a master browser issue. I followed:

How to Determine the Master Browser in a Windows Workgroup | Scottie's Tech.Info

only to find that with >> net view << this PC only sees himself (not even showing the other Laptop as in Win-Exp)
next I follwef:

Master Browser Service broken after Creator update

where I get up to the point of:

4.Run “regedit” to open Registry Editor, navigate to “\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services \Browser\Parameters”, ensure the “MaintainServerList” is set to Yes or Auto

5.In the same location of registry, ensure that at least one computer in each subnet, has the “IsDomainMaster” REG_SZ key set as True.

I manage to achieve / confirm Point 4) but fail to get to step 5) ....
Thanks to your very valuable first hint I believe to have moved into the right direction. However it looks like I am stuck again, since I can not identify what is given above as >> same location of registry, at least one computer in each subnet, "IsDomainMaster" REG_SZ ke set as true <<

Any further advice / hint from your end ??

best regards
My System SpecsSystem Spec
28 Nov 2018   #7

Win 7 Profeesional x64

brute force solved,
thank you SAMURIA indeed,
lesson learned I keep with me
My System SpecsSystem Spec

 WIN 7 NAS + XP-PC not showing

Thread Tools

Similar help and support threads
Thread Forum
File not showing up in folder,but showing up in Remove Empty Directori
I am trying to remove empty folders using Remove Empty Directories. I know of a few that are empty, and just ran a test to see if RED would detect they were empty. Well, to my surprise, I am finding that RED shows 1 (or more) file in these folders (a JPG at 0.00 MB), but it's not showing up in the...
General Discussion
Drives not showing, folders/file icons/thumbnails not showing
I have just built a new computer, using Windows 7 Pro 64 bit, however, I've noticed when I open Windows explorer, 3 out of 4 times it will continuously search for drives when opening up explorer and not show any drives that are installed. I've tried reformatting, using different hard drives, but...
General Discussion
SSD not showing in Disk Management, but showing on Intel Rapid Storage
Evening! Have recently formatted my laptop and re installed Windows on my normal HDD because i have a small SSD since formatting my SSD and deleting and renewing the old partition, in windows explorer and disk management i can no longer see my SSD. I can see my SSD in Bios and in the Intel Rapid...
Hardware & Devices
File folder is not showing in my pen drive, showing it is empty.
I have a game in my pen drive that is splits second, my friend had given this pen drive to me, but windows explorer is showing that this drive is empty, i have checked it if it is hidden but still it's not showing after i had changed settings for hidden files, and i had checked the drive...
General Discussion
Toolbar on taskbar should only be showing an arrow but is showing icon
I have a toolbar on my taskbar titled "Programs". It has about eight folders in it. I made another toolbar, and placed it directly adjacent to the Programs toolbar, to obscure the eight folders and force it to be a dropdown menu. Trouble is, as soon as I lock my taskbar, right next to the arrow...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:22.
Twitter Facebook