Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network troubleshooter gives error code 0x8E5E0247 - what's the cure?

13 Jan 2019   #1

Windows 7 Home Premium 64-bit
Network troubleshooter gives error code 0x8E5E0247 - what's the cure?

Fixing a friendís Acer laptop, with a failing HDD, turned out to be quite a challenge. The decision was quickly taken to upgrade to SSD storage. However, a multitude of disk errors severely hampered the upgrade. Eventually, after many attempts with two different programs (and numerous CHKDSK invocations), I managed to clone the HDD, and then finally get the SSD installed. Itís working well now, but there are still a few problems to iron out.

Unfortunately, the system had to be recovered using the Acer eRecovery software before any cloning software would run to completion. This means that the system in now about ten years out of date! So, the next step is to connect to the internet to download any important windows updates.

This is where the system has thwarted my efforts yet again.
It refused to recognise that a router was available at the end of a standard ethernet cable.
Running the networking troubleshooter was denied with error code 0x8E5E0247.
I ran ďsfc /scannowĒ and it reports that there are corrupt file that itís unable to fix.
When I use the recommended search for [SR] tags in the CBS.log, there are no filenames listed at all, just many lines with ďverify completeĒ.
I can confirm that the known problem updates for sfc (KB3022345, KB3035583, and KB3068708) do not exist on the system.
After three cycles of rebooting then running sfc, the result is the same, unknown corrupt files reported.

After a reboot the network manager finds several wireless network connections, but Iím only interested in an ethernet connection at the moment.

The network adapter is a Broadcom Netlink Gigabit Ethernet and itís reported as working properly in device manager, but itís not seeing my hard-wired router.

Any help suggestions on how to best proceed would be very much appreciated.
p { margin-bottom: 0.25cm; line-height: 120%; }a:link { }

My System SpecsSystem Spec
13 Jan 2019   #2

win 8 32 bit

Welcome to the forum. The first bit is worrying if you found a disk with bad sectors they are copied to the new drive, for an SSD drive extra settings are needed and third if the disk is bad you don't know what is corrupted hence your problem. You can spend hours trying to fix it and never get there if the best route is to do a clean install which will give you a good solid system
My System SpecsSystem Spec
13 Jan 2019   #3

Windows 7 Home Premium 64-bit

Thanks samuria, but if I had access to the original system disk that is precisely what I would have done. Alas, there was no option, in order to retain the licence that came with the machine. I am confident that the software used to clone the HDD did a good job. It had a setting to optimise for SSD and it completed normally. The system seems to be pretty good, but obviously it needs a few tweaks.
When I was doing all those CHKDSK invocations I noted the filenames it found problems with, and only two were in a windows system directory (\windows\temp, in fact), so I feel sure this system can be fully repaired.

Luckily, I have a 'Win7 Pro' system disk available to help with repairs.
Is there a quick fix for the faulty troubleshooter?
My System SpecsSystem Spec

14 Jan 2019   #4

Windows 7 Home Premium 64-bit

Report on progress: Updating the Intel drivers has fixed the fault with the networking troubleshooter.
Unfortunately, the network adapter appears to have died, as the troubleshooter can't find why the laptop will not connect.
No activity LEDs have been observed to blink on the ethernet connector and the WiFi is also fails to connect.
This was tested using a router that's known to work on ethernet and WiFi, with another laptop.
Short of swapping the motherboard, I don't know if this can be repaired easily.
My System SpecsSystem Spec
14 Jan 2019   #5

win 8 32 bit

I would try a live linux dvd these are free and run linux just from dvd and dont effect windows see if that sees them it just confirms its a hardware problem not a windows one. If it finds them then the problem is with windows
My System SpecsSystem Spec
14 Jan 2019   #6

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Phil,

Moving to an SSD does NOT invalidate the product key.

As Samari said, if you used a cloning program that does not detecct AND IGNORE bad sectors they will be carried over.

I would just have clean installed W7 with the correct media, Home/Pro etc.

as for wifi it might just be turned Off, clean install would also reset services back to presets

My System SpecsSystem Spec
16 Jan 2019   #7

Windows 7 Home Premium 64-bit

The idea to try Linux was a good one Samuria, thanks.
The WiFi works fine on Ubuntu, but the ethernet interface is still unavailable.
Attempting to run ‘dhclient’ on that port produced no result, the prompt simply hangs.
I take that as a sure sight that a hardware fault exists with the ethernet port.

Rebooting Win7, I used the WiFi connection to update windows.
I think the success of windows update proves that the migration to SSD was sound.
Running network diagnostics in Win7, results in the typical assumption that the “ethernet cable is unplugged”. Of course, it’s not - the router is ready and waiting for a connection.
So, it certainly looks like the port is shot.

Is there a definitive test to verify a broken ethernet port?

p { margin-bottom: 0.25cm; line-height: 120%; }a:link { }
My System SpecsSystem Spec
16 Jan 2019   #8

win 8 32 bit

It could be an irq,dma,address conflict disable it in the bios reboot then go back and enable it somtimes works as it reasigns it
My System SpecsSystem Spec

 Network troubleshooter gives error code 0x8E5E0247 - what's the cure?

Thread Tools

Similar help and support threads
Thread Forum
Manually fixing scripts and network troubleshooter error 0x8007000E
So basically 4 days ago I ran windows upadate and some of the updates failed. After that whenever I try network troubleshooter I keep receiving the same error. Package Id: Unknown Path: C:\Windows\diagnostics\system\networking Error code: 0x8007000E Source: Engine User: USER-PC.USER-PC...
Windows Updates & Activation
Windows Update and Network Troubleshooter not working
Hi folks I have been pulling my hair out trying various options found on the net to get my Windows Update and Network Trouble shooter working. It either just hangs up trying to start or it comes up and says service not turned on. I have checked and the service is in fact turned on. Only change I...
Windows Updates & Activation
Troubleshooter Error Code 0x8E5E0247 Won't start!
Diagnostic Report (1.9.0027.0): ----------------------------------------- Windows Validation Data--> Validation Code: 0x8004FE21 Cached Online Validation Code: 0x0 Windows Product Key: *****-*****-646WF-VXK9B-YVWGW Windows Product Key Hash: 6gMNiY2S2gAo/JUdv98HTRmcJ2w= Windows Product ID:...
Performance & Maintenance
troubleshooter error code 0x80070002
dears, every time i wanna use the trobleshooter it stops for example if i tried to use the network trobleshooter it give me " unexpected error has occurred. the troubleshooting wizard can't continue." when i click on "view error deatails" it gives me the following : Package ID : ...
Performance & Maintenance
Problem using network troubleshooter: error 0x80070490
When attempting to use the network troubleshooter, I receive this error (0x80070490) "A problem is preventing the troubleshooter from starting". I have attached a jpg of the problem, hoping for some answers. Thanks!
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:22.
Twitter Facebook