Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 Doesn't Know It Has A Connection To The Internet

14 Jan 2019   #1
trippb

OS version depends on the hour
 
 
Win 7 Doesn't Know It Has A Connection To The Internet

Win 7 Pro SP1 x32 fully updated
My mom's computer is about to drive me batty. It doesn't realize it is connected to the internet. I've found if I restart the Network Location Awareness service, it will realize it for all of about 5 seconds before changing its mind. It doesn't log anything in Event Viewer. I've used the troubleshooters and netsh int and winsock resets. I've made sure no proxies are enabled in the IE settings. Firewall on and off makes no difference. There wasn't any A/V when I got my hands on it. I'm pretty sure it had either Panda Cloud or AVG on it. I installed each of them and then used their uninstallers to make sure they are fully removed. This happens on WiFi or an ethernet connection on DHCP or with a static address. It has the same behavior in Safe Mode. I don't know when the problem started to trace it back to any updates. Any other ideas?

I'm trying to add an image but it isn't working. Hopefully it will let me post this link: Flickr



My System SpecsSystem Spec
.
14 Jan 2019   #2
samuria

win 8 32 bit
 
 

Welcome to the forum. Check on the antivirus site for uninstaller very often you have to run these tools to totally remove it
My System SpecsSystem Spec
14 Jan 2019   #3
trippb

OS version depends on the hour
 
 

Quote   Quote: Originally Posted by samuria View Post
Welcome to the forum. Check on the antivirus site for uninstaller very often you have to run these tools to totally remove it
That's exactly what I did for the couple A/Vs that I might have put on it in the past.
My System SpecsSystem Spec
.

14 Jan 2019   #4
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

How to upload files to this Forum:
Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
14 Jan 2019   #5
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Test the network using Safe Mode with Networking and, if no errors, try performing a Clean Boot.
My System SpecsSystem Spec
14 Jan 2019   #6
trippb

OS version depends on the hour
 
 

Quote   Quote: Originally Posted by iko22 View Post
Test the network using Safe Mode with Networking and, if no errors, try performing a Clean Boot.
I forgot to add that bit of info. It has the same behavior in Safe Mode. I just edited the original post to add that info.
My System SpecsSystem Spec
14 Jan 2019   #7
johnhoh

Win7 pro x64
 
 

I'm unclear on your symptoms. Can you browse the internet? Does your router show that you have an ip address? Do you have the "no internet access" message in network and sharing center?
My System SpecsSystem Spec
14 Jan 2019   #8
trippb

OS version depends on the hour
 
 

Quote   Quote: Originally Posted by johnhoh View Post
I'm unclear on your symptoms. Can you browse the internet? Does your router show that you have an ip address? Do you have the "no internet access" message in network and sharing center?
Take a look at the picture I linked to in my original post to see what I'm seeing. It is causing issues with Windows file sharing and TeamViewer because they don't think I'm on the network. But, I have a good address and can browse the internet.
My System SpecsSystem Spec
Reply

 Win 7 Doesn't Know It Has A Connection To The Internet




Thread Tools




Similar help and support threads
Thread Forum
USB internet connection works, Ethernet internet connection does not
OK. I'm trying to switch from wireless to a faster(?) ethernet cable based internet access. I use a Dell Optiplex 755, 32 bit OS, Windows 7. I'm the utilizing Comcast high speed internet supplier, a LinkSys E4200 wireless router, a LinkSys WUMC710 (wireless-ac universal media connector; with...
Network & Sharing
LAN connection without internet stops wireless internet connection
Well I've fiddled around and searched to no avail ... I have some form of conflict between my main wireless network and a LAN I use for file transfer and streaming. The attached PDF file illustrates the setup. Basically, the wireless network is fine by itself. Music streams from the...
Network & Sharing
Wireless Internet Works, Wired Connection Doesn't Work
Hi. I formatted both my laptop and desktop computer. When i did with my laptop, everything was great. Wireless still worked. Of course i have my linksys router connected to get the wireless. I then formatted my desktop. Its a dell. When i did this, everything seemed great. However, i...
Network & Sharing
Internet connection just stops and DPS doesn't run
Hi, I'm new to the forum and I have an issue. My 6 month old laptop just spontaneously stopped connecting to the internet. It says it has limited access to the network that 3 other computers all work on. I tried to diagnose it but the diagnostics says Diagnostics Policy Service isn't working. I...
Network & Sharing
Simple LAN, no Internet connection, doesn't work
I'm working on a system using a simple TCP/IP LAN with no internet connection. The current system uses Windows XP with a fixed IP address, no DHCP and running a software connecting to sub-components (UNIX and hardware controllers) through TCP/IP. It is setup to handle small real-time data packets...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:09.
Twitter Facebook Google+