Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wifi refuses to connect after h/w upgrade

19 Feb 2019   #1

Windows 7 Pro SP1
Wifi refuses to connect after h/w upgrade

I recently decided - for technical reasons that are not important here - to change the mobo on one machine but this meant that the o/s's were presented with a new chiptset and graphics. Basically SIS to AMD/ATI.

Expected everything to balk but to my amazement, Win7 fired up and all seemed well - except for Wifi (TPLink WN350GD pci card) which, whilst recognised refuses to see the world. Paradoxically, WinXP (on same multiboot machine) needed much nursing but had maintained the n/w connection and is now all good!

The problem is how to re-establish the wifi in Win7? I can't remember whether, in the original install it recogised the card or I had to install the proprietary drivers. Either way, if the Win drivers are removed and then reboot it is reinstalled, yet if I remove then install TPLink driver (or vice-versa) and reboot, the Win version still reappears and no connection can be seen (red cross on system tray icon)!

Please help.

[BTW MX-Linux booted up without a glitch and active Wifi whilst PCLos ground to a halt after grub menu ]

My System SpecsSystem Spec
19 Feb 2019   #2

win 8 32 bit

Welcome to the forum. You dontsay what version of 7 you have 32 bit or 64 bit. I wonder if you have a 64 bit and the other systems are 32 bit the drivers and FAQ are here Download for TL-WN350GD | TP-Link

It not clear if they do a 64 bit driver which could be the problem. The card is so old and so slow sooner than mess go and get a new one that is n or ac type as this will double your speed yours is old slow g type
My System SpecsSystem Spec
19 Feb 2019   #3

Win7 pro x64

You may be missing a motherboard pre-requisite driver. When switching motherboards its always good to download and install every final driver that the motherboard manufacturer has on their website, just in case
My System SpecsSystem Spec

23 Feb 2019   #4

Windows 7 Pro SP1

To test your suggestion about the chipset drivers so went through the excrutiating process of using WinToUsb to create a bootable Win7 usb (at least 4 attempts of an hour each) which, when presented to the target machine, took a further 9 hours to custom "install" itself to the usb and boot - ugghh! (a livelinux takes 30min to create and 2min to boot).

Anyway, the purpose of the exercise was to test the chipset + win tp-link driver combination which worked fine ootb.

What, I believe, is needed is a sequence of steps to purge Win of ALL - ie Win and TPLink - n/w card drivers so that Win is presented with a clean situation at the next boot. What seems to get in the way is that TPLink don't fully uninstall and still clash with Win drivers- though, I only installed the TPLink drivers because the Win "Atheros" driver fails.
My System SpecsSystem Spec
23 Feb 2019   #5

Win7 pro x64

Here are my thoughts in order of priority
1) Download and install all motherboard drivers from the motherboard site other than the ones you obviously do not need, from post #3. This cannot hurt, and might help.
2) do start > run > cmd > msinfo32 > components > problem devices. This will show the drivers that are not working properly. There may be a couple you have not installed or need to re-install
3) If you are having trouble removing drivers, here's how.
- use start > run > appwiz.cpl to remove any programs that look like they may possibly have installed drivers
- use safe mode to uninstall driver from device manager.
- do a forced removal from the command line: find the device in control panel, then right-click and select Properties, then Details, then find its INF Name in the drop-down list. Then from a command window opened with Admin privileges do start > run > cmd > pnputil.exe -f -d INFName.inf.
- Use Device Cleanup Tool (below) to remove any and all drivers from NON-PRESENT devices.
Tools for Windows
My System SpecsSystem Spec
24 Feb 2019   #6

Windows 7 Pro SP1

Thanks for the comprehensive reply johnhoh.

1) I actually downloaded a set of drivers before buying the mobo. The only ones I could find were for Gateway but am not convinced they're correct as there seem to be anomalies. And I'm surprised that XP coped without them except for graphics which were downloaded from another source.

2 and 3 will need more time but that's a useful link.

I'll report back later.

In the meantime I'd already clocked that device manager > rt click > properties reports that the device is working properly yet no activity lights from the device!
My System SpecsSystem Spec
28 Feb 2019   #7

Windows 7 Pro SP1

Ok, done (2) but nothing is listed under Problem Devices.

This got me wondering whether Win7 was not seeing pci cards so put in DVB-S card which was seen (though not installed) but did show in Problem Devices. (I can't remember whether it had been set up prior to these difficulties).

Yet Win7 insists on installing the Atheros driver, device manager insisting that it is working properly whilst everywhere else reports problems or non-existence! It even appears in network connections as does the ethernet (ie cable) - which does work.

I'd already checked appwiz (several times) but nothing there that shouldn't be.

I haven't done the last step yet but DeviceCleanup reports 126 non-present devices! Most are described as last used 4471 days ago (which is about the age of Win7 isn't it?) but those allegedly used much more recently is more curious.

Anyway, I've wasted too much time and am at the point of biting the bullet and doing what I was trying to avoid - reinstall Win7, with the additional time in adding all my usual apps and hope the process doesn't balk everything else.
My System SpecsSystem Spec

 Wifi refuses to connect after h/w upgrade

Thread Tools

Similar help and support threads
Thread Forum
ALFA AWUS036H usb Adapter REFUSES completely to connect
SOLVED! By me, please see page 2! OK, This is my first post, so go easy on me..! I have a Sony VPCEC2S0E laptop which is less than a year old. I have spent DAYS trying to get the ALFA adapter to work, I have searched the net, and in particular the forums, including this one, and I have...
Network & Sharing
One device refuses to connect to Wifi-Router
Hi, I set up a wireless bridge with my TP-Link TL-WR1043ND to get better signal in my flat. (landlord provides internet via wifi AP but I have bad reception, therefore the wireless bridge) I works flawlessly. I can connect my android phone and my PC to it. Recently I tried to connect with a HP...
Network & Sharing
Lenovo laptop REFUSES to stay connected to internet(wifi AND lan)
HI all, I have a lenovo laptop that is almost exactly a year old and it WILL NOT stay connected to the internet neither by wifi nor LAN. It will connect sometimes for 10 mins, sometimes for ten seconds. I can turn the computer off, restart it, close all other programs, diagnose connection, disable...
Network & Sharing
PC refuses to automatically connect to wireless network
I travel frequently with my Windows 7 Ultimate laptop. I have a Windows Mobile 6.5 phone and use WMWifiRouter to tether my laptop to the phone. (WMWifiRouter actually creates a mobile Internet hotspot.) This provides my laptop with wireless Internet access just about anywhere. WMWifiRouer uses...
Network & Sharing
Netflix refuses to connect in WMC
Until just an hour ago Netflix was working just fine, but now every time I run it, even after running some scans and restarting my PC and router, it won't connect. Whenever I try it sits for a minute before telling me that it can't connect to the internet, even though I can easy watch it in my...
Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:34.
Twitter Facebook