Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network card does not connect to my router

25 Nov 2009   #1

Windows 7 build 7600
Network card does not connect to my router

I own a Belkin Wireless G Modem/Router. I connect my computer to it via Realtek RTL8139/810x wired network adapter.

Just a moment ago, my computer could not connect to the internet. When I ran the troubleshooting tool, it suggested to "Make sure the other end of the cable is plugged into the router. If that does not help, try a new cable."

I checked the LED light on the network card, and it appears to be solid red. I'm not too sure about its usual colour when it was working fine. The modem's LED shows that it detected a connection from the cable. I tried to replace the cable with another one, but it the light is still red and the modem still shows that it detects a connection from the cable, but my windows is not able to connect to the modem. It failed to detect any connection.

I am currently using a D-link wireless USB adapter to connect to the modem.

Can anyone tell me what is wrong? Is there a problem with my settings or is the network card damaged?

My System SpecsSystem Spec
25 Nov 2009   #2

Windows 7 Ultimate x64 SP1

Have you checked the device manager to see if the onboard NIC is having problems?
My System SpecsSystem Spec
26 Nov 2009   #3

Windows 7 build 7600

Yeah, device manager is reporting that the NIC is working fine.
My System SpecsSystem Spec


 Network card does not connect to my router

Thread Tools

Similar help and support threads
Thread Forum
Win 7 unable to connect to wireless network(router)
Hi all, i have some problem with my wireless connectivity, When i try to connect to a wireless network, it keep saying "Unable to Connect to X" (let's assume the network name is X) When using network troubleshooter, it recommend me to turn off the router, keep it for 10 secs, and turn it back...
Network & Sharing
Problem with my Network Card? Can't connect to Wi-Fi!
Hello! Ok so I just switched from Ubuntu 14.04 to Windows 7 (finallyyyy) and now I am stucked with a problem that I never encountered yet. When I want to connect to my Wi-Fi, it's said: ~~~~~~~~~~ "Aucune connexion n'est disponible" No connection is available. ~~~~~~~~~~...
How to connect to same network on one router
Hi there, I work in a small office and use a laptop with Windows 7. We use the same router and have wired internet. His computer is connected to a "Network 4" while mine is connected to the private wireless internet system we've set up. He can't connect to any other connections on his computer...
Network & Sharing
Unidentified Network LAN to router won't connect.
I have tried everything I, and others on many forums, can think of to fix this issue. I have tried static network settings, re installing my network card, restarting winsock, disabling bonjour, route delete, editing the group policy to change unidentified networks to work networks, and many...
Network & Sharing
Trying to Remove Router from Network but Can't Connect Without It
I'm trying to remove my router from my home network and connect my computer directly into the line coming into the house. I'm doing this to, among other things, run some tests to evaluate the impact of my router on my bandwidth. However, removing the line seems to be causing problems. ...
Network & Sharing
USB network cannot connect to router
Hi. I can connect to the router if I use wired LAN. But if I want to connect to the router via a USB network stick, I cannot connect. The conection refuse when I enter the password for the router. Wha can be the reason ?
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App