Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Diagnostic Policy Service Won't Start

21 May 2019   #11

Win7 pro x64

Quote   Quote: Originally Posted by chuckbear View Post
I have tried all the fixes posted on the internet but none are working.
Just to provide a little general guidance here, don't mean to be a complainer, and I realize that the above statement is factual, however it is way, way too inspecific to provide any useful information other than to discourage others from trying to pitch in.

In any case, here is the best thread on the subject. If you tried everything that everyone has posted there and still have issues, its very important that you post back here with your specific results to EVERY solution in the thread, such as you did with your System Error 1378 comment. "Tried everything, nothing worked" are words to always be avoided.

Diagnostics policy service not running on Windows 7 home premium

My System SpecsSystem Spec
21 May 2019   #12

Windows 7 64

Johnhoh, I have tried every suggestion on that thread. I gave you the results of the command prompt. I did try the registry fix but get ACCESS DENIED when trying to add Trusted Installer, I don't have that entry in the registry. In trying to get permissions to grant full access, to administrator, I again get access denied. Even though I am running regedit as administrator and logged in as administrator. There is no current TrustedInstaller entry under Permissions. I don't have an issue connecting to the internet or accessing my wifi as many did in that thread. I have done system file checks with no errors found. I have run clean disk with no change. Chuck
My System SpecsSystem Spec

 Diagnostic Policy Service Won't Start

Thread Tools

Similar help and support threads
Thread Forum
Cannot connect to the Internet. Diagnostic Policy Service not start.
First time posting. Running an Asus Notebook U50F Series with Windows 7 Home Premium, 64 bit, 2 Gig processor w/ 4 GB RAM. I lost the ability to connect to my wireless router or to connect via an Ethernet cable connected to the router. Other devices can connect wirelessly and hard wired so...
Network & Sharing
Diagnostic Policy Service not working
Hello All I am looking for help with a problem I am having with my laptop Dell Inspiron 1545 O/S Windows 7 Home Pemium. It has stopped connecting to the internet through the house wireless router although all other devices in the house can connect. If I try to run troubleshooter I cannot and get...
Network & Sharing
Can't run Diagnostic Policy Service because of Error 5
This started happening when I accidentally turned off my computer whilst it was booting. I have tried sfc /scannow, I have done the CMD thing (net localgroup Administrator) and have tried manually starting the service, to no avail. Here is a screenshot of what I think appears to be the...
Performance & Maintenance
Diagnostic Policy Service cannot be started
I've searched the forum but most error text is different. Mine is simple.. It says I've tried multiple things however I cant get it fixed.. I tried system restore but system restore took 4 days and SURPRISINGLY, the restore failed.. I am planning to do system image restore.. Any help will...
General Discussion
Cannot start diagnostic policy service
i tried to diagnose my internet connection, and it informed me that the diagnostic policy service was not running. so i went over to services.msc right clicked the diagnostic policy service and got the following error: im at loss |:
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:32.
Twitter Facebook