Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet browsing is slow without VPN and often get 404 error

07 Feb 2020   #1
sono

Windows 7 Ultimate 64bit
 
 
Internet browsing is slow without VPN and often get 404 error

I am subscribed to 12mbps cable internet, but on my laptop the connection is dead slow when browsing. I am connected to the Wifi of the router my service provider gave me. The connection speed is okay on my Tablet or Phone from the Wifi, the problem occurs on the laptop only. Most of the pages I want to visit load very very slowly, and very often I get 404 error first, then, after 15-20 seconds the page starts to load. Oddly, when I use VPN connection of a third party provider, the connection becomes lightning fat compared to the speed without VPN.

As the problem only occurs on both of my laptops installed with Windows 7, I started thinking about whether it can be a problem with my operating system components. On both laptops, I am running the fresh, unupdated Windows 7 Ultimate. From the beginning I disabled svchost, so there are no annoying updates. Is it possible that this way I skipped an update that has an effect on network connection, and that's why I have this problem?

I run Eset Nod Virusscanner on both of my laptops, they didn't report any infections or suspicious activity so far going on my machine.

Any ideas to solve the issue?


My System SpecsSystem Spec
.
08 Feb 2020   #2
wither 2

Windows 7 Pro SP1 64 bit
 
 

I'm sure other people will help but it sounds like you don't have all the Windows updates installed. I would install all that are available first, in case one of them affects your problem in a good way. Since Win 7 support ended Jan 14, there should be no updates to worry about once you install the others.

I don't know which browser you're using but it's possible you have the security settings set too high.
My System SpecsSystem Spec
08 Feb 2020   #3
z3r010

Windows 10 Workstation x64
 
 

Try changing your DNS to a 3rd party provider such as cloudflares 1.1.1.1 or Googles 8.8.8.8

DNS Addressing - How to Change in Windows 7
My System SpecsSystem Spec
.

08 Feb 2020   #4
sono

Windows 7 Ultimate 64bit
 
 

I set Google's, it seems to be fine now. I will test it further and will come back to report what happened.
My System SpecsSystem Spec
Reply

 Internet browsing is slow without VPN and often get 404 error




Thread Tools




Similar help and support threads
Thread Forum
Slow internet browsing
I all of a sudden have slow internet browsing after getting messages for java updates. I disabled the Java add on so I don't get the message anymore but the browsing using either IE or Google is slow. I deleted temporary internet files and cookies and checked with my ISP. I ran malwarebytes scan...
Browsers & Mail
Slow Internet Browsing
My machine is presario cq62, with an intel i5 processor. i do experiencing an extraordinary slowness in both browsing and downloading. I Tried re-installing OS several times, and was not successful. I'm using avg antivirus package. I'm using Google crome as current browser. Cooling fan is also...
Browsers & Mail
Internet browsing slow with IE9
When I use IE9 to browse the internet it sometimes is very slow. I have run an internet speed test program (speedtest.comcast.com) which hangs when testing IE9. I then started Chrome and the internet browsing was fast. I ran the speed test program and the speed was what I expected. I switched...
Browsers & Mail
slow internet browsing
At my home network my pc runs just nicely. But today I moved it to my friends place and for some reason all surfing is really slow, like google.com takes up to 30-40 seconds to load. Using my laptop computer it loads in about a second on the same network. I am on a 4mb/500kb connection and...
Network & Sharing
slow download and internet browsing
Hi I seem to have joined the many that are having problems with slow download speeds using Windows 7. I recently bought a well speced HP Pavillion with Windows 7 64-bit. Since I turned it on for the first time I have painfully slow download speeds. A broadband speed test showed download speed...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:26.
Twitter Facebook