Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wireless adapter cuts out on 5G band only

17 Feb 2020   #1
EmeraldShard

Win7 Pro x64
 
 
Wireless adapter cuts out on 5G band only

Recently I built a Win7 Pro desktop machine (the one in my specs), and while most of the hardware was Win7-compatible (initial USB issues aside), the mobo's wireless card was not. So I ended up getting this: TP-LINK Archer T3U AC1300 Mini Wireless - Micro Center . It's been working beautifully... when it wants to work at all.

When I first installed it, I tried connecting to the 5G band on my router, but it didn't work at first. No helpful message - the OS just said it couldn't connect. Eventually I tried my 2.4G band, that connected normally, and then I switched over to the 5G band and it worked. I thought it was weird, but didn't think anything of it beyond that.

A few days later, I notice the adapter is cutting out every so often. Not like a bad signal, or dropping the connection and then picking it up again - I'll go from a quick ping straight to nothing, and it doesn't recover. The network status just shows as disconnected (red X), with no wireless networks available, until I restart the adapter.

Even then, restarting the adapter only succeeds maybe 50% of the time. The other 50% of the time, things get weird. The adapter won't show as disabled until I refresh the adapters screen, and then when I try to enable, it sits at "Enabling..." indefinitely. Killing/restarting explorer doesn't help. Even if I try to reboot, it sits on the shutting down screen indefinitely until I hard reboot. The device is still seen in device manager without any errors/warnings, although the link light is off on the physical device. After the hard reboot, everything's fine for awhile until it happens again. I can't find anything in the event logs which might explain the problem.

One day last week, I noticed it would consistently cut out every time I was trying to download or stream something of any significant size (in this case, a new GPU driver). That day, it was cooperating with my disable/re-enable without rebooting, but each time I'd try to restart the driver download and it would cut out again, pretty reliably around 20-30%.

So I decided I'd switch it back to my 2.4G band and see how the performance was. But it's behaving weirdly there as well. When it's connected to 5G, all it pulls up are a small selection of networks in my area, which excludes my 2.4G band (I theorize the ones it can find are 5G). I had to uninstall the driver both from device manager and run the TP-Link uninstaller before it would find the 2.4G band again after reinstalling. If I tried only one of the two, even the freshly reinstalled one would only find 5G networks.

Eventually I got it connected to the 2.4G band using the above method, and while understandably it was slower, the download did finish and I've been downloading/streaming other stuff for a good week now with no issues. Not a single disconnect when it's on the 2.4G band.

So I really want to use this thing at modern speeds, but what could be the problem with it?

A few more tidbits which might help rule out things:
  • No other device on my network has issues like this, either older devices on the 2.4 or modern devices on the 5. If I run another device (say, my phone) in the same general area / distance from router as this desktop, that device doesn't cut out.
  • I do have modded USB drivers (obtained from this thread/page: Update your Win 7 installation media ), which were needed to get the OS installed. I don't believe these drivers are at fault, though, because otherwise why would the 2.4G band work?
  • I have not installed any Windows updates aside from the Simplix update pack. I'm open to installing an update if it directly relates to this kind of issue (which seems unlikely). I do not want to install all available updates, for several reasons.
  • The router is a Trendnet device from around late 2013, self-bought. Had no issues with it before, except it was fairly stupid when I tried to hook up an external HDD to it (I kept seeing events from bowser saying it was trying to conflict with the desktop machine, so I took out the external drive to rule that out as the cause). I'm open to replacing the router, but only if I can conclusively determine that it's at fault (since no other device is having the issue).
  • The NIC is brand new, is connected to a USB3.0 port, and it has a good signal at all times when it's working. I've ruled out low signal strength issues because the connection never slows down, it just cuts out (tested with continuous pings both to the router and external sites). I'd really rather not replace it if possible - for one thing, TP-Link's driver software just installed without any fuss, didn't bring any bloatware with it, and it works through the OS's connection interface rather than some TP-Link software, which I really appreciate.
  • I have installed the latest driver from TP-Link, to no effect - including removing all program files from the old driver. Also checked the registry but I didn't see anything there.
Thanks in advance for any help/suggestions.
My System SpecsSystem Spec
.
17 Feb 2020   #2
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi

Hints and tips

1) is your router - Broadcasting both 2/5 connections
2) if it is do you have different SSID's on them
3) On your advanced tab for the driver are the options for BOTH bands selected, not just 2 or 5


Roy
My System SpecsSystem Spec
17 Feb 2020   #3
EmeraldShard

Win7 Pro x64
 
 

Quote   Quote: Originally Posted by torchwood View Post
Hi

Hints and tips

1) is your router - Broadcasting both 2/5 connections
2) if it is do you have different SSID's on them
3) On your advanced tab for the driver are the options for BOTH bands selected, not just 2 or 5


Roy
Both bands are broadcasting, and yes under different SSIDs. I have devices connected under both bands most of the time.

I didn't mention it before because it was already a wall-of-text, but yes I have checked on that setting. It defaults to "Auto" (and stays in Auto when it's on the 5G band, despite showing only 5G networks). I've tried setting it to 5 (802.11ac) and then back to auto - no change. When I set it to 2 (802.11b/g/n), it would find nothing until I put it back to Auto. I imagine now that I've done the clean reinstall and connected to the 2.4G band instead, using the b/g/n setting would show only 2.4 networks.

EDIT: To clarify, I tried leaving it in the 5 (802.11ac) setting for awhile the night I was trying to run the GPU driver download, and it didn't solve the problem.
My System SpecsSystem Spec
.

Reply

Thread Tools




Similar help and support threads
Thread Forum
BSOD after installing a D-Link Dual Band USB adapter
Hi, my computer used to work fine until I installed yesterday a D-Link USB wireless adapter. After the installation of the software, I received a blue screen indicating : DRIVER_IRQL_NOT_LESS_OR_EQUAL that is refering to anodlwfx.sys. The computer restarted and windows indicated that it has...
BSOD Help and Support
buying laptop PCIe mini dual band adapter
Unfortunately, at my school you need a dual band wireless adapter in order to connect to the internet. With my current laptop, there are certain requirements it must meet in order for it to work. it must be a full height card. An adapter will not work as the antenna wires won't go that far....
Hardware & Devices
Looking for a wireless N dual band PCI card.
I got a new d-link wireless N router the other day which solved most of my slow internet problems. It is a dual band router and supports 5ghz but my current network card is only 2.4ghz. I'm in an apartment complex so I figure if I run it on the 5ghz band I will get much less interference from other...
Hardware & Devices
Windows 7 64 wireless problem with dual band
Hello I have a new Toshiba A500 laptop with a Linksys 610 router, the max wireless connection is 70Mbit. Also have a Dell E5500 with Vista and have a wireless connection 150Mbit. On the Toshiba a have windows 7 64 as OS, standard on the laptop! The wireless chip is Realtek! Thanks Mike
Network & Sharing
Wireless guitar rock band problem
Hi, yesterday I bought a guitar this exactly --> Comprar Guitarra Rock Band Guitar inalámbrica en Hardcore Gamer and I can't make windows detect it, what I do is connect the usb reciver and a green light blinks, then put the guitar ON and the reciver stop blinking, the light turn permanent green,...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:24.
Twitter Facebook