Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to open port 21 for FTP.

3 Weeks Ago   #1
A1Topgun

Windows 7 Pro
 
 
Unable to open port 21 for FTP.

Unable to open port 21 for FTP.


Setup:
I have a remote location running a web cam server. I had an old homebrew AMD64 PC running Windows 7 that I had set up and everything worked well. The web server used nginx and I had five cameras on the web site page. I had Filezilla FTP Server running and was able to FTP the server to upload and download files from a couple of off site Pcs. (Linux Ubuntu desktop with Fillzilla Client and a Windows 8 laptop with Core FTP LE Client)
A couple of weeks ago we had a heavy wet spring snow storm which caused massive power outages. Three days later with power restored I booted the server and it went to boot repair. Long story short, the HDD was flaky and dying. So I bought a Optiplex 2070 and began rebuilding the server.


The server is in a remote location with cable ISP to MODEM, cat5 to a Linksys EA2700 running DD-WRT, and cat5 to the server. The server is a Dell Optiplex 7020 running a fresh load of Windows 7 Pro and updates. (Thanks to Windows Seven on how to do the updates). Web software is nginx 1.17.10 and is running well. I can use Remote Desktop to connect to the server from my Ubuntu desktop and the Windows 8 laptop. The router has Port Forward set for the web server, Remote Desktop, and a web cam wired through a router port.


Here is the problem:
I am unable to connect to the server using FTP.
I have scoured the net for three days trying to find out why I can not connect with no luck.
I have tried:
Forwarded router ports 21, 990, 50000 – 51000.
FTP with and without TLS.
Set access through Windows firewall – no luck.
Disabled Windows firewall – no luck.
Verified clients OK by FTP to other sites.
Verified FTP and Filezilla are enabled in Widows firewall advanced settings.
Checked open ports with “Canyouseeme.org”, ports show open for Web and Desktop, port 21 FAILS.
Deleted and reinstalled Flezilla.
Tried different FTP and loaded Quick&EasyFTP.



Example of Client error:
note – port xxx21 is forwarded to port 21 on the server.
Resolving xxxxxx.xxxxxx.com...
Connect socket #1172 to xxx.xxx.xxx.169, port xxx21...
Can't establish connection --> xxxxxx.xxxxxx.com:xxx21 @ Wed May 06 14:04:56 2020 (0-5)
Connection Failed


Tried telnet to the server on port 21 and it also fails.


Is there something simple I overlooked?
Any help would be appreciated.
My System SpecsSystem Spec
.
3 Weeks Ago   #2
samuria

win 8 32 bit
 
 

Welcome to the forum. What mode are you running FTP in passive or active. As the ports vary depending on mode you have forwarded a port does not go to a fixed IP not a dynamic one
My System SpecsSystem Spec
3 Weeks Ago   #3
A1Topgun

Windows 7 Pro
 
 
All Static IPs

All devices on the LAN are static IPs.
I setup Filezilla as I had it on the old computer. Passive mode with ports 50000 - 51000 and Port Range Forwarded on the router.
My System SpecsSystem Spec
.

3 Weeks Ago   #4
samuria

win 8 32 bit
 
 

Passive ode recieves on port 21 then the server decides the data ports so firewall and router must allow those ports out as its sever setting the ports
My System SpecsSystem Spec
3 Weeks Ago   #5
A1Topgun

Windows 7 Pro
 
 

For some reason Windows is not allowing port 21. Could Window block the FTP server running, netstat and netsh do not show port 21. What is the Task Manager Process for filezilla? What Services need to run?
My System SpecsSystem Spec
3 Weeks Ago   #6
A1Topgun

Windows 7 Pro
 
 

I just did a CLI telnet 127.0.0.1 21 and ftp 127.0.0.1 and received the Filezilla welcome message. Progress! That was from a Remote Desktop session. And it still does not work from a client over the internet.
My System SpecsSystem Spec
2 Weeks Ago   #7
F22 Simpilot

Windows 7 Ultimate x64
 
 

Couple of things. Your ISP may be blocking port 21. Check here: GRC | ShieldsUP! — Internet Vulnerability Profiling


Make sure port 21 is the right port that needs to be opened. If you could change your ports to something like 43000 I'd do that as a better security measure.

Make sure you're not using the default username and password for the camera.

If you chose to use Filezilla, make sure you go into the options and enable binary mode. I personally use WinSCP. Binary mode is on by default in WinSCP.
My System SpecsSystem Spec
.
2 Weeks Ago   #8
A1Topgun

Windows 7 Pro
 
 
Port 21 won't open

Re: F22 Simpilot


Shields Up gave me a green light, no responses to the Upnp probe.


I use four or five digit ports for internet to ddns resolved router (except 80) and have the router NAT change the port to the correct forwarded port. I set different ports in Filezilla server and then tried to connect to that FTP port from the client to no avail.


I CAN connect to the server for Remote Desktop and the web server is working on port 80.
I CAN connect to the wired web cam using it's assigned port forward.
I CAN NOT connect to FTP on the server no matter what port I assign and forward.


If I have time today I will configure a Raspberry Pi for FTP server and take it to the remote site just to verify I can FTP through the routers forwarded port.


Again, everything worked before I switched to the “new” server. I used the old Windows 7 DVD to clean load the new server. Everything seemed to load OK, but it's a bitch to get the Windows 7 “KB” update patches to install.
My System SpecsSystem Spec
Reply

Thread Tools




Similar help and support threads
Thread Forum
Unable to connect to 127.0.0.1 on any port.
Ok, so I've been having this issue for some time now, and it primarily happens with games. (but it also interferes with O&O Defrag, since it uses localhost connections to control its services) They try to connect to a localhost server using 127.0.0.1:XXXXX and are never able to. Nobody has been...
Network & Sharing
Unable to add printer port
WhenI go to Devices and Printers and right click on the icon for my systemprinter, select Printer Properties and then click on the tab for Ports andclick on Add Port the following error message appears Add a port dialog cannot be displayed Error0x0000007b :( What could be the cause of this...
Hardware & Devices
Can't open firewall port
Hi I Can't open firewall port I used this guide -http://www.thewindowsclub.com/block-open-port-windows-8-firewall I tried to add a rule to the advance settings to allow port 8092 etc.. But when I run a port scanner it shows it as closed...
System Security
Cannot connect to any open port
I have a desktop computer that I haven't started for around half a year. Last week, when I started it, it made a lot of updates and later when I wanted to connect my laptop to it, it didn't work. This used to work in the past, so I started to debug the issue. I have Avast antivirus and the Windows...
Network & Sharing
Open port 51005?
I'm trying Windows 7 Ultimate RTM 7600.16385.090713-1235_x86 fre_client_en-us. After clean install and Windows firewall "on" I checked all ports with few Port scaners. They report that port 51005 is open. This problem persist even inbound traffic is blocked and also with latest addition NOD32 Smart...
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:48.
Twitter Facebook