Network Share - Unsharing Itself


  1. Posts : 1
    Windows 7 Ultimate 32bit
       #1

    Network Share - Unsharing Itself


    Hi. I'm new to the forum so not sure how much system info I need to provide, since I just listed a lot when making the account.

    I've a Win7 Ultimate 32bit self-built, has been in use as a NAS for years. Besides the issue of this topic, it's completely stable. Drives connected to it have come and gone, meaning old get replaced with new, has worked fine to network share these drives. Some are internal SATA, others are external USB3.

    I just added a brand new Western Digital Elements 6TB to it, seen by Win7 as NTFS, Primary Partition, Basic Disk, and set it to be shared the same as all the other drives...

    Right click on drive - Properties - Share With - Advanced Sharing - Checkmark "Share this folder" (and used same drive letter which has no conflicts with any other drives) - Permissions (Everyone has Full Control).

    The drive is then shared, can access via \\computer\share. It's not mapped to any drive letters on clients. However after 2-3 days, can no longer access it like this and if I check the sharing via the above method, now it is no longer shared in the drive properties. I can repeat the above and the drive is then shared again, but again, 2-3 days pass and it becomes unshared.

    It seems to lose the share after a reboot. I wondered if there was some different account issue, but I always have it auto-login at boot. Regardless I also tried the following and it did not help, the one share is still missing after a reboot:


    1. Press Windows +R and type in : regedit
    2. In Regedit, navigate to HKLM//SOFTWARE//Microsoft//Windows //Current Version//Policies //System.
    3. Create a new REG_DWORD entry named "EnableLinkedConnections".
    4. Set its value to 1.


    I also tried CMD net config server /autodisconnect:-1 which also, didn't help.

    Anyone know what's going on? This has never happened to any other drives on this system, and even now, no other shared drives become unshared, just the WD Elements. When it becomes unshared, the host system has no problem accessing it, nor the clients over the LAN once it is set to shared again, and WD Diagnostics finds nothing wrong with it.

    What is causing windows to undo or forget that it's shared?

    - - - Updated - - -

    I saw this page:

    Shared Folder Becomes Unshared

    It made me wonder if the WD Elements has a far more aggressive power management or something, so it is not online yet when the server service enumerates shares. I could be making up nonsense, but this is what I'm trying next. First in services.msc I set the Server, service, to Automatic (Delayed Start) instead of the default Automatic.

    No, after a reboot the shared drive is still unshared again, but here's where it gets interesting... if after the reboot, and the WD Elements is shown as unshared, if I THEN open services.msc and restart the "Server", service, this makes the drive shared again.

    Does knowing this help me? Does it indicate to anyone what is wrong, or if I had to, is there some way to issue a command to make the server service restart at the end of every boot?

    - - - Updated - - -

    I tried running this batch file on windows startup, but had mixed results... sometimes it works, sometimes all I do is reboot again and it doesn't work.



    DIR J:
    timeout 15
    net stop server /y /y
    net start server


    This is getting annoying so I switched the WD Elements over to using a PCIe card port instead of the hub on the Seagate enclosure. So far, that works after every reboot.


    However, I switched a different Seagate External from that PCIe card port, to the Seagate enclosure's hub port, and that other Seagate shows up shared just fine after a reboot, unlike the WD Elements. I guess I'll just leave it like this, though I was about to retire the other Seagate anyway.
    Last edited by dave99; 21 Apr 2022 at 13:21.
      My Computer


  2. Posts : 6,872
    W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
       #2

    Hi

    wild guess here as your using 32bit..... your BIOS drive setup is MBR.....unfortunately that only supports a 2TB drive, you will need to boot using EUFI....to use it properly

    i suspect when you reboot your system throws a wobbly
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:12.
Find Us