Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I have lost administrative right!? :S

01 Dec 2009   #1

Windows 7 Home Premium 32bit
I have lost administrative right!? :S

Hey guys, I'm new to the forum and the 'wonderful' world of Windows 7

So basically, last week I put up a file on my home network to share... on the public folders. When my flatmate wanted to access my computer - it asked for the password - and thinking this will give him access to my shared files - i typed it in.

Then, he had access to EVERYTHING on my laptop - and I mean everything. To prove it - he right clicked on my desktop form his laptop and created a folder on mine! Immediately, I thought I needed to change this.

So, thinking it was a simple procedure - I right clicked on my user account (quite simply, Dilz) and changed the sharing settings so that it is shared with 'nobody' with the small padlock symbol.

The process began... and seemed as if it was taking a VERY long time. So, needing to work on my laptop - I cancelled it and assumed that would be the end of it - so I can try again at a later time.

But, however, from then on - things got strange.

On the next reboot - my desktop became a solid black screen, all of my startup apps were unable to process with notification messages flooding my screen, Catalyst Control Center, Fences, Acrobats temp files etc... nothing works! Even when I click on the start button, all of my personalized shortcuts on the menu became unusable! Google chrome cant access a temporary location to create certain files so even that doesn't work! And when I type in the start menu search field... no results come up what soever.

The main issue is however, when I click on my main file directory (Dilz), I receive the message:
"You don't currently have permission to access this folder"
Click continue to permanently get access.

I click continue and then get a UAC window stating that:
Program name: Edit Security
Publisher: unknown
File origin: Hard drive on this computer

So I click yes to allow and get:
"you have been denied permission to access this folder"
To gain access to this folder you will need to use the security tab"

The security tab is a hyperlink, so I click on that and receive:
"Desktop: the properties for this item are not available"

Please can you help as to how I can go back to how things were, I think the main problem was when I cancelled the sharing settings from changing to nobody...

On the UAC settings, I am the admin, but this seems to prove that I have no power at all!

Any help would be GREATLY appreciated

Thanks for your time


My System SpecsSystem Spec
01 Dec 2009   #2

Windows 7 Ultimate x64

Please....go on!
My System SpecsSystem Spec
02 Dec 2009   #3

Windows 7 Profession 64-bit

I am afraid my experience in this area is not very deep, so I don't know how helpful I will be, but I will try to get the ball rolling. I am afraid your conclusion that canceling in the middle of the process caused this problem, or at least contributed to it, is correct. Then the reboot drove in the final nail.

This problem has surfaced before on Vista systems with files created or modified with XP via sharing, or held over from an upgrade from XP.

Is your account the only admin account?

I have found this solution (Denied permission to access folders - Vista Security) in various forms scattered about, this seems to be the best written. You can give it a try, or hopefully someone who has been through this before will join in with some better advice. Otherwise, and if yours is the only admin account, I don't see much hope.
My System SpecsSystem Spec

02 Dec 2009   #4

Windows 7 Ultimate x64

Have you tried a system restore or booting into advanced options and choosing last know good configuration?

It's clear that permissions and sharing has been messed up by cancelling the changes half way through the job (never recommended) but trying a system restore might work, if not we'll try & do it the hard way!

By default sometimes whole user accounts are shared on the network (mine was when i set mine up), the best way to share files on your network is to ditch the context menus in explorer and head straight to fsmgmt.msc.
My System SpecsSystem Spec
02 Dec 2009   #5

Windows 7 Profession 64-bit

@Dilz - Please do not edit your post to add additional technical information when there have been replies. Those following by email notifications don't see the edits. It is best to just to add a reply (unless doing minor typo corrections that don't alter meanings, spell checks, or removing unnecessary non-technical comments).
My System SpecsSystem Spec
02 Dec 2009   #6

Windows 7 Home Premium 32bit

Thank you soo soo much for the instantaneous reply! Indeed the Windows 7 is an inpace upgrade from Vista, so I shall try your method and report back asap.

Thanks also for the reply! I cant seem to do a system restore (which was my first thought) as I don't seem to have any restore points available :S
Im now going to try the booting into last known good configuration - and see if that helps!

N.B im using a different laptop atm for Uni work - but hope I can get back to my Vaio soon
My System SpecsSystem Spec

 I have lost administrative right!? :S

Thread Tools

Similar help and support threads
Thread Forum
how regain lost session lost favorite file due to currupt
my system window 7 IE 11 ;is set to reopen last open tabs after any reboot etc. this time due to freeze ; I ended task at task manager thereby all open tabs got lost ; were told the folder for them should be favorite htm ;how do I find it ??? saved to favorites file ,renamed and moved...
Browsers & Mail
Accidentally lost administrative privilege
Hello guys, Before enabling guest account, i tried to secure the system drive so that no one can access except administrator. Most probably i selected authenticated users in security tab. Think that's why i can't access. Now i can't create any other user, no access to device manager. :cry: ...
General Discussion
Lost my HP Touchsmart LOGO since I lost resetted my BIOS (I guess)
Hi All I have a HP Touchsmart 300-1060a (Home Premium Windows 7 64 BIT) which I bought few years back. Now for the last 6 months or so I started getting issues with my machine was not displaying anything at all after turning it on. So I had to hard reset my power from the machine and then...
Hardware & Devices
My administrative account is not allowing administrative priveleges
Hi, I just completed a factory reinstall of my HP Computer, 64-bit, Windows 7. I only created one user account at the prompt, as the computer was setting up. I've made sure that the account is listed as having "administrator". However, after installing a number of programs onto my...
General Discussion
Lost Administrative Account...Now Guest
I recently lost my administrative account. (i.e. it is now a guest account.) I am the owner of the computer and have created a backup account that has administrative access thru the built-in admin. I was trying to get rid of the Homegroup section of Explorer when suddenly I only had Guest access....
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App