Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ethernet card not being recognized...

25 Feb 2009   #1
Milan0

Windows 7
 
 
Ethernet card not being recognized...

Hi all,

I'm really glad I stumbled across this forum whilst on a mad scramble to find an answer to my question.

I installed the 7022 x86 version of Windows 7. Everything installed fine and there were driver issues which I anticipated but my Ethernet port is not working on W7 or any other OS for that matter.

Itís a very strange situation. After it was not seen I W7 I booted from my 2nd drive which has Vista on it and it was not seen there so I booted from my XP drive and it was not seen on there either.....

I have re-downloaded all the drivers for each version of the OS but none are making the NIC discoverable.

I have an nVidia 680i SLi & I am using the on board port.

Any help would be greatly appreciated as I would love to get into W7 and start using it fully.

Thanks very much.


My System SpecsSystem Spec
.
25 Feb 2009   #2
Brink

64-bit Windows 10 Pro
 
 

Hello Milan0, and welcome to Seven Forums.

Double check in the BIOS to make sure that the LAN port is enabled.

Hope this helps,
Shawn
My System SpecsSystem Spec
26 Feb 2009   #3
angryman

Windows 7 Ultimate 64bit
 
 

I had the same problem, just posted what worked for me in another thread:

Quote   Quote: Originally Posted by angryman View Post
Open device manager, and right click on any unknown devices that show. Put in your MB driver CD, and have it look for the driver in the "driver" folder, it will pick the correct one, do not manually pick it because there might be a couple devices that are unknown like mine was.

I had the same issue, this fixed it.
My System SpecsSystem Spec
.

07 May 2009   #4
wrcs

All Of them
 
 

I had the exact same problem, i followed the steps listed in the link above, tried everything. It's as if my network card was 100% dead.

The solution for me was to update the bios on my EVGA 680i motherboard. I noticed that along with windows 7 not being able to see the network cards at all, the light on the network adapter was out completely. Flashing the bios with http://www.evga.com/support/drivers/...t.asp?switch=2 seemed to resolve the issue. After that the boards drivers were all loaded by windows 7 by itself except the sound ones... they didn't work. Downloaded the new realtek ones ect. ect.
My System SpecsSystem Spec
20 Jul 2009   #5
plube

windows 7
 
 

i have not found any realtek ethernet drivers that worked with win 7 ....i disabled the bulit in main bord card and installed a d-link 530tx and it was recognised right away by win 7 and connected right away.....now nic cards are so cheap and the one i put in is 5yrs old and is working fine.
My System SpecsSystem Spec
20 Jul 2009   #6
Snufffed

 

Quote   Quote: Originally Posted by plube View Post
i have not found any realtek ethernet drivers that worked with win 7 ....i disabled the bulit in main bord card and installed a d-link 530tx and it was recognised right away by win 7 and connected right away.....now nic cards are so cheap and the one i put in is 5yrs old and is working fine.
5yrs old, it is still wet behind the ears.
look and find then install.
Driver = 7.2.1127.2008
My System SpecsSystem Spec
12 Sep 2009   #7
RamboGT

Windows 7 Pro
 
 
D-Link DFE-530TX+

I have a Biostar TF8200A2+ motherboard with built-in Realtek NIC.

I tried the software patch suggested; no luck. (7.2.1127.2008)

After installing the latest drivers (Vista32 version is the latest, ftp://ftp.dlink.com/NIC/dfe530tx+/Dr...rivers_700.zip), I was able to go online.

Problem is, that EVERY time I restart, I have to go into Device Manager, Uninstall the NIC (not deleting software), Scan for new hardware, let it re-install the NIC, then it works; same software, just has to 'clear' itself for some reason.

Any ideas on how to fix this?

Thanks.

RamboGT
My System SpecsSystem Spec
12 Sep 2009   #8
Brink

64-bit Windows 10 Pro
 
 

Hello RamboGT,

Have you already tried the Windows 7 7.006 driver version directly from Realtek?

Hope this helps,
Shawn
My System SpecsSystem Spec
13 Sep 2009   #9
RamboGT

Windows 7 Pro
 
 

Thanks for the latest driver reference (09-09-09).

However, after uninstalling all existing drivers and software, and installing the 7.006 software from the link provided, it still does not work upon reboot; I still have to go into Device Manager and Uninstall, Scan for Hardware Changes...then it works.

Maybe one day this will work.

If anyone finds the cure, please let me know.

Thanks for all the efforts thus far.

RamboGT
My System SpecsSystem Spec
13 Sep 2009   #10
Brink

64-bit Windows 10 Pro
 
 

Strange, are you using the auto installation version of the driver for Win7, second one listed?
My System SpecsSystem Spec
Reply

 Ethernet card not being recognized...




Thread Tools




Similar help and support threads
Thread Forum
Ethernet Adapter not recognized
So I have a Dell PC I bought a little over 1.5 yrs ago that came with an integrated ethernet adapter on mobo. worked fine uptill november last year when it started giving me problems where the comp would not recognize the adapter on start-up, a reboot would solve the problem and I'd be able to go...
Network & Sharing
USB PCI card not recognized
Hello, I installed this USB PCI card: 5 Ports High Speed USB 2 0 PCI Card Expansion Kit 4 External 1 Internal for PC | eBay when I booted, I didn't get any alert that new hardware was installed. I think I installed it correctly into the motherboard.
Hardware & Devices
ethernet cable not recognized, asking for isp login info
I know this question has already been asked as i've been researching this for the past 2 days, but none of the threads i've found have solved my issue. 1. my internet is working on all other computers, the router and modem both work properly and are both configured to work with other computers...
Network & Sharing
Ethernet Connections not being recognized.
First of all thanks in advice for taking the time to read my issue and if you can help me, Thanks even more! So my issue is regarding ethernet connections not being recognized when i plug in the ethernet cable to the port. I have been searching for days for a solutions, but no one quite...
Network & Sharing
Card not being recognized at all
I have an ATI Radeon 4650 card (dual DVI ports) which is working perfectly. That is in a PCIe slot on the board. I have two monitors running well. I also have third monitor which I'm trying to get running but can't. I've installed one card in the second slot (PCI slot) that is the NVIDIA GeForce...
Graphic Cards
Ethernet not recognized
So I just installed windows vista ultimate clean installed. I was running the release candidate before this. The issue i'm having is that windows can't seem to install the drivers for my Ethernet adapter. My computers a Dell dimension 9200. I've got to dells website and downloaded their...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App