Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Remote Assistance over net doesn't work

20 Dec 2009   #1

Win7 Pro
Remote Assistance over net doesn't work

Tried asking for help in the Networking forum, but nobody would reply, so I thought I'd try here before giving up altogether.

Twice I have been unable to make a connection to offer RA to a friend. Our basic system specs are as follows:

Both have DSL (different providers).

My end: Win7 Pro; Linksys WRT54GS (v6) router with UPnP enabled; Windows firewall set to allow RA.

His end: Vista HP; a Netgear WGR614 (v7) router with UPnP enabled; RA allowed in firewall.

We can easily establish a chat connection using Live Messenger (latest version). I suggested on both occasions that he request RA from me via Messenger. After entering his RA session password at my end, it is unable to make the connection. Only vague, general possible reasons for failure are offered by the RA software. Microsoft offers a connectivity diagnosis tool online, but it is not compatible with Win7, so I cannot run it for reliable results on my box.

Reading in "Windows 7 Inside Out" (published by Microsoft Press) about RA, it notes that with the advent of Vista, RA is supposed to easily traverse a pair of NAT routers to link a pair of computers. Well, apparently not in my case, which is why I'm asking for help here.

Maybe I'm just too bleary-eyed from frustration to see where I'm missing a critical setting either within Windows (Win7 & Vista) or in router setup. Can someone guide me through steps most likely to make this work?

I should note that I have subsequently tried TeamViewer, and did successfully link to my friend's computer, but I would still like to have RA available as an alternative.

Thanks in advance for any help offered.

My System SpecsSystem Spec
21 Dec 2009   #2

Win7 Pro
Making some headway...

Alright, so it occurred to me to "just try something, anything" in hopes of finding a clue. My desktop consistently fails when trying to initiate a RA connection via the Easy Connect method (either to Invite Someone, or Help Someone). It churns for bit, then returns with "Easy Connect is not available .....Can't connect to the global peer-to-peer network ."

This usually leads to a suggestion to run MS's Internet Connectivity Evaluation Tool, resulting with a "Not Supported" for the NAT Type test, and "Not Run" for the UPnP test. UPnP is definitely enabled in the router (actually, in all three of them I've tried).

So, for the hell of it, I tried a household laptop (Win7 too) via wireless to the same router (currently D-Link DIR628). Easy Connect on the lappy succeeds every time in linking to the "global peer-to-peer network". It either presents me with a password to convey to my "helper", or a RA terminal waiting for me to enter the "requestor's" password. Weird. Good, but weird.

If I run the Connectivity Tool from the laptop to the same router, it returns a "Supported" result for NAT Type, but still "Not Run" for UPnP. At least something seems to be working right.

Now the obvious question would be why my desktop cannot do the Easy Connect thing, but the laptop can, with same OS and behind the same router. There must be some software setting in 7 on the desktop at fault. I briefly enabled a wireless adapter in the desktop (then pulled the ethernet cable), but had no success, so I think I've ruled out a quirk with the ethernet (my normal connection to router).

Any ideas?
My System SpecsSystem Spec
21 Dec 2009   #3

Windows 7 Ult, Windows 8.1 Pro,

Everything I could find out about this problem is contained in the thread below.

Remote Assistance and linksys router
My System SpecsSystem Spec

21 Dec 2009   #4

Win7 Pro

Quote   Quote: Originally Posted by kokopelli View Post
So, for the hell of it, I tried a household laptop (Win7 too) via wireless to the same router (currently D-Link DIR628). Easy Connect on the lappy succeeds every time in linking to the "global peer-to-peer network". It either presents me with a password to convey to my "helper", or a RA terminal waiting for me to enter the "requestor's" password. Weird. Good, but weird.
Ok, so I decided to scour through networking related settings, comparing my laptop and desktop side-by-side. Found one thing:

Network and Sharing Center > Change advanced sharing options (on left pane) > Public > Public folder sharing --on the lappy Turn on sharing so anyone...... was checked. On my desktop Turn off Public folder sharing was checked instead. After changing that one setting on the desktop, magically Easy Connect began working--my desktop will now find the "peer-to-peer network" when trying the Easy Connect option. I was easily able to use my laptop to "request" RA help from my desktop via Easy Connect, and vice versa. Would not work before. I have not been able to try a RA session to another computer across the net and behind its own router yet, but I suspect it will work now provided the other computer and router have appropriate settings.

Edit: And now the Internet Connectivity Eval. Tool test categories all result in "Supported" for my router after making that small settings change. Problem seems to be solved on my end.
My System SpecsSystem Spec

 Remote Assistance over net doesn't work

Thread Tools

Similar help and support threads
Thread Forum
Remote Control Doesn't Work in Win-7
Hello i have strange problem, my hp remote not work on windows 7. After 2 years i preinstall from vista home preimum to win7 ultimate. My laptop is hp pavilion dv7-1023cl and i have all windows 7 x64 drivers, and all hp services running on automatic mode, HID also. I try many many times to set up...
Hardware & Devices
Remote Desktop doesn't work after upgrade to SP1
Hi, After I upgraded my windows ultimate to SP1 my rdp stopped working. My remote settings now look like this: I can't find any reason why this would have happened. Does anyone have any idea what I can do to solve this, without reinstalling windows/sp1?
Network & Sharing
VMC Remote Control doesn't work with Netflix streaming
My remote control (Windows 7 Vista XP Media Center MCE PC Remote Control and Infrared Receiver for Home, Premium and Ultimate Edition) doesn't work with Netflix online streaming. The pause button works fine with live tv, recorded tv, and DVD playback but not Netflix. Any suggestions on getting...
Media Center
Using Remote Desktop instead of Remote Assistance for remote helpdesk?
Hi I know there are other products out there, like vnc, ultravnc, teamviewer etc etc, but really nothing beats the sheer speed of remote desktop, it's like sitting in front of the actual computer. I also know about Remote Assistance built into Windows 7. I would like to use remote desktop...
Network & Sharing
Remote Desktop Connection Doesn't Work!!!! HELP!!!
Hello everyone. I am having an issue getting my laptop (has Windows 7 Home Premium) to connect to my desktop work computer (has Windows 7 Professional) using RDC. I keep getting the following message: "The Local Security Authority cannot be contacted". I have searched the forum and Google and can't...
Network & Sharing
Creative SB X-Fi Platinum Fatal1ty Remote doesn't work
Hi alls, I have searched on forum for the issue of remote, but no luck. :o so i start a new topic then. I have this carte Creative SB X-Fi Platinum Fatal1ty Champion Since from the site of...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App