Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: homegroup problem

27 Dec 2009   #1
bjproc

Win 7 Pro 32bit
 
 
homegroup problem

i tried to connect to a homegroup, with a win 7 HP to a win 7 pro, but it says it can't connect as it needs ipv6

whats the point in it at all then, as i believe most folk have ipv4


My System SpecsSystem Spec
.
27 Dec 2009   #2
RogerR

7 x64 Ultimate
 
 

Homegroup is only between Win7 machines. IPv6 is included in Win7 but in some instances requires a registry hack to fully enable. There are threads here detailing this particular fix.

Here is one.
My System SpecsSystem Spec
28 Dec 2009   #3
bjproc

Win 7 Pro 32bit
 
 

thanks rodger, i'll have a read of that

the 2 pc that i want to homegroup have win 7
My System SpecsSystem Spec
.

28 Dec 2009   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

If the registry fix doesn't do anything than most likely you have a problem with your router. A firmware update may fix it, I can also check the compatiblity with Windows 7 if you give me the exact model number and version number. That registry hack is only attempting to make up for not using a Windows 7 compatible router. It's a work around at best.
My System SpecsSystem Spec
30 Dec 2009   #5
bjproc

Win 7 Pro 32bit
 
 

thanks chev65, the router i use is a netgear DG834GT, i'm on sky broadband (UK) and they have their own firmware for the router, not netgears, not upgradeable unless sky do it themself, part of there T&C. there away to put their prices up, so i'm just about to move over to O2 BB, so i'll try again after that
My System SpecsSystem Spec
30 Dec 2009   #6
WalkerA WinTeam

Windows 7 Home Premium (64-bit) *** Windows XP SP3 (32-bit), OSX 10.6
 
 

Quote   Quote: Originally Posted by bjproc View Post
thanks chev65, the router i use is a netgear DG834GT, i'm on sky broadband (UK) and they have their own firmware for the router, not netgears, not upgradeable unless sky do it themself, part of there T&C. there away to put their prices up, so i'm just about to move over to O2 BB, so i'll try again after that
Hi bjproc,

I'm sure chev65 will be back soon but I took the liberty of running your router model - it's not listed at the Windows 7 Compatibility Center. What's the model of your network adapter? Is it built-in, or a USB stick?

Also, here's a thread from a few weeks ago in which someone's having problems with their Netgear DG834GT as well: Netgear Router DG834GT - Windows 7 driver

Cheers,

Walker
Windows Outreach Team
My System SpecsSystem Spec
30 Dec 2009   #7
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

One thing I'd like to bring up is if the PC's are *ethernet* connected to the router vs wireless, then the driver issue is moot. There wouldn't be one for the router. The router isn't going to know anything about IPV6 anyway so any IPV6 packets would be ignored by it. You could throw *any* IPV4 based router in there and it wouldn't make a difference. Wireless is a different story of course.

WalkerA has a good point: The ethernet NIC could be an issue and drivers are common problem.

One tip that I learned that has worked on almost every version of Windows when IP acts really weird is to uninstall the adapter and reboot. This causes Windows to "re-discover" the adapter a reinstall the driver and create new registry settings. This may not be it, but I'll throw it out for consideration...
My System SpecsSystem Spec
30 Dec 2009   #8
bjproc

Win 7 Pro 32bit
 
 

Quote   Quote: Originally Posted by WalkerA WinTeam View Post
Quote   Quote: Originally Posted by bjproc View Post
thanks chev65, the router i use is a netgear DG834GT, i'm on sky broadband (UK) and they have their own firmware for the router, not netgears, not upgradeable unless sky do it themself, part of there T&C. there away to put their prices up, so i'm just about to move over to O2 BB, so i'll try again after that
Hi bjproc,

I'm sure chev65 will be back soon but I took the liberty of running your router model - it's not listed at the Windows 7 Compatibility Center. What's the model of your network adapter? Is it built-in, or a USB stick?

Also, here's a thread from a few weeks ago in which someone's having problems with their Netgear DG834GT as well: Netgear Router DG834GT - Windows 7 driver

Cheers,

Walker
Windows Outreach Team
Quote   Quote: Originally Posted by RedBirdDad View Post
One thing I'd like to bring up is if the PC's are *ethernet* connected to the router vs wireless, then the driver issue is moot. There wouldn't be one for the router. The router isn't going to know anything about IPV6 anyway so any IPV6 packets would be ignored by it. You could throw *any* IPV4 based router in there and it wouldn't make a difference. Wireless is a different story of course.

WalkerA has a good point: The ethernet NIC could be an issue and drivers are common problem.

One tip that I learned that has worked on almost every version of Windows when IP acts really weird is to uninstall the adapter and reboot. This causes Windows to "re-discover" the adapter a reinstall the driver and create new registry settings. This may not be it, but I'll throw it out for consideration...
i've disabled my wireless cards, and the router is connected with ethernet cables (a 25' one trailing through the house just now, maybe get it put under the floor tomorrow )

it's still not having this homegroup problem


the hard wire has fixed my streaming problems
My System SpecsSystem Spec
30 Dec 2009   #9
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

Sounds like a wireless adapter issue. If you can provide the details on the adapter that would be a great start.
My System SpecsSystem Spec
30 Dec 2009   #10
WalkerA WinTeam

Windows 7 Home Premium (64-bit) *** Windows XP SP3 (32-bit), OSX 10.6
 
 

Quote   Quote: Originally Posted by bjproc View Post
i've disabled my wireless cards, and the router is connected with ethernet cables (a 25' one trailing through the house just now, maybe get it put under the floor tomorrow )

it's still not having this homegroup problem


the hard wire has fixed my streaming problems
Well I'm glad your network is at least working now! Although running ethernet cable under the floorboards sounds like an inconvenient/expensive solution

Let us know if there's anything else we can do...

Cheers,

Walker
Windows Outreach Team
My System SpecsSystem Spec
Reply

 homegroup problem




Thread Tools




Similar help and support threads
Thread Forum
Homegroup problem
I'm having an issue with Windows 7 Homegroup. I have 2 systems, one a desktop wired and a notebook connected wirelessly. The existing router is a Netgear N600. Yesterday, I was attempting to download a 2gb file from my desktop to my notebook and it hung for a minute or so before starting the...
Network & Sharing
Homegroup Problem
Hi - I have a Netbook, a Laptop and a Desktop - all running Windows 7 and on the same Homegroup. The Netbook is fine and can see both the others but the other two can only see each other and not the Netbook. I tried the Troubleshooter to no effect. Curiously, they can all see each other on the...
Network & Sharing
Homegroup Problem
OK, just built 2 Windows 7 64-bit boxes with the 7000 beta build. One is a desktop, the other a laptop. I connect wirelessly with my laptop, create the network and tag it as a 'Home Network'. Connect over the LAN with the desktop. When I try to create a Homegroup from the laptop, it errors...
Network & Sharing
Homegroup problem
I created a homegroup in PC. I can access homegroup in laptop and access files in PC But i cannot access files from PC to laptop through homegroups, nor i can see my laptop listed in network devices. In PC i am running W7 Ultimate In Laptop W7 Home Premium
Network & Sharing
@#$%! Homegroup problem
Desktop has 7, laptop has 7. I'd like to connect them in a Homegroup but cannot. No problems creating a Homegroup on the laptop, but I cannot create one on the desktop. Also can't turn on media file sharing on the desktop. I click the button and the circle goes around and around for 1-2 seconds,...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:55.
Twitter Facebook Google+