Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Mapped Drive Not Connecting at Startup

09 Mar 2010   #11

Win 7 Professional and Windows 8 Professional
Mapped Drive Not Connecting at Startup

Here is another alternative if you just want to get rid of the warning. Mapped drives will not connect until you click on them for the first time but the annoying warning won't pop up at start up . Again it requires a registry edit and needs to be done with caution.


Set or create a DWORD

RestoreConnection = 0

Do a restart after making the changes.

Just a follow up. My Vista PC has started to display the same problem again even with the registry edit in my previous post. (mapped drives fail to connect and I get the warning message) I will do some investigation and post back with my findings. Win7 PC is still functioning as expected.

My System SpecsSystem Spec
25 Jan 2011   #12

Win 7 Home Prem
Win7 64bit + LG NAS mapping issue


I also have this issue as described by Alakar.

Kit list:
2 x Win 7 Pcs Prem home edition
1 x LG RD1 NAS drive (operating in Raid 1 mode)
1 x Trend Gig switch connecting all devices on the the same LAN.
RJ45 cables between all, and all devices running at 1GB FDuplex

Software config
Win7 is setup to map to my NAS with logon info saved.
NAS is configured for user to allow reconnects and access to directory
WIN7 firewall is on currently (see below)


Basically Boot PC and icon pops up with message 'Not all network drives could be re-connected' All applications can't see data on drive until you click on drive mapping in Explorer and then all is fine.

I need this not to occur as our photos are all on the NAS to allow my wife and I to share access and I don't want to have to tell her to click on the drive each time she needs to use any data. Frankly she should not have to do this, it should just work.

Tried so far
Started by turning off Firewall. This seemed to fix it. Therefore I figured maybe the network service was being blocked. Turned on Netlogon service. Seemed to work for a bit but problem is back. Think it is not related at all.

Rebooted NAS, no change to status. NAS I should say is on 100% of the time, standby and hibernation are currently OFF.

What works please?
I noticed the link to the MS support page, with a reg edit. Does this work? Seems a bit drastic given such a basic networking function.

Ive seen others talk about batch files, again this is not the 1990s people, that seems crazy!


I am wondering if this is a Win7 Home Prem issue that somehow the cut down version is not supporting this feature fully. Or its just broken!

Ideas, comments, all welcome.
My System SpecsSystem Spec
27 Aug 2011   #13

Windows 7 Home Permium 64bit

How can I set up my laptop so it connects automatically on startup to my home network? On startup, in the lower right hand corner,I have to click the internet connection, find my home network, click on it and I am connected. With previous laptops running XP, I connected to the internet on startup automatically.
My System SpecsSystem Spec

28 Aug 2011   #14

Win 7 Professional and Windows 8 Professional

Quote   Quote: Originally Posted by shakreit View Post
How can I set up my laptop so it connects automatically on startup to my home network? On startup, in the lower right hand corner,I have to click the internet connection, find my home network, click on it and I am connected. With previous laptops running XP, I connected to the internet on startup automatically.
When you click the internet connection and select your home network, check to see that the "connect automatically" box is ticked with a check mark.
My System SpecsSystem Spec
22 Mar 2012   #15

Windows 7 Pro x64

Does anyone have a copy of that utility? The download link is dead.
My System SpecsSystem Spec
14 Aug 2012   #16

Windows 7 Pro

We been having this same issue and after many hours, we have resolved the issue....we are using an intel based PC and the factory nic card. We tried using a diffeent NIC card and found the issue has been resolved extremely quick..

If your Network has to search at all then your mapped drives will fail connection, but using this intel pro/100 s NIC card, the connectivity is instant and the mapped drive is connected at boot!!

Hope my novice language helps all of you out there!!!
My System SpecsSystem Spec
04 Jun 2013   #17

Windows 7 Professional x64, Windows 7 Ultimate x64

It amazes me that no one has posted a helpful, REAL solution, aside from "just re-enter your credentials every time". It truly bothers me anyone would post that as a solution.

So, here is the REAL solution.

The issue is that the name of the drive is not being resolved before trying to connect. To get past this, you need to re-map the drive using the server's IP address.

  1. Get the server's IP address.
    • Open the command prompt by typing "cmd" in the search box in the start menu.
    • type "ping server". Write down the IP address that it returns.
  2. Disconnect the network drive
    • Be sure you are not connected to the network drive. You can do this by clicking on "Computer" in the start menu, right-clicking the drive, and selecting "disconnect".
  3. Re-map the network drive
    • In the same folder of windows explorer where you disconnected the drive, click "Map network drive" at the top of the window.
    • Instead of typing "\\server\data" or "\\server\share", use the IP address. For example, "\\\data".
  4. Connect to the network drive using your credentials
    • Enter your user name and password.
    • Click "remember credentials" or "remember password" checkbox.
  5. Check to see if it worked properly
    • Restart your computer. It should automatically connect to the network drive now.
My System SpecsSystem Spec
05 Aug 2013   #18

Windows 7 Home Premium 32bit

Thank you Affe! This started for me about three weeks ago (not auto-mapping NAS drives on boot-up) and I had to disconnect/reconnect WiFi to map. No idea what caused it as I hadn't knowingly changed anything. Remapped the drives using NAS IP address instead of name and all mapped ok after restart. Let's hope this continues to be the case after a cold boot :)
My System SpecsSystem Spec
08 Aug 2013   #19

Windows 7 Ultimate 32bit

I followed all of this info but still had problems so I thought I'd post another solution. My issues are with a Goflex Home, it maps it's own folders every time but for the USB drive plugged into the back that I use with XBMC for DVD Movies (Backup rips of all my DVD's, no transcoding), TV Shows, and Portable videos. I map directly to each folder in the external drive.

I opened notepad and typed the following, the quotations would be omitted if there were no spaces in the path, but since there are spaces I have to use the quotes. The XXX's is the IP address of the Goflex Home, though I could have just used Goflex Home instead of the IP. The reason I went with the IP address is because if I used Goflex Home, the drives would show up upon reboot/login as unable to connect. When I use the IP address and reboot, the drives always disappear, even though they are set to reconnect at login.

net use M: "\\XXX.XX.X.X\External Drive\FreeAgent 2TB\DVD_Movies"

Then I saved the file to my desktop as "map M.bat"

I repeated the process for two other drives, creating separate files for each, "map V.bat" and "map T.bat".

I moved the files to the root of C: so it'd be easy to find.

I started the task scheduler.

General Tab:
Name: Map Network Drives
Security Options: Selected Run only when user is logged on.
Configure for: Windows 7, Windows Sever 2008 R2

Triggers Tab:
Begin the task: At log on
Settings: Any User
Advanced Settings:
Delay task for: 30 seconds

Actions: Start a program
Program/script: Browse to C:\map M.bat, Open.
Repeated the last three steps for map V.bat and map T.

Then I clicked "OK", found the task in the list, right clicked and clicked "Run" to test it out.

It works every time. I am not sure if it would work if the mapped drive showed up as disconnected, but when there is no drive showing up at all it fixes the problem.
My System SpecsSystem Spec
08 Aug 2013   #20

Windows 7 Ult, Windows 8.1 Pro,

This problem just seems to go on and on and on.

Windows 8 thread with more possible solutions hope it helps. :)
persistent network drive mappings not very persistent
My System SpecsSystem Spec

 Mapped Drive Not Connecting at Startup

Thread Tools

Similar help and support threads
Thread Forum
Mapped drives wont load on startup
Hey folks, Been researching all sorts of options but unable to find one that works. I have a synology NAS connected to a HP desktop and I recently installed a new Samsung SSD running Windows 7. Since doing so, the OS now loads so fast that the mapped drives do not load in time for my XBMC...
Network & Sharing
how to access to mapped drive from second pc
Hi, The situation is following: I have 2 PCs(computer01 and computer02) where I am an Administrator. On computer01, IT team with their credentials mapped drive to some share folder, like (Drive Z: is pointing to \\someserver\sharedrive). Is it possible somehow from computer02 to browse drive...
Network & Sharing
Slow wireless AD connecting to mapped drives
Hello, I have a new LT, that works great when connected to the LAN via ethernet cable. However, when connected to AD through wireless, the login to AD is not bad, but the connecting to the mapped drives takes a long time. A messgae comes up "Could not connect to all drives" and then the LT...
Network & Sharing
Mapped drive & USB drive letter conflict
I just built a new computer for work. Our server is mapped as letter F and this works unless I leave a USB card reader plugged in when I shut it down. On boot up one of the drives on the card reader gets assigned F and the mapped drive doesnt work. I then have to remove the card reader and...
Network & Sharing
Mapped Drives not Connecting
I've set up a dual boot with XP and 7. My mapped drives work fine under XP but on 7 they fail to reconnect at startup. I have made sure I ticked "Reconnect at startup" and I have switched on "Always wait for network at computer start up and logon" in Group Policies but still no good. Any...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:46.
Twitter Facebook Google+