Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No multicast (IGMP reports) on VPN connection

22 Jan 2010   #11
Nick More

Windows Vista
 
 

The netsh routing commands don't seem to work either on Vista or on 7.
The 'netsh interface ip show joins' displays the join.
This is the same on Vista and on 7

If i use a testprogram that joins on address 239.1.0.99, the netsh command displays:

E:\>netsh interface ip show joins
Interface 1: Loopback Pseudo-Interface 1
Scope References Last Address
---------- ---------- ---- ---------------------------------
0 3 Yes 239.255.255.250
Interface 32: TEST network VPN
Scope References Last Address
---------- ---------- ---- ---------------------------------
0 0 No 224.0.0.1
0 1 Yes 224.0.0.252
0 1 Yes 239.1.0.99
0 3 Yes 239.255.255.250
Interface 11: Local Area Connection
Scope References Last Address
---------- ---------- ---- ---------------------------------
0 0 Yes 224.0.0.1
0 1 Yes 224.0.0.252
0 3 Yes 239.255.255.250
Interface 13: TEST netwerk via kaart
Scope References Last Address
---------- ---------- ---- ---------------------------------
0 0 Yes 224.0.0.1


My System SpecsSystem Spec
.
22 Jan 2010   #12
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

Evidently the Microsoft VPN client just doesn't like multicast.

Have you tried a 3rd party VPN client like Shrewsoft?

http://www.shrew.net
My System SpecsSystem Spec
25 Jan 2010   #13
Nick More

Windows Vista
 
 

I did not try any other VPN client yet.
After a quick look at the documentation I must conclude that the 'shrew' client doesn't support PPTP. Nor does the Cisco VPN client. I don't know any 3rd party PPTP VPN client.
In the past a PPTP VPN connection was preferred since the application must receive with a latency as small as possible. I don't know what the effect on the latency will be if an other VPN protocol (L2TP of IpSec) is chosen. I might discuss this with an network expert.
At least i could try it to conclude if the muticast work.
My System SpecsSystem Spec
.

26 Jan 2010   #14
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

It may not be a bad idea to at least try another client running IPSec. I'm not a multicast expert and I'm quite surprised that Microsoft's W7 VPN has trouble with multicast.
My System SpecsSystem Spec
27 Apr 2010   #15
Nick More

Windows Vista
 
 

Microsoft solved the problem with hotfix http://support.microsoft.com/kb/981637
My System SpecsSystem Spec
27 Apr 2010   #16
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Nick More View Post
Microsoft solved the problem with hotfix http://support.microsoft.com/kb/981637
It figures there is a hotfix for this. If one person had this problem then so did thousands more, hence the hotfix. Thanks for reporting back in Nick More.
My System SpecsSystem Spec
Reply

 No multicast (IGMP reports) on VPN connection




Thread Tools




Similar help and support threads
Thread Forum
Do I need reliable multicast protocol?
What is reliable multicast protocol? Do I need it installed under the protocols of my network connections? Please do not link me to wikipedia since I already Googled about this and there aren't any direct answers to my question. Thanks.
Network & Sharing
DIR 615 reports link at 300Mbps, windows reports 150Mbps
Hello there, Recently setup my home wifi network, i had been noticing that my link speed to any device through my Dlink DIR 615 router, was always 65Mbps (as reported by the device), i searched around that i should set the channel width to 'auto 20/40mhz' to gain speed; however now that i did...
Network & Sharing
IGMP outbound filtering not working
I've got a Windows 2008 R2 server with Firewall with Advanced Security configured with an outbound rule configured, in all policies, to block all IGMP traffic. I've deleted all but this one rule from the outbound list. When I run software, on this host, that joins a multicast group, I still...
System Security
MULTICAST Problem
Hello everybody, please help me with my problem: I have problems with receiving multicast (IGMP) traffic - VLC is not able to see any multicast data stream. I have only Windows firewall and VLC is allowed in it. My roommate, who is connected to the same physical switch as me has no...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App