Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: no network access on 2nd nic

04 Jan 2010   #1
drowe

windows 7
 
 
no network access on 2nd nic

Have 2 nic's, 1 for internet and 1 for intranet. Internet works fine until I set up #2 with default gateway then I get a error message when leaving properties box. something about redundant default gateways. If I leave this in place #1 network stops working. I have tried to just setting #2 to auto both ip and gateway. I can't even ping the server. It doesn't leave the computer. I thought it was the nic card because i riped it out of the old computer and the driver wouldn't work for the W7. So I bought a new one that was compatible with W7. Nothing has worked. The problem is that this is not my computer it's my wifes, and she's not a happy camper. This set-up worked on the XP that was taken out of service and replaced with the Windows 7.


My System SpecsSystem Spec
.
04 Jan 2010   #2
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

The problem is you can't have two default gateways. Windows will get confused and not know which NIC to send internet traffic to.

I'd suggest keeping a default gateway on the NIC connected to the internet but take it off the intranet NIC. As long as the NIC on the intranet and all devices on it are on the same subnet, you shouldn't need a default gateway on that NIC.
My System SpecsSystem Spec
04 Jan 2010   #3
aem

Windows 7 Ultimate 64Bit
 
 

I would also try bridging the two NICs.
My System SpecsSystem Spec
.

05 Jan 2010   #4
RedBirdDad

W7 Ultimate 64bit W7 Premium 64bit W7 Premium 32bit WXP Home 32bit
 
 

Quote   Quote: Originally Posted by aem View Post
I would also try bridging the two NICs.
Not a bad idea!
My System SpecsSystem Spec
Reply

 no network access on 2nd nic




Thread Tools




Similar help and support threads
Thread Forum
How can I Access a Child Network From a Parent Network in Win7 64bit
I use a Comcast broadband gateway, say that this network is called 'Home'. Connected to the 'Home' LAN I have multiple PC's, a Wii, and a Linksys E2500 Router. Connected to the Linksys routers LAN I have 1 PC and 1 network storage device. I would like to map a network drive from a PC on the...
Network & Sharing
Unidentified network access No internet access in windows 7
I have had my laptop for around a year and a half now, I've never had one single issue. I moved into a new house in August with 4 different roommates, we all have windows computers, tablets, xboxs phones ect.. For 3 months my computer worked 100 percent never had an issue with the internet, and...
Network & Sharing
Custom screensaver file read access right, network access
Hi, I've creates my own custom screensaver (in Visual Studio 12 using WPF), which need access to network for check an weather and email check. I've settings saved in two files. First one is NotifyScreensaver.scr.config, where I've only url to server, from which I take weather informations....
Themes and Styles
Fresh install of Win7 *unidentified network/no network access*
I've freshly installed Windows 7 Enterprise 64 bit on my system that previously had Ubuntu installed, and prior to ubuntu had win7 ultimate installed. With the fresh install of win7, I receive an unidentified network/no network access issue. Heres a list of things ive tried: - reset the...
Network & Sharing
unidentified network, no network access, limited access
I have a brand new acer aspire notebook and I'm trying to connect to my airport extreme card built into my iMac desktop. The laptop sees the signal just fine, but it will not connect to the internet and I get "limited access". What can I do to connect?
Network & Sharing
Unidentified Network; No Network Access; Limited Access
I have a Dell Inspiron 1750 with Windows Home Premium x64. This problem began occurring on Thursday after my brother put his hard drive from his laptop which runs Vista, into my laptop. I figured it was a stupid idea, but he stayed home and I went to school that day. (His CMOS battery needs to be...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App