Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network usage causes high DPC Latency

05 May 2011   #71

Windows 7 Pro x64
Atheros AR5005 + Win7 = High DPC

Ive had this problem for years...never fixed it - i get 25% DPC Usage when I download on uTorrent OR web browser OR transfer files in or out of the laptop - its all to do with networking and ndis.sys driver - the fault lies with Microsoft, while I get 25% CPU usage it does not really affect my computer usage, although I dont play music or movies - it does dpike DPC CHECKER but not as much as ive seen some users on here, soon as I stop uTorrent or Download off web page it stops.. i installed XP SP2 on dualboot and the problem went away for me..

Acer 5051 Laptop
2Gb (2x1) 667Mhz RAM
1.8Ghz Dual-Core 1Mb L2-Cache
ATi Radeon X1100
120Gb 7200rpm drive
Atheros AR5005 54Mbps
Netgear DG834GT

I definitely think its windows 7 has a bug in the TCP Stack

My System SpecsSystem Spec
07 Jun 2012   #72

Windows 7 64-bit
Push: Found a solution on my machine

Lantency caused unacceptable audio dropouts on my machine. The pointers towards Intel were good.

This was one definite cause on my machine: The service

"intel desktop boards fsc application service".

If I disable this service, the dropouts are virtually gone!

The crackling noise I put down to heat (the system is very quiet at low fan speeds),
changing audio to CD quality helped here.

Hope this helps some.
My System SpecsSystem Spec
10 Jun 2012   #73

Windows 7 Ultimate x64

Hello guys,

(first of all sry for my English) i have the same problem here, high latency, when im using the internet. Until i'm using my comp offline there isn't problems, after i connect n try to download something, or turn on the uTorrent, spikes are comming. I tried almost everyting, new windows, new drivers, (Bios, chipset, lan...), i got a new lancard also. When installed it first time, it goes very well, but after a restart spikes appear again.

I downloaded that LatencyMon, and it says the problem is whit raspppoe.sys ! But i dont know what to do whit it, i tried to replace it, but it is protected and i cant change that.

This is really annoying now...

What should i do?
My System SpecsSystem Spec

21 Jul 2012   #74

windows 7 64-bit

So... has anyone found a legit fix for this? Cause my high latency spikes are network related too.

However heres my problem:

I ran latencymon and narrowed my problem down to ndis.sys which I knew was my ethernet card. However when I disabled my LAN card and used wifi instead then latency mon showed that USBPORT.sys started causing high latency spikes.

Disabled my wifi card and used my LAN card. Then I was back to getting high latency from ndis.sys and some TCP driver.

So basically no matter what I do, if I want to use the internet im going to get latency problems :l

Anyone know how to fix this? Im getting really fed up... Im starting to regret buying windows 7
My System SpecsSystem Spec
22 Jul 2012   #75


Sorry if this has been mentioned but after 3 pages I realized I dont want to read through more.

Please help, post your DPCLAT latency test results!

is a good guide for finding out which driver causes dpc latency problems. You can also check out a utility called latencymon.

Also I would try another intel inf driver. I can recommend and 9301021.

Please take care to do this:

My System SpecsSystem Spec
31 Jul 2012   #76

Windows 7 Ultimate x64

I've had similar problems like you guys.

The difference was that I experienced the problems during audio playback only when my ethernet cable was NOT plugged in!

After many things I tried, this helped:
  1. In Device Manager click View / Show hidden devices
  2. Under the Network adapters I could see a similar device ending with "VirtualBox Bridged Networking Driver Miniport" for every network device.
  3. I disabled all of them (ending with VirtualBox Bridged Networking Driver Miniport) and guess what This was THE ONLY thing that helped in my case (and I tried every suggestion on here).
  4. I also had "VirtualBox Host-Only Ethernet Adapter" disabled, but I'm not sure if this one needs to be disabled.
The down-side of this solution is that after leaving those devices disabled, when I plugged in the ethernet cable, I couldn't access internet. I tripple checked, if I have the legit network adapter enabled and it was. I also ran the windows troubleshooter, it didn't help.

So definitive solution - uninstalling VirtualBox. I needed it but clear sound without wired connection is what I need more...

I hope this will help to someone as well
My System SpecsSystem Spec
12 Sep 2012   #77

XP SP3 32bit, Vista SP2 RC Business 32bit, 7 Beta 1

Holy f. I have this problem as IRQ interrupts in Windows 8. Will f. with the config when I get home and let you guys know the result.

Never noticed this f. s. with Windows 7 though. f.

P.S. this f. piece of s. did not help either. f.

P.S. 2 netstat -nt this shows InHost instead of Offloaded so this may be the problem now.

The Interrupts appear when there is network traffic.
My System SpecsSystem Spec
08 Dec 2013   #78

Windows 7 64 bt Home Premium

I am running Windows 7 (64 bt).

I tracked the NDIS.SYS 6.20 Driver problem down to:

Atheros AR938X Wireless Network Adaptor.

If I disable it via Device Manager no more crackles and dropouts ! I am trying to find the correct advanced setting for the Atheros but as yet without success. I have spent hours looking and not a mention anywhere.

If anyone has the correct advance settings for the Atheros AR938X Wireless Network Adaptor please let me know.

Kind regards.
My System SpecsSystem Spec
25 May 2016   #79

Win10 64bit

Glad to see I am on windows 10 and this issue is still present. I have most of these fixes with no luck. I am going to try installing windows on a different ssd maybe and swapping out the CPU. If anyone has found out after all these year please share.
edit: using a 3.0 usb ethernet adapter helped a bit, but did not fix the issue.
My System SpecsSystem Spec
04 Jan 2018   #80

Windows 7 Ultimate x64

Just coming in to report that uninstalling Oracle VirtualBox fixed my problem. I didn't even have to reboot. Disabling the VirtualBox network adapters didn't work. It seems like it's injecting itself into the network stack, and having effects despite never running. I guess I'll just have to stick with VMware (which also has virtual network devices installed). I'm running uTorrent (on a drip right now) and running a GNU Wget script (which I did confirm was triggering the problem, then monitoring with DPC Latency Checker... and unlike earlier today, I haven't had a single red bar. mostly green...

and I spoke too soon. exactly as I type, I'm seeing a wave of red bars, and about 50/50 green vs yellow. Still, nothing like the mountains of constant red I was getting before. now it's smooth green across the board again.

Maybe there's something inherently wrong with how the Windows network stack interacts with certain chipsets/hardware/drivers. I have to assume that not everyone is having this problem.

So my advice? Look into some of the programs you're using. Anything that seems like it might inject itself into your network stack in some fashion? Antivirus/Firewall, virtual machines, hardware monitors... things that may need to operate on a lower level... things that need more than just "surface" network connectivity. A web browser is unlikely to be doing anything funny like this, but something like a VPN client, a packet sniffer or a DDoS bot (for example! tsk tsk) might be needing access to core network functions

Then again, maybe it's not even that complicated. Maybe the developers of certain software just haven't updated their code since they first cooked it up in the Windows XP days. VirtualBox is essentially proprietary abandonware scooped up by Oracle. I thought I'd give it an update before using it after a long break. There were no updates to be had.

for the record:
Windows 10 Pro 1703
motherboard: MSI P35 Platinum (MS-7345) {2007!}
CPU: Intel Core 2 Quad Q9450
GFX: GeForce GTX 750 Ti
RAM: 4x 2GB DDR2-400
chipsets: P35 & ICH9R
ethernet: Realtek PCIe GBE Family Controller (driver 10.10.714.2016)
USB bluetooth: Broadcom BCM20702
USB 3.0 card: Syba SY-PEX20140 (Etron chip) {piece of junk}
My System SpecsSystem Spec

 Network usage causes high DPC Latency

Thread Tools

Similar help and support threads
Thread Forum
Very high physical memory usage, no high usage programs running
Hello everyone, I've been having a very weird problem recently, in which I BELIEVE is involving high physical memory usage. Sometimes I will be doing things such as playing a game, or watching a stream, and my computer will run fine for a little while. But at random times, my computer will majorly...
Performance & Maintenance
High DPC/IR cpu from Network Usage
I have noticed when Iam downloading at full speed of 1.8MB/s on Wifi or LAN there is high DPC/IR (Deferred Procedure Calls and Interrupt Requests) CPU usage - and when transferring files in or out to USB hdd.. i sometimes get pops & clicks in audio too - the CPU is a Turion 1.8Ghz x2 with 1Mb L2...
Network & Sharing
High CPU usage, low fps, high latency.
Since Jan-Feb of this year I have encountered the following issue while trying to play games on my laptop. Abnormally High CPU Usage Extremely low FPS - After 5-20 Mins of play. Extremely High latency to servers - from 300 - 900 after 5 - 20 mins of play. The thing is all of these started 1...
Performance & Maintenance
Network Traffic Causing High CPU Usage
Hello. For the last week or so, my network traffic has seemed to be related to some pretty sever spikes in my CPU usage. These spikes are causing extreme stuttering in my music playback, freezing of my cursor, and other symptoms of a really laggy computer. This pretty much occurs whenever I use the...
General Discussion
High CPU usage while copying file over network
Hi, for some reasons, while copying a 13 gb file over the network (accessed from \\servername\e$\ to my C drive, the CPU usage is going close to 100%. When I look at task manager, I see System using more than 30% of the CPU, SMC.EXE is using between 15% and 18%... Does anyone have an idea...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:14.
Twitter Facebook Google+