Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: VPN "No Network Access", ipv4 not connected

18 Jan 2010   #1

VPN "No Network Access", ipv4 not connected

I set up vpn and it appears to be working, but can't access the network. I am getting the notify connected but ipv4/6 "no network access" message. Tried several different settings, fyi PPTP has been opened on the firewall. Any suggestions on how to get network access? Using native (no 3rd party software) ms PPTP to connect a win7 to a vista computer. thanks.

Attached Images
VPN "No Network Access", ipv4 not connected-vpn2.png 
My System SpecsSystem Spec
19 Jan 2010   #2


Got vpn working, but not with Microsoft. Went with hamachi vpn free version works on my vista as vpn server (sort of-guess its not a true server program for user since you go thru hamachi's servers) & windows 7 as client (its windows 7 tested). took 2 minutes to set up. Painless, amazing app. Firewall & router and multiple os's proved too much for ms pptp. I can even access my usb hard drive from 2000 miles away!!! So far no problems. Has anyone had any issues with hamachi? little concerned about privacy & security.

so easy to use. It open ports & takes care of all firewall bs. Just right click your vpn computer hit "browse" and you're in from anywhere in the world. (ip adresses whited out) for simplicity even beats anything i've seen on a mac.

Attached Images
VPN "No Network Access", ipv4 not connected-vpn4.jpg 
My System SpecsSystem Spec
19 Jan 2010   #3

Windows 7 Ultimate 64Bit

Thanks for the info.
My System SpecsSystem Spec

05 Nov 2010   #4

XP 32
Fixed it, heres how

I had this problem and went out and purchased a new lan card and it didnt work... plus i followed instructions from this site
updated vista, now ipv4 and ipv6 not connected - Tech Support Guy Forums

TCP/IP stack repair options for use with Vista or Window 7.

Start, All Programs\Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

In the command prompt window that opens, type type the following commands:

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

None of those worked, but heres what did!!! I found this out by myself...

AVG 2011 had a packet filter driver running and this stopped all internet access so showing those two IP4 and IP6 not connected. Once the check box for this filter driver was unticked and apply pressed, hey presto all net activity came back.

So what I would suggest is go into this place and untick any but the most essential drivers for your network card...

Control Panel, network and sharing centre, CHANGE ADAPTER SETTINGS

double click the adapter you appear to be using, ie your LAN card of your WIFI card

A window appears... click properties

A window appears witha tab "networking" and "the connection uses the following items..." Untick them all... and press ok...

Then go back into properties and reselect just these:



If you net is working... go back in and one by one click on those unticked boxes to renable and work out which ones is making the net go bye bye... and leave that one UNTICKED...

Then tick all of then except that one thats stopping your net.

Thats it. Good luck.

What ever is the one that is unticked still is probably a bad driver. Note its name and which software it seems to be connected to... like mine was AVG packet Filter Driver... and uninstall AVG and reinstall it... or in your case uninstall whatever software that driver came from... may be an antivirus or may be something else... and reinstall it. If it plays up, consider using a different piece of software made by someone else.

truthseekers.... a PC engineer!
My System SpecsSystem Spec
09 May 2011   #5

Windows 7 Home Premium x64

I know this is an old post, but I have this exact same problem. I setup VPN and get no ipv4 or ipv6 connectivity, my dialog box looks exactly like the one pictured in this thread. I tried the above posters solution of disabiling everything except the two services and it still did not work. I also tried it with windows firewall turned off, other than that I have no anti virus currently on the computer. I'm going through a Linksys E4200 router, if it makes a difference. However, the router has PTPP VPN pass through enabled and I port forwarded the 1723 and 47 ports to the correct PC.
My System SpecsSystem Spec
01 May 2013   #6

Windows 8 Professional x64

I'm having similar issues. I'm connected to it from my iPhone, and I have an IP address that I setup (range: - I can ping my iPhone (LTE connection) from my home computer, but no other traffic seems to be going back and forth.

The status window for the remote connection says that IPv4 connectivity is not connected and the duration is always 00:00:00. Send/received packages, compression, and errors are all at 0.

Any ideas?
My System SpecsSystem Spec

 VPN "No Network Access", ipv4 not connected

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 SP1 WiFi Fails "Limited Access/Not Connected" after update
I'm using a MBP mid 2012 15-inch non-retina running Windows 7 through BootCamp. I decided to update my installation to the SP1 and hence installed a few Windows essential updates. After the update, I realized that my WiFi failed to connect to any hotspot, although all were present in the...
Network & Sharing
Cable connected to modem, ipv6 no internet access ipv4 no network
Hello Guys, I've been searching for the past 2 days a solution, but nothing came up to work. Tried different things, nothing good yet. So I'm directly connected to a modem, cable, and well, my computer takes time to identify and then identifies it first a a public network (i was able to...
Network & Sharing
"No Network Access" and "Limited Connection/Connectivity" ?
Hey, I am really hoping someone can help me solve this problem, it's driving me up the wall! When I started using my computer this morning everything was fine, and then "no network access" kept appearing, along with "limited connection/connectivity". I would troubleshoot the problem, but then at...
Network & Sharing
Laptop losses internet access, but says "connected" to wireless router
I bought a Cisco Valet M10 wireless router a few days ago and I have been having issues where my laptop says that it is connected to network and it shows maximum strength signal, but underneath the network name it says "No internet access". I have already contacted Cisco several times and also HP,...
Network & Sharing
Settings changed? No IPv4 internet access & "Default Gateway N/A"
Hello! I have a Dell laptop, running Windows 7. Yesterday my cat walked across the keyboard and literally that very moment, my internet lost connection. It wasn't a case where she disabled the wireless capability by pressing the combination of fn and F2. The wireless is turned on, and is in...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:20.
Twitter Facebook