Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: My Book World Edition

30 Apr 2010   #11

Win 7 64

Windows 7, 64 bit - recognizes all my HW. So far so good. Except for the following: I have had problems with one of my My Books being slow to wake up, or respond after periods of inactivity. This results in apps and components of windows being unresponsive for extended periods, like 5 minutes max I waited. If I am patient the drive wakes up and everything starts to work again. But that is still pretty damn bad behavior.

Does anyone else think that their issues are related? Sometimes My Book has been missing when I started 7, turn the drive off and on physically it comes back, but again, might take quite some time to "wake up".

Forgot to mention, both my external drives are connected via eSata, not USB or FW.

My System SpecsSystem Spec
25 Jan 2011   #12

Windows 7 Home Premium 64-bit
Windows 7 Shutdown with MyBook NAS Online

I too was going nuts with my 64-bit Windows 7 freezing up on every attempted shutdown, if the MyBook World Edition II was powered up. Like Pejx72 (see earlier posting), I came to the conclusion that file system handling was causing the system to freeze as it waited for a shutdown acknowledgment from the MyBook which, of course, it was not going to get.

My particular MyBook appears only as a storage unit and a media device under the 'Network' tab in Windows Explorer. However, it also shows up in the "Disk Drive" category of the Device Manager window. I pulled up the context menu in Device Manager (right-click on the "MyBook World Edition Network Storage" entry) and selected "Disable" from the menu. At this point, Device Manager appeared to hang up, with the cursor stuck as an hourglass. I then went into the web page for the MyBook and powered it down, which freed up the hourglass in the Device Manager window.

After a reboot, the partitions on the MyBook are still accessible through the WD Discovery program and reconnect automatically in Windows Explorer. However, the disk has a "Disabled" status in Device Manager and my Windows shutdowns (Sleep, Hibernate, Shutdown or Restart) appear to be working normally.

My conclusion is that Windows was treating the MyBook as an internal drive, thanks to its entry in Device Manager, and this was causing the system to hang up when shutting down. I'll post here again if my solution doesn't stick. Interestingly, other computers who only accessed the network through WiFi did not appear to have the same shutdown problem. Perhaps this has to do with the sequence of shutdown activity, with WiFi going down before the file system tries to.
My System SpecsSystem Spec
10 Nov 2011   #13

Win 7 Pro x64
WD My Book - Unable to access drive

Just tonight I noticed I was unable to access my H: drive which is my WD My Book. This was of great concern to me as I back EVERYTHING up to it. It had been working perfectly fine just a few days ago.

The first thing I did was eject it, and plug it into another USB port. It came back, but I was still "denied access". I checked the Drive Manager and while it was showing as healthy, I was unable to check the properties of the drive after hitting Populate on the Volumes tab of the drive properties. It simply did nothing at all.

If I did the same on another drive it came up with the Backup, Defrag, Sharing, and all that other information. But NOTHING on the My Book.

I restarted and the problem still persisted. I have changed absolutely nothing on my computer in the past week and somehow this pest of a problem cropped up on it's own.

What I ended up doing and what ultimately worked was to go to the drive's security tab in properties and make myself the sole owner of the drive. Now everything is working just as before.

I have absolutely no idea how it changed it's owner to something that an administrator cannot even access, but it did and changing the owner back fixed the issue.
My System SpecsSystem Spec

06 Feb 2012   #14

Windows 7 Ultimate x64

Windows 7 Ultimate X64, My Book World Edition II Ethernet.

Discovery on network worked poorly, most of the time did not work. When I opened the link to the hard drive in Total Commander, it open an Explorer window, usually to the My Documents folder, rarely to the MBWE.

I used the ethernet hard drive at the office where it was set up for that network, on XP.

Browsing through the setup of the hard drive (using an internet browser and the hard drive's ip adress) I found the network settings and changed the network name to my current network name which was set up on my router (SSID).

It works perfectly now.

Hope this helps!
My System SpecsSystem Spec
27 Nov 2012   #15

Windows 7 Ultimate x64
Worked for me too.

Quote   Quote: Originally Posted by pejx72 View Post
For me, at least: From reading the various forum discussions on this I surmise that the Win 7 64 shutdown problems are caused by Windows waiting for the hard drive to respond that it is powering-down. Under the Network Tab of Windows Explorer, my Windows 64 setup seems to recognise the MyBook as a "Storage Device" and as a "Computer". The "Storage Device" element doesn't work properly, but the Computer one does (I can access all my MyBook directories from there - I also mapped them to Drive letters just in case...). This means the "Storage Device" is unnecessary, right? So I went to Device Manager and "Disabled" the MyBook as a Hard Drive. Since then everything has worked perfectly: No shutdown problems; constant visibility of the MyBook as a "Computer" on my home network. I guess all the issues were caused by a bad/wrong driver for the MyBook as a *Hard Drive*, and by preventing Windows 64 seeing it as a Hard Drive I have fixed my problems.

Let's see how long before it goes wrong again...

Let me know if this worked for anyone else?

I didn't have the shutdown problem.
WD Link could see my drive in the devices found window.
The Drive Map Section was completely blank.
As soon as I disabled "My Book Live Network Storage" in the disk drive section of device manager my shares appeared and I was able to access the drive.

Thanks for your help.
My System SpecsSystem Spec

 My Book World Edition

Thread Tools

Similar help and support threads
Thread Forum
WD My Book 2TB Gone
Greetings to all, My WD external HDD crashed couple of days before. I can't access it and the worst is the I have in it all my important files. Family photos and videos, everything. First opened the box and connect it on the motherboard as internal and started CHKDSK, but it's stucked at...
Hardware & Devices
My Book World
Hi i was just wondering if anyone knows if my book world external 1 TB device can be used as a external hard drive with a usb connection and not an internet one ? My Book World Edition that is the device i have and i want to connect it with a USB cable instead through a router , is it possible...
Hardware & Devices
My Book World Edition 1
my dad installed this on our network and i tried to access it. automatically, windows 7 tried to install the driver for it so that, obviously, it would work. but, it said something like "installation failed. more parts may be required" or something similar. so i decided to forget it. now, whenever...
Hardware & Devices
WD My Book World Edition - does it work in Seven ?
Hi, I can't install Mionet software to access the "blue rings". Has anyone solved it ? Thanks.
WD MY BOOK Premium Edition 1TB External
Above is configured for Raid 0 or stripping and is a 1 TB as opposed to two 500 GB. External works fine on Win 7 but the Raid software that allows you to configure does not work. Anyone else running this external disk?
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:35.
Twitter Facebook Google+