Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Transferring files from 7 to XP via SMB

25 Jan 2010   #1

Win 7 x64 Pro
Transferring files from 7 to XP via SMB

Since upgrading my machine here at work to Windows 7, I encounter a strange issue with transferring files to a Windows XP box.
For instance, I use a robocopy script to mirror my files. If I run it under Win 7, I get sporadic errors for some of the files that look like:

"2010/01/25 14:32:15 ERROR 64 (0x00000040) Copying [...whatever]
The network path is no longer available"

Sometime, the connection seems to recover and the transfer continues until
the next ERROR 64 occurs.

Note that this also happens when I use Windows Explorer to copy files, I also
get sporadically "The network path is no longer available"-errors.

I tested the connection with NetIO (UDP-bench) to make sure, there are no packet
drops due to physical problems.

I also tried various "compatiblity"-tweaks like the one described here:
Samba network share issue with Windows 7
unfortunately, no luck.

Strangely enough, a "pull-based" approach works, that is: if the XP box
initiates the transfer, everything works just fine.

Does anybody have some more ideas concering this issue?

My System SpecsSystem Spec
26 Jan 2010   #2


I have this exact problem and haven't been able to find a fix. I can pull files from XP machines onto this Win7 machine and can browse and stream from my network all day long with no problems at all.
My System SpecsSystem Spec
31 Jan 2010   #3


problem solved.... all i had to do was make sure flowcontrol matched, either enabled or disabled, on every computer. some reason win7 on this machine had it turned off.
My System SpecsSystem Spec

03 Feb 2010   #4

Win 7 x64 Pro

Doesn't work for me, unfortunately.
My System SpecsSystem Spec
06 Feb 2010   #5


spoke too soon.

it worked... then stopped working >.<

if i use something like radmin i can push files perfectly fine. the strangest and most annoying thing about this is if i boot into winxp there's no problems at all!
My System SpecsSystem Spec
10 Feb 2010   #6

Win 7 x64 Pro

Okay, I think I finally found a workaround:

Vista and 7 feature adaptive scaling of the TCP receive window. Some routers or other network devices don't work well with this feature. To disable it open a command shell with administrative rights and enter

netsh int tcp set global autotuninglevel=disabled

This can reduce the performance of the TCP/IP-stack but should improve compatibility.

See also Vista Auto-Tuning |
My System SpecsSystem Spec
10 Feb 2010   #7

Win 7 x64 Pro


netsh int tcp set global autotuninglevel=high

seems to work as well.
My System SpecsSystem Spec
11 Feb 2010   #8

Win7 Pro x64

I've got basically the same problem (using Windows 7 to move large files to or from XP fails), and disabling autotuning did not solve the issue. I've also tried updating both NIC drivers, rebooting both computers into safe mode with networking, disabling as much offloading as I can for both NICs, directly connecting the computers (with 2 different cables), setting LAN Manager authentication level to Send LM & NTLM, turning Network Discovery off, and turning off IPv6, QoS, Link-Layer Topology Discover Mapper I/O driver, and Link-Layer Topology Discovery Responder. Nothing seems to fix the problem.

I used Wireshark to do a capture of a failed transfer, but I have no idea what to make of the results. (Note that this capture was done after undoing most of the "fixes" I attempted above.)

Anyone have any ideas what might be causing my problem?
My System SpecsSystem Spec
12 Feb 2010   #9

Win 7 x64 Pro

Well, it helped in my case. Maybe you got a problem with similar symptoms but other causes.
My System SpecsSystem Spec

 Transferring files from 7 to XP via SMB

Thread Tools

Similar help and support threads
Thread Forum
Transferring WPL files from WMP too Foobar?
Currently have a large WPL playlist in WMP and wanted to transfer them over to Foobar,when i try and add it it says wpl unspupported,i have tried using wpl to mp3 convertor programs but not working,maybe its cause there is a couple hundred hours of music on the playlist,yet says the playlist is...
Sound & Audio
Lags while transferring files between HDD's
Hello! Bought a new rigg recently and i noticed when im watching a movie or playing music using spotify and transferring files between my HDD's the movie starts to lag same with the music. Cannot figure out why ? Anyone got any ideas ? //Karlsson
Hardware & Devices
Transferring files across LAN
I have 2 computers connected via my LAN. SYS1 AND SYS2 I think I have administrator privileges on both, but not sure. I can transfer some files/folders between them but not all. What do I have to do to allow file/folder transfer both ways? Thanks,
Network & Sharing
Transferring files
Hi,:confused: I have Windows Home Premium on my laptop and Windows Ultimate (both Windows) When I try to transfer files, I get a message that I do not have the proper authority. I know I have administrator authority on my desktop, but not sure of status on the laptop. What do I need to do to...
Network & Sharing
Help with transferring 32 files to 64 bit
I had Win 7 32 bit installed and just put 4GB of ram in to run 64 bit system. 1. How do I get some, like favorites, programs from Windows.old 32bit over to the new 64 bit OS? 2. Once this is done can I or should I delete windows.old 3. I notice that I have Prorgram Files and Program File (86)...
Installation & Setup
Need Help Transferring Files Via Wifi
Hello every one... i am a bit new bie in this matter... i installed windows 7 7100 32bit on my desktop Pc and 7100 64bit on my laptop... i have D-Link Wireless Router... Now I have successfully connected laptop from desktop pc via wifi...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App