Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: can't use any p2p program

27 Jan 2010   #1

Windows 7 Ultimate Build 7600
can't use any p2p program

Recently, I cannot use any of my p2p program. I've tried different program, but they all have the same problem. I've used Limewire, and Bittorent.

I've also installed Norton Internet Security 2010, and I know that it takes over my Windows firewall. Does this have something to do with my connection using p2p program? I cannot connect to Limewire, and I cannot even download anything using Bittorent.

Somebody have this problem before? I can use that for a ling time before, until now. I've done everything with NIS2010, I've set firewall setting, but it's just the same. Nothing happens, as it I don't have any connection to the internet.

My System SpecsSystem Spec
27 Jan 2010   #2

Operating System Microsoft Windows 7 Ultimate Build 7600

Hi MrPotato,

Check the status of your P2P clients under the Program Rules list in Smart Firewall settings. It should be set to ALLOW.

You may have to make manual rules for the needed ports to be open. For example, to open port 60966 then make a new rule as follows:

Go to (in NIS2010) Settings > Internet Settings > Smart Firewall > Advanced Settings > General Rules > Add.
Select ADD and next.
Select "to and from" and next.
Select "any computer" and next.
Select "TCP and UDP" and "Only the ports and ....." and "Add".
Select "Individual ports", select "Local" and type in 60966" and click OK.
Click Next, Next, type in a rule name and click Next.
Click "Finish"

Select the new rule you just made from the list of general rules and move it to the top of the rules list by clicking on "Move Up" until it is the first on on the list. This will apply this rule before any other rules.

Hope this helps.

PS. Please remember the unauthorized downloading of copyrighted material is illegal!

My System SpecsSystem Spec
27 Jan 2010   #3

Windows 7 Home Premium x64

Have you disabled Norton and then tried to use bittorrent? Usually when a program is being blocked by the firewall it will give you a popup telling you so.
My System SpecsSystem Spec

28 Jan 2010   #4

Windows 7 Ultimate Build 7600

I've change the setting and disabled the antivirus, and still no results. I've reinstalled my bittorrent, and yet no change.

Why is this happening? I cannot connect to any peers, so how to download.
My System SpecsSystem Spec
28 Jan 2010   #5

Operating System Microsoft Windows 7 Ultimate Build 7600

Are you sure that port forwarding has not been blocked by your ISP?

Have a look at the following link to see if you can find the information relevant to your router ?

My System SpecsSystem Spec
28 Jan 2010   #6

Windows 7 Ultimate x64

just find the ports for your other P2P ports on the internet and all you have to do is the same thing with the others.....

Attached Thumbnails
can't use any p2p program-nis-settings.jpg   can't use any p2p program-nis-advance-settings.jpg   can't use any p2p program-general-rules.jpg   can't use any p2p program-add-ports.jpg  
Attached Images
can't use any p2p program-any-computer-.jpg can't use any p2p program-allow-rule.jpg 
My System SpecsSystem Spec

 can't use any p2p program

Thread Tools

Similar help and support threads
Thread Forum
Program Problem - Program won't open - No Error Messages
Ahhh back to the experts. I have a rather unusual, 'never happened before', problem. When I click on one particular shortcut either on the desktop or elsewhere it flashes real quick on the screen but does not open. The program is Webroot Window Washer which is no longer available nor is support....
Program installed in Program Files requires elevation?
I have a program that wanted to install in a document folder :mad: I have installed it in Program Files, but it requires elevation or it produces errors when running. I know I can tick the Run As ... box in the shortcut, but is there a better way, such as taking ownership of the install folder?
System Security
Program refusing to install in standard program files folder
I have an Advent (PC World brand) Laptop that comes with its own custom On-Screen Display software. The software is made for 32 bit Windows with no 64 bit version available as far as I'm aware. I have upgraded to 64 bit Windows recently and everything seems to work great except the OSD. ...
Creating an Elevated Program Shortcut for Search Everything Program.
I`ve done this successfully for SpeedFan, but I`m having a problem with doing the same for the Search Everything program. I`ve been through the tutorial steps several times now, the task executes successfully,( I checked it with command prompt box) but nothing happens. /c start "SpeedFan"...
Program icon pinned to taskbar not replaced by active program button
Until recently, whenever I opened a program by clicking on the program icon pinned to the taskbar, that icon was replaced by the active program button. This is the behavior I want in order to keep the taskbar uncluttered. However, I recently mistakenly unpinned an icon for Mozilla Thunderbird and...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App