Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: D-Link DIR655 won't connect to internet.

06 Feb 2010   #11

Windows 7 Ult, Windows 8.1 Pro,

Quote   Quote: Originally Posted by Black454 View Post
Quote   Quote: Originally Posted by chev65 View Post
Quote   Quote: Originally Posted by Black454 View Post
Went back and forth with the dlink support the last few days and still not connecting to the internet. Boxed it up and returned it and back to my old linksys and working great. I was wanting to use the Dir-655 because it has great reviews when using voip. I will have to keep looking for another router with good voip manners.
That's what firmware updates are for. There is a new one for the DIR-655 dated Jan/ 28/ 2010. It probably wasn't compatible with your modem for some reason. That router works perfectly for me and is still one of the best on the market.

One of the problems fixed with a recent firmware update dated 7/20/09 > Fix when disable DHCP server and enable DHCP server, LAN PC cannot get IP.

Which I believe relates to the problem you seemed to be having.

Just to test, I just updated my DIR-655 using the latest firmware, I also saved my set up file by going to Tools/system and saving the set up file to my desktop.

The Firmware update went flawlessly and took about two minutes to complete. After that I went to tools/system and uploaded my setup file so that I didn't even need to redo my wireless setup. Just tested it out and my wireless laptop connected up as usual, no problems at all.

Actually I did my research before buying this router and saw firmware 1.33 was available. The first thing I did when I unpacked the router was update the firmware and it went flawlessly as well.

Thats good your router works fine for you. For some reason the one I had did not want to get an ip from my isp no matter what.
That is strange indeed, it was either just a bad router "very unlikely" or your ISP's modem or internet service wasn't compatible "more likely but very strange". I'm not sure if that router has to use broadband for a connection or not but it sure works well for me. :)

My System SpecsSystem Spec
07 Feb 2010   #12

Windows 7

Maybe it was a bad router who knows. The fact that when I removed the dlink router and put the linksys 160N back in place everyone worked as it should. I would say that rules out a p roblem with my modem or ISP. Also it is not a new internet service as I have had it for 4 years or more. I mentioned I have returned the router so I am not interested in trouble shooting it any further.
My System SpecsSystem Spec
07 Feb 2010   #13

Windows 7 Ultimate 64Bit

Nothing beat testing out stuff...thanks for getting back to us. :)
My System SpecsSystem Spec

07 Feb 2010   #14

Windows 7 Ult, Windows 8.1 Pro,

Seems like if the router was bad just replacing it with another would fix the problem. I'm pretty sure there was another problem involved here but unless the router is changed out for another one we can't know for sure what the actual problem was.
My System SpecsSystem Spec
21 Jan 2011   #15
N brown

winxp pro and win 7 64bit ultimate dual boot
Just thought I'd add..

I have a dual boot winxp win7 64bit ultimate and am wireless through Dlink AP and DIR-655 router. Widows 7 has no problems but Windows XP can't see the internet.

The firmware is up to date but this has been identified as a win 7 Homegroup issue from what I've read. Some are saying if you have a win7 homegroup setup no xp machines can see the internet. So thanks again MS for lack of foresight lol.

Can anyone confirm this? BTW I can connect to the network fine just no internet in xp.
My System SpecsSystem Spec

 D-Link DIR655 won't connect to internet.

Thread Tools

Similar help and support threads
Thread Forum
Can not connect to my NAS D-link DNS320 to map a drive
I have a D-link DNS320 NAS. For long there was no problem until recently I had a severe crash that extended through my backups and I had to do a full new windows installation (and new PC in the process) but for some reason win 7 (home prem 64/SP1) refuses to detect the NAS. It is detected on my...
Network & Sharing
Can't connect to wireless on D-Link DIR-600
Hi guys. Need your help with this. Since two days ago, I have not been able to connect through WiFi to my dlink router. The computer that's connected to the router through the lan cable is fine and able to connect to the internet. But when I try to connect my laptop wirelessly, it says...
Network & Sharing
TP-Link WN722N will not connect after sleep
Hi, I just bought a TP-link WN722N usb wireless N adapter, when I turn on the computer, the adapter can connect to the wireless network. However, when I sleep the computer then turn it on again, the usb adapter could not be found! How do I fix this?
Network & Sharing
Unable to connect through D-link router WBR-1510
Hello, I have a Lenovo, Windows 7 Home premium 32bit. McAfee controlling my firewall. Unable to connect to internet. Connects to my wireless network. Timewarner has given up since my other HP xp computer works. Router has problems but works OK with my HP and vonage devices. The router is...
Network & Sharing
Dlink dir655 xtreme compatibility w/windows 7
hi i recently upgraded frm windows 7 home premium to ultimate and now i cant connect to internet at all.. cant connect to wireless or connect or direclty frm my modem.. so i decided to install the driver from the DLINK CD .. and it gives me another error sayuing "error 101 no ethernet connection...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:18.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App