Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "no files have been found on this remote library"

12 Feb 2010   #1
sdjensen

Windows 7 Professional x64
 
 
"no files have been found on this remote library"

Hi,

I am trying to setup media sharing (music and photo) from my server to my laptop and my ps3. Both the laptop and the ps3 can see the shared library, but when I e.g. want to see the music files I get this message "no files have been found on this remote library". I have setup a homegroup and both the laptop and the server is a member of this homegroup. I set the steaming to "allow, units to play media files automatically" - I have disabled windows firewall in the setup face - could it be that I need to open for some port in my router?

SERVER is running windows 7 professional x86
LAPTOP is running windows 7 professional x64

what to do?


My System SpecsSystem Spec
.
15 Feb 2010   #2
sdjensen

Windows 7 Professional x64
 
 

I solved this issue and just wanted to share this with other that might have the same problem.

The reason why I could not see my files on my laptop and ps3 was due to the fact that I had added attached network drives into my library and not libraries on the local disk.
My System SpecsSystem Spec
02 Nov 2010   #3
Creeping Jesuz

Windows 7 Ultimate x64
 
 
Same error solved using workaround

I had the same error but it was related to the defualt sharing options. I had 3 computers sharing media with all devices on the network allowed. The devices could see each other sharing but the message "no files have been found on this remote library" displayed when tring to access them. Btw, these machines are all windows 7 with 1 being x64 and the other two being x86.

In the end I had to set the Customize settings for each device to "Make all of the media in my library available to this device" and selected "Only: Rated 1 star or higher" and then from within Media player on the other computer right click and "refresh" the device and it started working.
My System SpecsSystem Spec
.

07 Feb 2011   #4
vahnx

Windows 7 Ultimate x64
 
 

Confirmed, the above solution works. Very odd, I did not have to do that fix in previous Windows 7 installations. To clarify, click the Pearl (aka Start Menu) and type "Media Streaming Options". Launch the Control Panel item from the search and select Customize on only the devices you wish to share with. The one star rating or more applies to all songs, because by default they are all rated with a 3 in WMP.

Sorry for the "necro post" but this is one of the top Google searches and I feel it would be of value to validate the post above to give searchers more confidence on attempting the above solution.
My System SpecsSystem Spec
30 Apr 2011   #5
blushades

Windows 7 Professional x64
 
 

Confirmed to be a working solution for me as well. Definitely weird, hopefully this is a side effect of a patch and will be fixed soon.
Note, you can't change the default settings to this solution as it will revert back to 'All ratings'

Signed up just to post this
My System SpecsSystem Spec
Reply

 "no files have been found on this remote library"




Thread Tools




Similar help and support threads
Thread Forum
All Users Desktop Files "Not Found" (Dir *.*) in Elevated Cmd Prompt
Re: Windows 7, SP1, Home Premium, 64-bit When using Q-Dir, a 4-pane Windows Explorer replacement, I can manually move desktop files/icons between the all users a/c and my account. I created a batch file to do this, and it works fine when clicked from within Q-Dir. It does not, however work from...
General Discussion
Sony Vaio Win7 "Operating System Not Found" - missing data files
This is a client's pc. SONY VAIO All In One VPCL21AFX/B recvd a "Operating System Not Found" error msg when starting after normal shutdown rebooted w/o external devices, same error F8 didn't work F12 put it into a Sony repair menu Esc'd out to Win menu Command Line "bootrec.exe /fixmbr" -...
General Discussion
"Item not found" bug when moving or renaming files/folders
Hello, I just made an account here because this bug is seriously bugging me. It shows up whenever I move or create any new files/folders. I have googled the registry fix and that doesn't seem to be working. Is there any other known fix? P.S. There is nothing wrong with Waterfox.
General Discussion
"Resource protection found corrupt files..."
"but was unable to fix some of them." Ok, I have a machine that was hit by a root kit, that's all removed now, but it will not boot...gets a 0000007B BSD error so I start in repair mode which creates an X: ram disk to operate from. When I get to a command propmt and run the SFC with OFFLINE...
General Discussion
Files in "Documents" Library removed from folders
HELP!! I got tired of all the clutter in the "Documents" section of the Libraries. I created a new Library for my client files. I included a folder and many sub-folders from deep within the Documents library. It is working properly, the files and folders are now available in the new Library. ...
General Discussion
2nd internal hard drive wont appear "error: core library not found"
I have a problem with windows saying my 1TB WD HDD isnt there. When I boot my computer up i can see it on the boot menu, but when i log into my computer an error message pops up and says "error: core library not found", and my D: is gone. I boot off of a 64gb SSD. It also seems the problem is...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App