Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wireless USB adapter not working

16 Feb 2010   #1

Wireless USB adapter not working

Hi everyone,

I recently bought this adapter. Plugged the item into my desktop computer (specs: gigabyte p55m-ud2, Radeon 4890, Windows 7 32-bit) and it would automatically install the drivers, BUT that's all it would do. Then several minutes later it shoots me a popup saying:

"Windows found driver software for your device but encountered an error while attempting to install it. Asus 902.11n Network Adapter. This operation returned because the timeout period expired."

Well apparently even after saying there was an error, the driver installed anyways (or so I think) because when I check in network places the device showed up. BUT it says disabled. So I try and enable it. It goes from enabling... to enabled. BUT the device still shows up as disabled. I checked device manager, updated to latest driver, uninstalled driver, reinstalled. I even did a fresh install of Windows 7 and it still gave me the "timeout error". I might also add that whenever I plug in the adapter, everything is much slower. Shutdown hangs, startup hangs, opening programs hangs, etc. I had windows troubleshooter check and it gave me the following response:

"There might be a problem with the driver for the Wireless Network Connection adapter"

I looked this up on google and found no help.

Then I tried it on my laptop (Gateway P-6860fx) , and when I inserted the adapter, WOW it worked, everything was working fine., internet goes But I don't understand why it won't work on my desktop. The only reason I would think is the possible culprit is maybe....MAYBE driver or hardware conflicts. I'm not sure. Any input would be nice.

Also, I've heard about the kaspersky filter, but I don't have kaspersky on my computer and I've looked through the forum with no luck. Any input will be much appreciated. Thanks in advanced!

My System SpecsSystem Spec
16 Feb 2010   #2

Windows 7 Ultimate 64Bit

It looks like a USB port issue. Have you tried different ports? sounds trivial and i don't expect it to be a fix.
My System SpecsSystem Spec
16 Feb 2010   #3


Yes, I've tried alll the ports with the same results. Thanks for the suggestion though. Anything will help
My System SpecsSystem Spec


 Wireless USB adapter not working

Thread Tools

Similar help and support threads
Thread Forum
Wireless adapter not working
My computer will not even load the wireless adapter it says This device has been disabled by the wireless button and cannot be enabled from the Wireless Assistent and I looked and not even loading it up.
Network & Sharing
Wireless adapter not working
Hello, I need help! Two days ago my wife's computer would not connect to wireless networks anymore. It said that "No connections are available". It used to tell us to turn the switch in the front of the computer on, however it is on. (Now it will not troubleshoot, I receive an error during...
Network & Sharing
RDP not working with new wireless adapter...
I recently purchased a Tenda W311U wireless adapter for a machine in a second room. Plugged it in, Windows 7 loaded the drivers and it was good to go. I set it up to be an RDP server, was able to connect to it without issue. The only problem I had with the Tenda adapter was the range & power, so I...
Network & Sharing
Wireless Adapter not working
I have a Canyon CNP-WF511 that just will not work. It installed on Windows XP and ran fine but now windows now installs the drivers and thats it. Nothing else. The card doesn't appear on the list of network cards. Then though after a few restarts it asks for the drivers again. Also the card...
Hardware & Devices
wireless adapter not working
hello,, recently i've bought tp-link tl-wn721n wireless usn adapter.. dont know wether already install properly or not.. but i found wireless icon in said "Enabled".. when i tried to create adhoc...cannot.. what shud i do? is it this usb adapter can create network n access...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App