Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to print in WIndows xp printer.

11 Mar 2010   #1

windows 7
Unable to print in WIndows xp printer.


Please be informed that I have 1 Desktop running Windows xp and one laptop running Windows 7 Ultimate at home.

Files and printer sharing is enabled in both the system and I am able to share files and folders.

Desktop is connected with a Lexmark X 4270 printer with USB cable and the printer is working fine.

My Windows 7 laptop can 'see' the printer but when I try to print nothing happens.

I have gone through various tutorials and tried uninstall and reinstall of the printer.

I also tried to install the printer as Local printer ( eg. //desktop/Lexmark).
I have installed the latest available driver and the printer works fine if it is connected physically to any system.

but No matter how I try I am unable to share the printer.

This extra info may help you:

The printer is visible from windows 7.
I can even change the settings from Windows 7.
Print spoller is active and starts automatically in both system.
Files and folders sharing is working fine.
As I have installed both Windows xp and Windows 7 in my laptop, the shared printer works fine if I boot into Windows xp from it.

Now what can I do to make the shared printer also work with my Windows 7?
Help please

Jhambulal Agrawal

My System SpecsSystem Spec
11 Mar 2010   #2

Microsoft Community Contributor Award Recipient


Hello Jhambulal, welcome to the Seven Forums.

You could try if this works for you: HP LaserJet 5000 drivers?
Different printer but the same issue.

My System SpecsSystem Spec
11 Mar 2010   #3

windows 7
Thanks, but did not worked !

Thanks Kari,

I tried that way but didn't worked.

My 7 can see printer connected to Xp but can't 'handshake'. It seems it is installed but print command brings no result....

My System SpecsSystem Spec

12 Mar 2010   #4

windows 7
Is it driver conflict?

As I am still trying to figure out the solution and uninstalled all the printer driver from both system. Here is what I found:

1. If I only install the printer as network printer in windows 7, it works fine and I can print anything using it.

2. As soon as I installed the printer in my Windows 7 (physically connecting it with Windows 7) it stops working. ( Win 7 can still 'see' the printer,though)

3. If the printer is installed physically in Windows 7 and also as a network printer in the same laptop it stops working.

Any clue???
Any tech Guru??

Thanking in advance !

My System SpecsSystem Spec

 Unable to print in WIndows xp printer.

Thread Tools

Similar help and support threads
Thread Forum
Unable to print anytihing after installing pdf printer
My printer: Samsung M2026W My PDF-printers: Cute PDF Creator, Foxit Advanced PDF Editor I have a serious problem with printing. All my printers have previously worked fine. But after installing a pdf-printer Cute PDF Creator or Foxit Advanced PDF Editor, all printing attemps will fail. I...
Hardware & Devices
Printer not on print manager list but can print to it from aps
My usb attached printer is no longer listed in control panel PM. I want to set it as default but can't. Tried several suggestions in this forum but nothing worked. Thanks.
Hardware & Devices
Printer problems print button grayed out - test print page fails
Hi, I just purchased an used computer with Windows 7Home Premium x64, this is an HP Slimline s5610f. The problem that I have is with a Brother HL 2040 series printer. It gave me a really hard time to install the drivers that I downloaded from the Brother website I kept getting a "0x00000057" error...
Hardware & Devices
Laptop unable to print to networked printer
This has been around for some time, but I've yet to find a solution that works. My Set-up is: BT Home-Hub (up to 8 MBs Broadband connection with two ethernet ports and Wifi, telephone and USB) - port 1 connected to Vista PC - port 2 connected to 8 port Netgear switch. Netgear switch. - port 1...
Hardware & Devices
Unable to print "The printer has not yet responded, but the ..."
I am unable to print from any program. Printers seemed to be installed OK. When I select print, the program freezes and displays the message "The printer has not yet responded, but the Microsoft Office program may be able to proceed without printer information. Do you want to continue to wait...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:58.
Twitter Facebook Google+