Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Strange problem with LAN

16 Mar 2010   #1
rezelute

Windows 7 64-bit
 
 
Strange problem with LAN

Hi,
Everynow and then i start getting this strange LAN problem and im abit puzzled as to what is causing it - see image:
http://img219.imageshack.us/img219/1342/65295373.png
It seems that it picks up 2 LAN networks and then i can connect to the internet. The only way i can resolve this problem is by disconnecting the LAN (when i disconnect one of the above both disappear) then enabling LAN again and it connect straight away.
Anyone have any ideas why i am having this problem?


My System SpecsSystem Spec
.
16 Mar 2010   #2
Bill2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

My System SpecsSystem Spec
16 Mar 2010   #3
rezelute

Windows 7 64-bit
 
 

Hi Bill,
I read those posts and im still not very sure how to resolve this, im aware im deleting a default route (ROUTE DELETE 0.0.0.0) but i dont really understand why im doing this and what else to do after that ...
My System SpecsSystem Spec
.

16 Mar 2010   #4
rezelute

Windows 7 64-bit
 
 

Apparently this guy who has the exact same problem as me came up with a solution by disabling an Apple service running:
Fix No Internet Access in Windows 7 - Tildemark blogs

I will try this to see if i still get the problem and over time i will post back. In the meantime if anyone can agree/disagree with me on what i just posted let me know.
My System SpecsSystem Spec
16 Mar 2010   #5
HammerHead

win 7 X64 Ultimate SP1
 
 
Lan

Is it a dual Lan? If so are you using both. If your not using both, you could disable the empty one in device manager to see if that helps. Fill out you specs.
My System SpecsSystem Spec
16 Mar 2010   #6
rezelute

Windows 7 64-bit
 
 

Hi,
I do not have 2 LANS connected to my computer no. The other unknown network appears out of no where and this issue does not happen all the time it just seems random. If i disable the other LAN it also disables the other home LAN and therefor i have to go back into network connections and enable the LAN again for the internet to work(which also gets rid of the other LAN).
My System SpecsSystem Spec
16 Mar 2010   #7
Bill2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Run CMD as Administrator and type the following command.
"ROUTE DELETE 0.0.0.0" (without the quotes)

Open the "Network and Sharing Center". you can do this via control panel. Click on "Change Adapter Settings". Right click on your valid LAN, then click on properties. Then click on TCP/IPv4 and select properties.
Check "Obtain an IP address automatically" and "Obtain DNS server address automatically". (IF YOU GET YOUR IP DYNAMICALLY VIA DHCP)
Otherwise IF YOU MUST SPECIFY YOUR OWN IP ADDRESS
Choose an IP address for your "Local Area Connection"
Specify a network mask
Enter a default gateway IP address, this is the IP address of your Internet router
--------------------------------------------------------------------------------

The route delete command removes the default routes from all network interfaces so you have to reapply the necessary default routes to your interfaces.
My System SpecsSystem Spec
16 Mar 2010   #8
rezelute

Windows 7 64-bit
 
 

But what if "Obtain an IP address automatically" and "Obtain DNS server address automatically" are already set by default, does this mean that i only have to run the delete route command?
My System SpecsSystem Spec
16 Mar 2010   #9
kegobeer

Windows 7 Ultimate x64 SP1
 
 

Are you using wifi to connect to your router?
My System SpecsSystem Spec
16 Mar 2010   #10
rezelute

Windows 7 64-bit
 
 

No ive had to disable my wireless card temporarily since its incompatible with Windows 7 (driver issue). So the only thing connected is actually the 1 LAN wire.
My System SpecsSystem Spec
Reply

 Strange problem with LAN




Thread Tools




Similar help and support threads
Thread Forum
Very strange problem.
Hello I am new on this forum, and I have a problem. I don't really know how to describe it so i took some pictures of it. So as you can see, the gadget is not working. I have tried changing UAC or what it was, and it did not help. :( In the second attachment you can see the sound...
Customization
strange problem
sir, Im having 2048 X 1152 - 23 inch Dell LCD monitor.. the problem im facing is, only when im running windows media center, i cud see a narrow colour patch (flickering) in the extreme right of my screen... thn i reverted the media center to 1920 x 1080 pixels.. then i watched that the narrow...
Media Center
I'm having a very strange problem.
In advance, I apologize if this is not the proper place to post this. All of these problems happen all at once, after a few hours of use: 1.) My Recycle Bin will disappear upon emptying it. 2.) All of my folders contain invisible icons. Not all of them are invisible, but most of them. Those...
BSOD Help and Support
Strange RAM problem
I am running Windows 7 64 bit. It has been running great until today when it wouldn't boot. The Repair Disc wouldn't run and I thought that a BIOS flash I had done had gone wrong. I eventually did get it to boot but it wouldn't fully load. I decided to try removing RAM. I have 4gb in two...
General Discussion
strange problem
Hi, I got a real strange problem this time. Whenever i use an application that puts heavy load on my NIC and opens a lot of connection (e.g. torrent), my pc shuts down after a few hours (lets say 2 to 8 hours). It's like unplugging the power cable, no shutdown sequence, no bluescreen, it just...
Performance & Maintenance
Strange freezing problem and administrator problem
Hi all, I'm new on the forums. Best Windows 7 forums btw, have helped me a lot. So I'm having two different or same kind of problems. I really need help to solve these! Problem number one:I'm having a strange freezing problem. Sometimes randomly my desktop freezes. I can't right-click any...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App