Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow Internet on Windows 7 Notebook Only

24 Mar 2010   #1
MoneyAddyct

7 64-bit
 
 
Slow Internet on Windows 7 Notebook Only

Hello, I just bought an ASUS K60IJ today running 64-bit 7. I have another laptop running Vista. My problem is: the download speed and browsing (via wireless) on the new ASUS system is much slower than it is for my other laptop running Vista on the wireless. The difference is a download speed of 0.56megabits/second to 9.65megabits/second, respectively.

The first thing I tried to do was update the drivers for my ATHEROS AR9285 Wireless Network Adapter, listed in Device Manager. I went to the ATHEROS website, and they do not even show any drivers for Windows 7 network adapters. Additionally, I tried the support download page at ASUS, entered in all my system info, and none of the 6 suggested drivers listed under "wireless" were for an Atheros card.

My question is: Is there an updated driver for Windows 7 for the Atheros wireless adapter that I should be able to download? If not, can you think of any reason why I'd have such a discrepancy in internet? Thank you!


My System SpecsSystem Spec
.
24 Mar 2010   #2
cjf

Windows 7 Ultimate 64 bit
 
 

Hello MoneyAddict,

Verify first that you are connected to the proper wireless network in the Network and Sharing Center, you could be connected to the wrong wireless network.
My System SpecsSystem Spec
24 Mar 2010   #3
MoneyAddyct

7 64-bit
 
 

I am indeed connected to the right wireless network.
My System SpecsSystem Spec
.

24 Mar 2010   #4
MoneyAddyct

7 64-bit
 
 

Update:

If I hard-wire the ASUS machine, I get normal internet speed. ASUS says I have the latest wireless network adapter drivers and said it was a compatibility problem with my linksys router. Linksys said my router should be Windows 7 compatible and I shouldn't be having problems in a live-chat earlier (since my router is a few years old, she couldn't give me detailed troubleshooting information without charging me). She suggested I try different wireless channels. I tried 1, 6, 9, 11, and the problem still persists, so I set it back to 'auto'.

I'm kinda stuck at this point.
My System SpecsSystem Spec
24 Mar 2010   #5
YeYowYa

Windows 7/Vista/XP
 
 
Same problem with the Atheros AR9285 wireless

my new laptop is an HP however and it is not the lan, like you all non atheros computers are getting the correct speed, and the Upload for the computer in question is correct. My LAN computers all get 21 down and 3 up. the one with the Atheos is getting 1 down 3 up. this is unacceptable.
My System SpecsSystem Spec
24 Mar 2010   #6
YeYowYa

Windows 7/Vista/XP
 
 

Also Talked to Atheros and they said that the Computer Manufacture will be handling all Tech issues.
My System SpecsSystem Spec
24 Mar 2010   #7
MoneyAddyct

7 64-bit
 
 

I took my laptop to Best Buy and was able to connect to their wireless network at regular speeds. So I figured the problem must be with my Linksys WRT160N router. I spent an hour and a half on the phone with tech support and they couldn't figure out why this was happening. They reset the router, changed settings, etc. I have a friend coming over later who has Windows 7; if she can connect to my wireless with regular speed than I know it's the laptop and not the router. Right now, I still don't know.
My System SpecsSystem Spec
24 Mar 2010   #8
MoneyAddyct

7 64-bit
 
 

I bought a new router. Problem solved!
My System SpecsSystem Spec
24 Mar 2010   #9
Spidey1976

Windows 8.1 Professional x64
 
 

I have a D-Link Dir-655 and have had good luck with a Wii and 2 notebooks (one with 7 and one with XP)
My System SpecsSystem Spec
24 Mar 2010   #10
manhunter2826

Windows XP - Now Windows 7 Home Premium (64-bit).
 
 

Good to hear you got the issue sorted! My new HP laptop uses the identical Atheros in-built wireless adapter and no problems whatsoever.
My System SpecsSystem Spec
Reply

 Slow Internet on Windows 7 Notebook Only




Thread Tools




Similar help and support threads
Thread Forum
Notebook slow - changing focus, opening new windows...
Hi there, I did a clean boot(disabling startup items) a while ago and after reverting back to normal boot, my computer became pretty slow in doing certain things. I don't know if this has anything to do with my clean boot or if it was just coincidence that it happened then. Anyway, booting seems...
Performance & Maintenance
Notebook Is Slow While Connected To HDMI
Today my notebook Asus M50Vn suddenly started to behave weird. While it's connected to plasma via HDMI, everything starts to stutter a bit, which is very inconvenient in videos. It works like this: 0,5 s of fluid picture, 0,1 s of freeze, 0,5 s of fluid picture, and so on. Situation is the same...
Graphic Cards
acer notebook windows 7 lost internet connection
my 2007 acer aspire was taking a long time to open aurora i did a system restore with uniblue powersuite what i ended up with was no internet at all but internet sais its connected network sharing center indicates everything is running fine but my internet speed is 0 no internet connection local...
Network & Sharing
Internet slow on Windows 7
Ok so here is the problem, i installed a fresh copy on Windows 7 32-bit edition Build 7600 on my pc(previously i had XP) the problem is my internet DL speed is running really slow, i have a webstar dpx 120 cable modem and before on XP my DL speed was ~3-3,5mb/s no its just a mere ~700kb/s, i...
Network & Sharing
Windows slow internet
my problem is windows takes such a long time to load websites! can anyone tell me a setting that could be responsible for this?
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App