Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: UPNP connectivity between Win7 machines not reliable

30 Mar 2010   #1
dinki

Windows 7
 
 
UPNP connectivity between Win7 machines not reliable

Hey guys. I am having problems getting UPNP to work reliably on my windows 7 machines. I am running the PlayOn Media Server (PlayOn Digital Media Server | PlayOn) installed on one of my windows 7 machines (my office computer). Firewalls and AV are turned off on both machines. I am able to sometimes view the PlayOn server on the office computer from my home theatre PC (windows 7) but other times it doesn't show up or takes an awful long time to show up. I am using UPNPInspector (UPnP-Inspector - Coherence - a DLNA/UPnP Framework for the Digital Living - Trac) as a means of checking whether the HTPC machine can see the PlayOn Server on the office PC.

I'm using a D-Link DIR-628 router. Both machines are connected via wired ethernet. The router sometimes shows up in the list of UPNP devices but other times it doesn't show up at all. I'm not sure if this indicates anything or not. I have UPNP turned on on the router.

I ran the Internet Connectivity Evaluation Tool (Internet Connectivity Evaluation Tool) on both PCs and both showed that UPNP was supported on both.

This has been puzzling me for quite a long time. Every once in a while, everything works great for a short period of time. Usually, however, the HTPC machine can't even see the PlayOn server on the office PC.


Does anyone have any ideas on what I can do to troubleshoot further?


My System SpecsSystem Spec
.
30 Mar 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by dinki View Post
Hey guys. I am having problems getting UPNP to work reliably on my windows 7 machines. I am running the PlayOn Media Server (PlayOn Digital Media Server | PlayOn) installed on one of my windows 7 machines (my office computer). Firewalls and AV are turned off on both machines. I am able to sometimes view the PlayOn server on the office computer from my home theatre PC (windows 7) but other times it doesn't show up or takes an awful long time to show up. I am using UPNPInspector (UPnP-Inspector - Coherence - a DLNA/UPnP Framework for the Digital Living - Trac) as a means of checking whether the HTPC machine can see the PlayOn Server on the office PC.

I'm using a D-Link DIR-628 router. Both machines are connected via wired ethernet. The router sometimes shows up in the list of UPNP devices but other times it doesn't show up at all. I'm not sure if this indicates anything or not. I have UPNP turned on on the router.

I ran the Internet Connectivity Evaluation Tool (Internet Connectivity Evaluation Tool) on both PCs and both showed that UPNP was supported on both.

This has been puzzling me for quite a long time. Every once in a while, everything works great for a short period of time. Usually, however, the HTPC machine can't even see the PlayOn server on the office PC.


Does anyone have any ideas on what I can do to troubleshoot further?

Are you using homegroup and IPv6? some system have trouble with connectivity and stability using home group. You can verify if that is the problem by setting up a ne network connection using workgroup. if the problem stops you can disable IPv6 and kill homegroup

Good luck

Ken
My System SpecsSystem Spec
30 Mar 2010   #3
dinki

Windows 7
 
 

Thanks for the reply Ken.

I'm not sure. I do have a homegroup set up but I don't know anything about IPv6 . How do I go about setting up a workgroup? I've networked machines with win98 and XP but I think win7 set everything up automatically. Thanks again.

*EDIT* I figured out how to turn off homegroup (leave on both machines then stop services) and I disabled IPv6. Same problem. Do I need to reboot after disabling IPv6?
My System SpecsSystem Spec
.

31 Mar 2010   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by dinki View Post
Hey guys. I am having problems getting UPNP to work reliably on my windows 7 machines. I am running the PlayOn Media Server (PlayOn Digital Media Server | PlayOn) installed on one of my windows 7 machines (my office computer). Firewalls and AV are turned off on both machines. I am able to sometimes view the PlayOn server on the office computer from my home theatre PC (windows 7) but other times it doesn't show up or takes an awful long time to show up. I am using UPNPInspector (UPnP-Inspector - Coherence - a DLNA/UPnP Framework for the Digital Living - Trac) as a means of checking whether the HTPC machine can see the PlayOn Server on the office PC.

I'm using a D-Link DIR-628 router. Both machines are connected via wired ethernet. The router sometimes shows up in the list of UPNP devices but other times it doesn't show up at all. I'm not sure if this indicates anything or not. I have UPNP turned on on the router.

I ran the Internet Connectivity Evaluation Tool (Internet Connectivity Evaluation Tool) on both PCs and both showed that UPNP was supported on both.

This has been puzzling me for quite a long time. Every once in a while, everything works great for a short period of time. Usually, however, the HTPC machine can't even see the PlayOn server on the office PC.


Does anyone have any ideas on what I can do to troubleshoot further?
There is a good chance that one of your AV's or firewalls is causing this problem. Often times just disabling them isn't enough, sometimes you need to uninstall them completely. Homegroups is not causing this problem I can assure you.
My System SpecsSystem Spec
Reply

 UPNP connectivity between Win7 machines not reliable




Thread Tools




Similar help and support threads
Thread Forum
Upgrade 200 XP machines to Win7 Pro
I am about to upgrade around 200 XP machines (laptop and desktops) to Windows 7 Pro. I would love to hear some of the best options for this? Any suggestion would be much appreciated! Thanks.
Installation & Setup
BSOD on 3 of 4 Win7 Machines - Cause mrxsmb10.sys
I am getting a BSOD on 3 of 4 PC's in the office. This started occurring in early Feb. I have tried updated all the video drives and network drivers on the workstations and servers. Tried to run the hotfix related to mrxsmb10.sys (says update not necessary or something to that effect). This is...
BSOD Help and Support
Network load balancing 2 Win7 machines
We have 2 windows 7 machines and I would like to network load balance (NLB) them. Can I do it in anyway ? The reason why I cannot use windows 2008 R2 server ======================== 1) This is a development/test environment 2) This is in a corporate environment so we are only allowed to...
Network & Sharing
Same programs on Xp and Win7 machines, no Flac on win7?
I use mainly Winamp for audio and VLC for video. I have music that I've played on my XP machine transferred onto my Win7 Machine, and it won't play on the Win7 machine. To my knowledge Winamp and VLC both should have flac playback. Kinda curious as to what's going on. :(
Sound & Audio
Can you network with win7 and XP machines
I am having problems with connecting my new win 7 computer to my network (all of which are XP). I cannot access my network drive or for some strange reason Outlook. Any suggestions? thanks Brian
Network & Sharing
sharing files on a win7 machine with XP machines
When I share a folder from my windows 7 machine, my XP machines are unable to access those folders; I get NOT ACCESSIBLE errors, the only folder that works is USERS, which isn't a whole lot of use to me, as all my data is on another drive. The windows 7 machine is able to see all shared files and...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App